Android Tablets Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
83 Posts
Discussion Starter · #1 ·
OK I have this and it works but if more people try it we would have a better idea if it indeed consistently works. First I downloaded an app (free but can donate) called "wifi keep alive", you can read about it here Wi-Fi Keep Alive | Shantanu's Technophilic Musings, its available in the Market, open it and select "always on", click "advanced options", then enable "work around 3" and "work around 4", then select "Done." You can read about what the work arounds do if you press menu "up volume" and select "help".I based this on the 30 second wake time meaning the wifi should wake (turn green) with in 30 seconds and so far it has, nearly always 30 seconds precisely, kind of freaky.So if anyone tries this please let me know here, I'm kind of excited but you know how that can go.
 

·
Registered
Joined
·
666 Posts
I installed the Adhoc Enable posted in the forum, I includes an .apk and a few config files. After installing and running, I switched to Adhoc Mode, then Back to infra mode. My wifi has worked flawless ever since. Have you noticed if this apk Wi-Fi Keep Alive apk causes any standby issues? My standby is working correctly, no middle of the nite wakeups to find battery dead. I am hesitant to install anything that is a Keep Alive app, I want as few constantly running apks as possible. Please report if this causes any standby wake-up issues and maybe how much memory it takes while running.
 

·
Registered
Joined
·
83 Posts
Discussion Starter · #3 ·
[quote name='nchntrman;40448]I installed the Adhoc Enable posted in the forum' date=' I includes an .apk and a few config files. After installing and running, I switched to Adhoc Mode, then Back to infra mode. My wifi has worked flawless ever since. Have you noticed if this apk Wi-Fi Keep Alive apk causes any standby issues? My standby is working correctly, no middle of the nite wakeups to find battery dead. I am hesitant to install anything that is a Keep Alive app, I want as few constantly running apks as possible. Please report if this causes any standby wake-up issues and maybe how much memory it takes while running.[/QUOTE']I will. I just did this today so tonight Im going to leave it unplugged and put on sleep and see, then see if my wifi wakes up with in 30 sec. I did the Adhoc and it works to connect with my phone but my wifi will not wake if it is down for more then 20 minutes I would have to reboot to get wifi to begin or even start to scan again, pretty bad. I will see what the battery is like after tonights test. I think it turns off because when I let it sit the wifi takes 30 seconds or so to restart/reconnect, unless it is still running in the back ground. We will see.
 

·
Premium Member
Joined
·
2,338 Posts
Did you try Workaround 1, wi-fi lock?UPDATE: Workaround 1 did the trick. I was getting the dreaded scanning loop/no connection after sleep once Market was hacked (via flash of roebeet's 8/12 FW mod). Mind you, unlike what it says on the tin, the wifi does go to sleep when the unit times out and/or is forced asleep via power-button toggle. However, it re-connects in under a minute now. I only tested this on a short sleep. I'll try it overnight and check back.Since I don't have the fix for the notification bar, if I slip and put the PDN to sleep when canceling a power-down to get control over the bar I pretty much have to reboot if I need wifi (who doesn't?). Now I got green lights! Nice find on this one.UPDATE 2: Let the unit sleep for 8 hours via timeout with only Workaround 1 (WiFi Lock) engaged. It came back instantly to Home Screen (not the lock screen which happens when I force sleep) and WiFi was connected within a minute or less. I'm running the 8/12 mod FW.Battery drain was significant, 25%-30%, but not unexpected since I had Background Data, eMail and Market Sync turned on throughout. That's acceptable for such a long sleep to me, and if I turn off the background stuff before sleep I'd expect much better battery performance. This is a good option until the Devs nail down PDN's quirky wifi issues.
 

·
Registered
Joined
·
83 Posts
Discussion Starter · #6 ·
[quote name='davidr;41089]Mark..sorry for the confusion.. when you say "Workaround 1' date=' wi-fi lock". what, specifically are you referring to? Is this the Wi Fi Keep Alive referred to above?[/QUOTE']It is for the "wifi keep alive" app.
 

·
Registered
Joined
·
83 Posts
[quote name='Mark Adams;40759]Did you try Workaround 1' date=' wi-fi lock?UPDATE: Workaround 1 did the trick. I was getting the dreaded scanning loop/no connection after sleep once Market was hacked (via flash of roebeet's 8/12 FW mod). Mind you, unlike what it says on the tin, the wifi does go to sleep when the unit times out and/or is forced asleep via power-button toggle. However, it re-connects in under a minute now. I only tested this on a short sleep. I'll try it overnight and check back.Since I don't have the fix for the notification bar, if I slip and put the PDN to sleep when canceling a power-down to get control over the bar I pretty much have to reboot if I need wifi (who doesn't?). Now I got green lights! Nice find on this one.UPDATE 2: Let the unit sleep for 8 hours via timeout with only Workaround 1 (WiFi Lock) engaged. It came back instantly to Home Screen (not the lock screen which happens when I force sleep) and WiFi was connected within a minute or less. I'm running the 8/12 mod FW.Battery drain was significant, 25%-30%, but not unexpected since I had Background Data, eMail and Market Sync turned on throughout. That's acceptable for such a long sleep to me, and if I turn off the background stuff before sleep I'd expect much better battery performance. This is a good option until the Devs nail down PDN's quirky wifi issues.[/QUOTE']I also am using roebeet's 8/12 FW mod, but it seems that perhaps my wifi non wake issue is more severe I even have a "quick reboot" app on my desktop. I have tried the work around 1 but my wifi just wont wake up, I will turn wifi on and off and it wont even scan and any wifi networks that I have used such as my home network just reads "out of range", very annoying. Work around 2 and 3 together seems to work for me as long as I leave wifi always on, if I force sleep it with the power key or if it just time out the wifi will come back on under a minute. But I have a problem when I purposefully turn off wifi to read a book (to save battery), if I read too long for an hour I cannot get wifi to turn back on I get the dreaded "out of range" with no scanning at all so I have to reboot, hence the "quick reboot" app. I am still trying but I have to say this is the best so far till like you say a dev will fix this. Still love my PDN.I will try your way again with work around 1 just to see you never know thanks.
 

·
Registered
Joined
·
4 Posts
Is this still working for those of you who have tried it? My last two peeves are wifi reconnection and FC messages on rotate to landscape. Looks like clockworx has fixed the rotate issue (although I haven't had time to try it yet), and I wonder if that will enable me to put it in its stand landscape-style, which supposedly helps with wifi.
 

·
Registered
Joined
·
83 Posts
Discussion Starter · #9 ·
I did the rotate fix and WHAT A BLESSING!!!! Works great and my PDN sleeps really well. But I have use the systempanellite.apk to turn off google core running items now my PDN doesn't wake up to check things. Working great.
 

·
Premium Member
Joined
·
2,338 Posts
It could be the placebo effect, I haven't done a truly empirical analysis ... but ... Rotate Fix sure seems like it helped out the WiFi reconnect after sleep issue. I still have WiFi KeepAlive going (workaround 2 & 3 right now) but WiFi hasn't pissed me off since applying the Full 360.
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top