Android Tablets Forum banner
1 - 20 of 85 Posts

·
Premium Member
Joined
·
2,216 Posts
Discussion Starter · #1 ·
Some people are having trouble getting the ADB working so they can get the hack up and running. Let's have some SHORT, DESCRIPTIVE posts about what you have tried and what output you got. It will help to know what directories you're putting things in, specifically adb.exe, the inf file acting as the driver, and, if you're using nate's files, the directory those files are in. I will delete "me too" posts, because that does nothing to help us help you.A few things - the device has to be ON to connect with the ADB. Also, you can tell if you're connected by typing [adb devices] at the dos prompt. If it doesn't list the device, you're not connected.
 

·
Registered
Joined
·
2 Posts
I switched the MicroSD card in the device and started it back up. Plugged it back into the PC and now I get Device Not Found when attempting to run Nate's hack. Also 2 drives show up in Windows Explorer. One is the SDCard on the top of the device and the other shows as a drive letter, but doesn't recognise. Any ideas? Do i need to rename anything? I've already tried a factory reset, which does work, but i still cannot see the device.
 

·
Registered
Joined
·
87 Posts
[quote name='johncr131;22177]I switched the MicroSD card in the device and started it back up. Plugged it back into the PC and now I get Device Not Found when attempting to run Nate's hack. Also 2 drives show up in Windows Explorer. One is the SDCard on the top of the device and the other shows as a drive letter' date=' but doesn't recognise. Any ideas? Do i need to rename anything? I've already tried a factory reset, which does work, but i still cannot see the device.[/QUOTE'] Sounds like a problem with the new microSD card. How did you prepare it?
 

·
Premium Member
Joined
·
2,216 Posts
Discussion Starter · #4 ·
My previous response didn't post...once you do the hack, you shouldn't have to do it again, and the sdcard shouldn't matter. Did you try copying the files over to the new sdcard?
 

·
Registered
Joined
·
66 Posts
When I try this I get an error message stating that "One of the USB devices has malfunctioned and windows does not recognize it". I am then directed to the USB tree and when I click on the USB device am told that the device has no drivers. When I try to install drivers by going to the folder with the unzipped "Hack the Novel" files, the computer finds no driver. What is the name of the file so that I can direct the computer to the right one?Thanks
 

·
Registered
Joined
·
66 Posts
[quote name='Lockrob2000;22327]When I try this I get an error message stating that "One of the USB devices has malfunctioned and windows does not recognize it". I am then directed to the USB tree and when I click on the USB device am told that the device has no drivers. When I try to install drivers by going to the folder with the unzipped "Hack the Novel" files' date=' the computer finds no driver. What is the name of the file so that I can direct the computer to the right one?Thanks[/QUOTE']Also, I just connected with the Sys tools/Device Manager up and unknown device shows up in the USB controllers field, but it does not accept the android_winusb.inf item as a driver for the device.
 

·
Premium Member
Joined
·
2,216 Posts
Discussion Starter · #7 ·
this appears to be one of those mysterious changing device id problems. You are going to have to find out your device id and edit the .inf file. You should be able to get the device id in the unknown device properties window as I recall.Let us know exactly what changed from the last time it worked to the first time it didn't. I want to know why these device id's are changing.
 

·
Registered
Joined
·
66 Posts
OK- my device ID shows as USBVID_0000&PID_0000|6&2B021042&0&2..that is very different from the one in the file. Does the whole thing get pasted into the file (there are two locations for this that I see) or just part of it. Sorry if this seems like a dumb question, but...it can't be helped. I have limited knowledge of this.
 

·
Registered
Joined
·
66 Posts
I modified the file and it did not work. As far as changes, this is the first time I have tried this, so it has never worked. I put the unzipped files into a folder on the desktop and went from there, just can't get the computer (running XP) to see the file. I think I will try this on another of my computers.
 

·
Registered
Joined
·
143 Posts
My first device firmware dated 7/7 would freeze every time I tried to send any commands to the device over USB...updating my PDN to the 7/18 firmware fixed all of my problems and my Novel is rooted and I'm happy as can be.
 

·
Premium Member
Joined
·
2,216 Posts
Discussion Starter · #12 ·
64 bit windows and vista for some reason don't like adb much. It's like this all over the internet if you look (I did). We tweak until it works, basically.
 

·
Registered
Joined
·
2 Posts
I am a total noobie at this kind of stuff. Running Vista Home Premium 64 bit. Using instructions in "How to Hack the Novel" I successfully installed Nate's driver to my Novel, successfully hacked the volume buttons and successfully installed Panda Home. First try! When plugged into my computer, the novel shows up as PD_Novel (K:)Unfortunately, I have not had any luck installing apk's by Command Prompt. I get this error message - 'adb" is not recognized as an internal or external command, operable program or batch file.Where would I find the most comprehensive instructions for installing apps. I have looked through pages and pages of forum posts. Have not found a post title that seems to cover this. Would really appreciate some advice.
 

·
Registered
Joined
·
425 Posts
[quote name='DroidNewbie;22756]Is there a way to UNinstall some of these apps' date=' or delete some of the (not used) icons from the PandaHome screen?[/QUOTE'] There are a couple of ways to uninstall apps. The easiest that I've found is to use the Quick Uninstaller app. You can also uninstall from system settings (base, not the PDN settings). If you are using panda home just hit the menu button and click 'settings' in the menu at the bottom of the screen. As far as deleting icons, just press and hold until the app tab at the bottom of the screen changes to a trash can and drag the icon there. Also, on some apps when you hold the icon a circle opens in the middle of the screen with several actions that can be taken, one of which is delete.
 

·
Registered
Joined
·
425 Posts
[quote name='pamelamo;22883]I am a total noobie at this kind of stuff. Running Vista Home Premium 64 bit. Using instructions in "How to Hack the Novel" I successfully installed Nate's driver to my Novel' date=' successfully hacked the volume buttons and successfully installed Panda Home. First try! When plugged into my computer, the novel shows up as PD_Novel (K:)Unfortunately, I have not had any luck installing apk's by Command Prompt. I get this error message - 'adb" is not recognized as an internal or external command, operable program or batch file.Where would I find the most comprehensive instructions for installing apps. I have looked through pages and pages of forum posts. Have not found a post title that seems to cover this. Would really appreciate some advice.[/QUOTE'] If you want to use the command line to install apps, make sure that adb.exe is in the same directory as your .apk file. Also, you need to either add the path to adb to you windows path statement or run adb from the directory that adb is in. Personally, I'd recommend using App Installer on the PDN. Then all you need to do is put the .apk onto your SD card. App Installer searches the SD card for all .apk files and lists them for your to pick/install.
 

·
Registered
Joined
·
2 Posts
Thanks for all the help on the forum. I have now successfully modified my PDN and have installed several apps. Kindle and YouTube are working properly. Now off to find a Facebook app since it doesn't show up on the Panda Home menu for me. If I can do this - ANYONE can!
 

·
Registered
Joined
·
14 Posts
Wouldn't it mak a lot of sense to just run a bootable USB pen with a small linuxdistro and adb for when you need to use adb? These driver/deice not recognized problems are Windows only, after all.
 

·
Registered
Joined
·
23 Posts
Everything was fine until I tried to update Pandigital Firmware. When rebooting holding the vol. up & restart does not update firmware on reboot!After connecting usb and trying to install Apps, or trying to re-hack- always get "device not found' message. Running Windows 7 64bit, also tried Win XP machine- Still device not found, Able to read Pandigital drives and such but cannot use command line functions. Any way to revert to original Pandigital software and start over?Thanks!!
 
1 - 20 of 85 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top