Android Tablets Forum banner
1 - 14 of 14 Posts

·
Premium Member
Joined
·
1,062 Posts
Discussion Starter · #1 ·
Chuwi has released new firmware for the TIG (dated 12/16/13).

Changelog - "increased stability"

Note: this firmware is for TIG models with the following S/N #s:
V88 16G1130800001
V8816G2130800001

Chuwi DL link: http://pan.baidu.com/s/1OL1f

Google Drive mirror:https://drive.google.com/file/d/0B8U_zuXEtYujUWRMSERBQTBGT3M/edit?usp=sharing

Flashing Instructions:
1. DL rar
2. Unpack rar
3. See flashing instructions here (under Rockchip Flash Tool v1.7 section)

Please note any reviews or troubleshooting of this firmware release within this thread.

Thanks,

smithmal
 

·
Premium Member
Joined
·
1,062 Posts
Won't this firmware work with the original classic version as well?

I have a TIG and the S/N#s don't match with mine, I'm just confused.
As I understand it, Chuwi labels the TIG as the "v88" and labels the classic v88 as the "v88 Quad-Core" (when looking at their firmware release table here). I believe the TIG and the v88 have different screen controllers so I'm thinking you'd get a black screen when flashing this to a classic v88.

Chuwi seems to be all over the place with model numbers and hardware specs making the flashing process for us owners like "Russian Roulette." It would seem that they are constantly running out of hardware parts and swapping them out to different ones during production runs. Then they follow that up with a new firmware update, but the update is only for select models.

Can anyone verify that their TIG matches either of the S/N numbers noted above?

smithmal
 

·
Registered
Joined
·
47 Posts
As I understand it, Chuwi labels the TIG as the "v88" and labels the classic v88 as the "v88 Quad-Core" (when looking at their firmware release table here). I believe the TIG and the v88 have different screen controllers so I'm thinking you'd get a black screen when flashing this to a classic v88.

Chuwi seems to be all over the place with model numbers and hardware specs making the flashing process for us owners like "Russian Roulette." It would seem that they are constantly running out of hardware parts and swapping them out to different ones during production runs. Then they follow that up with a new firmware update, but the update is only for select models.

Can anyone verify that their TIG matches either of the S/N numbers noted above?

smithmal
Thanks smithmal for the clarification I get what you mean now. But then the thing is a have verified with the distributor from whom I purchased my TIG, confirmed with chuwi and assures me that the classic model and the TIG uses the same firmware, that was in Sept '13

OK here is what I think might be the case, the classic models and the TIG's that doesn't match the S/N noted above shares the same FW, that's why the previous official FW release was able to use in both models(classic & TIG) up until the TIG models which fuselage has the S/N noted above they are given a different FW because of different HW used.

So in my case, I have a TIG (S/N 16G2130700507) which do not match the S/N noted above, which means I definitely can't use the FW above but I'm able to use the previous version FW and lambstone's timeless ROMs that was also shared with the classic model. This is my understanding but please do correct me if I'm wrong

Edit: I must also note that I have not done any FW updating or flashing as of yet to my TIG, all the information I have gathered are from members post.
 

·
Registered
Joined
·
26 Posts
Guys my TIG matches the S/N numbers noted above. Tried flashing it but ended up bricking my TIG!!

Flash is successful but once it reboots, no logo, nothing, just a blank black screen! Worse still, I can't power off my TIG by holding the power button for 20 seconds or so. Its totally unresponsive! I finally had to open it up, desolder the battery from the unit to power it down, solder the battery back again, then got it to flash mode (vol up + power) and was able to flash firmware again.

I tried this 3 times and had the same results!! Finally reverted to OMA 5.3a...

Anybody else have any success with this firmware???
 

·
Registered
Joined
·
26 Posts
Guys my TIG matches the S/N numbers noted above. Tried flashing it but ended up bricking my TIG!!

Flash is successful but once it reboots, no logo, nothing, just a blank black screen! Worse still, I can't power off my TIG by holding the power button for 20 seconds or so. Its totally unresponsive! I finally had to open it up, desolder the battery from the unit to power it down, solder the battery back again, then got it to flash mode (vol up + power) and was able to flash firmware again.

I tried this 3 times and had the same results!! Finally reverted to OMA 5.3a...

Anybody else have any success with this firmware???
LOL, silly me... I realised that the firmware is for the 2nd generation of V88s, without the 'QUAD' in the S/N. Mine is the one with 'QUAD' in the S/N, although the S/N number matches... The way Chuwi names the different V88 and the revisions are confusing!!
 

·
Registered
Joined
·
4 Posts
I purchased a V88, with s/no V88 Quad16G2130801598 in September 2013.

As seen on attached photo, it shall be a TIG from color and website promotion listing.

Please advise which latest firmware suit to it. Read the above forum, may be the 2013_10_12 is the right one?

Thanks!
 

Attachments

·
Registered
Joined
·
21 Posts
I have a V88 Quad16G2130700629. I'm guessing I can't update to this? I have the previous 09/08/13 fw now installed and it's laggy and unusable.
 

·
Registered
Joined
·
4 Posts
Tried 2013_12_10 FW with risk, it worked on mine.
1.Freeze screen if touch during charging solved.
2.Multi screen function added
3.Screen sensitivity may have improved a little but still not good enough
Seen later fw released, sounds universal for Quad and non-Quad in serial no, will see other's opinion first.
 
1 - 14 of 14 Posts
Top