Android Tablets Forum banner
1 - 1 of 1 Posts

19 Posts
Hi all

I have a u20gt that was rooted prior to delivery from a UK seller. Recently the playstore was inaccessible, wifi wouldnt connect and google wouldnt sync. so my dad, who owns the tablet reset ot fac settings, and now its all chinese again.

It still has apk installer i believe from what chinese i can read, along with superuser.

I have read ALL the options on here but the jargon and use of files is really confusing me. I am quite adept at most tech stuff but this is ridiculous. surely its not this hard.

I have downloaded the superoneclick v 2.3.3 and tried those steps, along with the rk android tool v 1.35 but where is the installer wizard i am meant to find, on laptop or tablet??

I tried adding a new file .android to my home user files but wont allow

I cant install direct to the tablet as wont connect wirelessly

I can upload to sd card and try to install flash it there as cant read the chinese on the tablet

I have managed to tick usb debug mode, but when i attach usb to laptop, i then hold and press vol - insert usb otg host to tablet, remain holding vol - i get a dead android with red triangle for 60 sex then reboots back to chinese no change.

Please can a very simple step by step guide be uploaded, or can someone direct message me steps as to where i am going wrong?

To get back to English, click the settings icon then scroll down to the 12th icon down on the left (looks like an A in a square). Click that then the top item in the list on the right and you are in language selection. Scroll down to find English.

The process for firmware and for rooting is different.

To upgrade firmware, using the official Cube firmwares and the flash tool, try the following. First connect the USB to the PC then with the tablet OFF, press the volume switch on the side nearest to the power switch and plug the USB cable into the tablet. Keep holding the volume button until the PC recognises the tablet. I find this is enough, you don't need the power switch as well as volume. If you already have drivers installed, the tablet will show up in device manager as RK30 Device.

If you don't have the drivers, install them manually. They are located in the flash tool package (RKBatchTool1.5en ) in a folder called driver.

Install the drivers then disconnect the USB and do the same again (reconnect to PC using USB) to make sure that the PC recognises the tablet. If it shows up in Device Manager, now you are ready to try a firmware flash.

So disconnect the tablet again and open the flash tool RKBatchTool.exe then click the 3 dots at the far right on the line FW Path. Select the firmware you want to flash. Then connect the tablet using the same method as before and you should see a green box under connected devices. Then click the Restore button at the bottom and the flash will begin. It takes a few minutes and let the tablet reboot before you disconnect the USB.

It will be in chinese again afterwards with all the stock Cube firmwares.

If you are just wanting to root the device, you don't need to do all this.

For Android 4.0 use SuperOneClickv2.3.3-ShortFuse Modded. With the Tablet switched ON, connect USB to PC and make sure USB debugging is enabled in developer options. Then run SuperOneClick and press the Root button. If it doesn't work, try again.

For Android 4.1 use Bintry Root for JB (which I found on the XDA site). Same process as before, tablet ON, connect USB, USB debugging enabled and run the RunMe.bat file in the Bintry download. Then select option 1 and when asked and also select restore data on the Tablet when the option comes onto the screen. Let it reboot before discconnecting USB.
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.