Android Tablets Forum banner

Ugly hack to working market

71932 Views 290 Replies 76 Participants Last post by  william1853

Hi all, I found that the Market and Google Talk will work fine if you put in an Android ID yourself. Apparently that was the only issue.
For those of you who already have other android devices, you can get your android ID by doing the command.

1. X devices:adb shell sqlite3 /data/data/ "select * from meta";
2. X devices:adb shell sqlite3 /data/data/ "select * from meta";

You'll get a readout with a line that looks likeandroidId||27283232........38434 (a big number) That last number beginning after the bar is your android ID.
If you DONT have an Android device, you can create an Android ID on the 1.6 Emulator by following the directions here: How To Enable the Android Market in the Google Android Emulator - How-To Geek
and then running the 1.X adb code above to get your Android ID.

Once you have your Android ID, run this command with your novel connected (be sure the emulator is shut down and no other devices are connected)
adb shell sqlite3 /data/data/
"update meta set intvalue='ANDROID_ID_HERE' where name='androidId'"; where you've replaced ANDROID_ID_HERE with whatever your real Android ID is.
You can run the 2.X command above to ensure it worked. Reboot, and you should hopefully have working google talk and Market. (and no, you can't have mine)
See less See more
1 - 20 of 291 Posts
scmastertech said:
Works great thanks
Glad to hear it wasn't just me
I really couldn't believe that was all it took, I was expecting much more.
See less See more
nvrpayretail said:
I started up the 1.6 emulator and then ran the 1.x adb code above (from the SDK 'tools' directory') and all that is returned is "sqlite3: not found". Any ideas? By the way I've used Market fine from the emulator. Thanks folks.....
Try going to an adb shell and just running "sqlite3". I can't think of a good reason why it wouldn't work, it's part of the Android install.
nvrpayretail said:
It's really odd clockworx. Same problem running from the shell - even though I see the sqlite3.exe in the directory. Sigh.......
.exe? If you're running this in the adb shell, it shouldn't have a .exe.
mbkeller said:
Same thing here. Can't get the adb shell to find the sqlite3 command.
This is on the 1.6 emulator, correct? Try this:
(from Windows command prompt) adb shell(in adb shell #) cd /system/xbin(in adb shell #) ls you'll get a listing,

see if sqlite3 is listed there. If it is, you should be able to try changing the command to adb
shell /system/xbin/sqlite3 /data/data/ "select * from meta";
Can someone do this in a command window and post a screen shot of their window? The only thing I can think of is that there is some kind of miscommunication going on...
nvrpayretail said:
Here you go:
C:pandigitalhacksandroid-sdk_r06-windows>cd android-sdk-windowstools
C:pandigitalhacksandroid-sdk_r06-windowsandroid-sdk-windowstools>adb shell
# cd /system/xbincd /system/xbin
# lslsls: not found
# sqlitesqlitesqlite: not found#
I'm not sure why "ls" doesn't work, but the correct command is "sqlite3" (as opposed to "sqlite")
Justin Browning said:
I get a deviceId of 0. Obviously this will not work, as I have tried and it does not allow me access the market on the device. Any suggestions?
On where, the emulator? Wherever you're getting it from, the market must be up and running with your google account set up before you try this (sorry I forgot that detail, I was about to leave when typing my original post and kind of rushed it)
edit_text said:
I was able to get mine from the emu.I had to adb pull the accounts.db file then I was able to use the sqlite3.exe from the android tools to list the id.e_t
Cool, that will also work, I was just trying not to make things MORE complicated. Congrats on a working market!
Justin Browning said:
On the actual device I have not tried an emulator. So should/can I emulate a 2.0 device and use that deviceId on the PDN?
You need some kind of device with working market to get a valid android ID, either an android device or the emulator.
On the PD Novel, it will be zero until you fix it (with the valid android ID you get elsewhere).
I did mine with the 1.6 emulator image from the first post.
I guess I'll have to bundle up an android sdk for people to use....not sure why there are issues.
Alternately, you can pull off the accounts db file and use sqlite in windows, as edit_text did.
Maybe he'll be nice enough to make a list of the commands he used, but it should be pretty simple:
adb pull /data/data/ accounts.db "select * from meta";
nvrpayretail said:
That was just a typo on this run. sqlite3 does the same thing.
C:pandigitalhacksandroid-sdk_r06-windowsandroid-sdk-windowstools>adb shell
# cd /system/xbincd /system/xbin
# lslsls: not found
# sqlite3sqlite3sqlite3: not found#
You're running this against the emulator, correct? (No PD Novel or any other android device plugged in?). Try "./sqlite3" for that last line.....maybe the path in the shell is messed up, though I have no idea why it would be....
edit_text said:
That would pretty much be it just make sure the sqlite3 file is in the same directory as the accounts.dbOn a side note clockworx, the market seems to work. However, it fails anytime I try to download an app.e_t
That's the way it should work before the fix (failed download). Try running the 2.X adb command against your novel to be sure android id is set to whatever number you pulled. Also, did you reboot? A good test is to ensure google talk works. If it crashes on launch, the fix isn't working.
Justin Brownin said:
Followed the instructions to the letter and it worked!!! Thanks everybody. Now I just need to get Slacker Radio installed as I can't see it in the market. Anybody got an apk?
Try visiting with your browser. According to this ( that should work.
nvrpayretail said:
clockworx: Yes' definitely only have the emulator running. Had the same problem using ./sqlite3. For grins, I stopped the emulator and plugged in the PDN. Running the command again, just goes back to the command prompt - no error message. Very odd behavior. I think I've taken up more than enough of your time tonight. Not sure what to try next but I guess I'll pick up on this again tomorrow. Thanks for all of the help.
I didn't exactly follow the instructions on that page since I know the emulator pretty well. All I did was download the 1.6 SDK using the SDK Setup tool, and then go into "android-sdk-windowsplatformsandroid-4images" and overwrite system.img with the downloaded one that has market enabled. (Backup the original 1.6 system.img if you want to keep it for some reason). Then I made a new virtual device based off of 1.6 (since I had dropped the modded system.img into there), and got the market up and running.That is slightly less convoluted than the directions on that page, so maybe it's worth a shot?
dschoi said:
Thanks for the instruction. I am going try it tonight. By the way' date=' what are steps after 11? How can I go to market place? Is Market app installed automatically? It is a bit unclear what will happend after successfully putting the id into Novel. Many thanks!
You need to have my google experience alpha pack up and running (with your google account set up) before doing this. The market is part of that pack.
JamesDroid said:
I think what he said was' date=' once you have created an account ID, you can then add it to your slate and continue to configure it from there once the Market app is installed, right?
yes, that's correct. The Novel can't generate a working android ID due to lack of SIM, so this is a workaround that succeeds by generating the Android ID elsewhere and moving it to the Novel.
edit_text said:
I'm not sure if you are aware clockworx. When using your Google Experience pack, I am unable to use setCPU. The Novel reboots whenever I load up setCPU. Any ideas?e_t
I can't think of any really good reason....the pack is almost all apps and libraries. My best guess would be that maybe SetCPU tries to do something different in 2.1 vs 2.0 and the fact that GEv1 has to "fake" 2.1 to work causes SetCPU to do something that should work in 2.1 but crashes in 2.0.
Some credit is definitely due to you, as you got me started looking into it from your thread.Congrats!
betolley said:
I have done this market place runs but when I tell to download I get an error ! in the bar at the top but nothing else. Any ideas?
Use the 2.X command in the first post to ensure your android ID on the PD Novel is not set to 0
1 - 20 of 291 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.