Android Tablets Forum banner
1 - 20 of 291 Posts

·
Registered
Joined
·
1,351 Posts
DON'T BOTHER WITH ANY OF THIS ANYMORE. GO HERE: http://www.slatedroid.com/showthread.php?t=4684

Hi all, I found that the Market and Google Talk will work fine if you put in an Android ID yourself. Apparently that was the only issue.
For those of you who already have other android devices, you can get your android ID by doing the command.

1. X devices:adb shell sqlite3 /data/data/com.google.android.googleapps/databases/accounts.db "select * from meta";
2. X devices:adb shell sqlite3 /data/data/com.google.android.googleapps/databases/gls.db "select * from meta";

You'll get a readout with a line that looks likeandroidId||27283232........38434 (a big number) That last number beginning after the bar is your android ID.
If you DONT have an Android device, you can create an Android ID on the 1.6 Emulator by following the directions here: How To Enable the Android Market in the Google Android Emulator - How-To Geek
and then running the 1.X adb code above to get your Android ID.

Once you have your Android ID, run this command with your novel connected (be sure the emulator is shut down and no other devices are connected)
adb shell sqlite3 /data/data/com.google.android.googleapps/databases/gls.db
"update meta set intvalue='ANDROID_ID_HERE' where name='androidId'"; where you've replaced ANDROID_ID_HERE with whatever your real Android ID is.
You can run the 2.X command above to ensure it worked. Reboot, and you should hopefully have working google talk and Market. (and no, you can't have mine)
 

·
Registered
Joined
·
425 Posts
I started up the 1.6 emulator and then ran the 1.x adb code above (from the SDK 'tools' directory') and all that is returned is "sqlite3: not found". Any ideas? By the way, I've used Market fine from the emulator. Thanks folks.....
 

·
Registered
Joined
·
1,351 Posts
nvrpayretail said:
I started up the 1.6 emulator and then ran the 1.x adb code above (from the SDK 'tools' directory') and all that is returned is "sqlite3: not found". Any ideas? By the way I've used Market fine from the emulator. Thanks folks.....
Try going to an adb shell and just running "sqlite3". I can't think of a good reason why it wouldn't work, it's part of the Android install.
 

·
Registered
Joined
·
425 Posts
OK, not sure where I'm going wrong. I bring up a cmd prompt and type in adb shell. The shell starts. I type in sqlite3 and get not found. So I try clicking on sqlite3.exe using Windows Explorer and a cmd prompt window opens with sqlite3 started. So I put in the /data/data....... command and get "Error: near "/": syntax error". I know this has to be a dumb user problem, but I don't see where I'm going wrong.
 

·
Registered
Joined
·
1,351 Posts
mbkeller said:
Same thing here. Can't get the adb shell to find the sqlite3 command.
This is on the 1.6 emulator, correct? Try this:
(from Windows command prompt) adb shell(in adb shell #) cd /system/xbin(in adb shell #) ls you'll get a listing,

see if sqlite3 is listed there. If it is, you should be able to try changing the command to adb
shell /system/xbin/sqlite3 /data/data/com.google.android.googleapps/databases/accounts.db "select * from meta";
 

·
Registered
Joined
·
6 Posts
Okay, I tried doing that. Whenever I type a command in the shell (#), it echos back at me, then goes to another # prompt (or if I enter ls, it adds "ls: not found" before going back to another prompt. The files I used are ones linked in the original post.
 

·
Registered
Joined
·
1,351 Posts
nvrpayretail said:
Here you go:
C:pandigitalhacksandroid-sdk_r06-windows>cd android-sdk-windowstools
C:pandigitalhacksandroid-sdk_r06-windowsandroid-sdk-windowstools>adb shell
# cd /system/xbincd /system/xbin
# lslsls: not found
# sqlitesqlitesqlite: not found#
I'm not sure why "ls" doesn't work, but the correct command is "sqlite3" (as opposed to "sqlite")
 

·
Registered
Joined
·
1,351 Posts
Justin Browning said:
I get a deviceId of 0. Obviously this will not work, as I have tried and it does not allow me access the market on the device. Any suggestions?
On where, the emulator? Wherever you're getting it from, the market must be up and running with your google account set up before you try this (sorry I forgot that detail, I was about to leave when typing my original post and kind of rushed it)
 
1 - 20 of 291 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top