Android Tablets Forum banner
1 - 20 of 33 Posts

·
Registered
Joined
·
125 Posts
Discussion Starter · #1 ·
I just modified the RT2870STA.dat file in PDN, as the Wifi chip in PDN is RT2870 (ralink).This file resides in /system/etc/WirelessOpen this file in "WordPad" or so and then edit the line:pSMode=MAX_PSPtoPSMode=CAM** This will keep the wifi in Constant awake mode. The only good I seen with this that now when the system comes up from sleep mode it reconnects a little faster now. Hope it will be useful ......There are other settings for Wifi there, so just playing with those.
 

·
Registered
Joined
·
125 Posts
Discussion Starter · #3 ·
jackbox;26877 said:
That's not ugly.
I thought it is as you have to get the file first from PDN to PC and then edit and put it back.But with this now I see the wifi connecting fast after bringing PDN back from sleep and connection is very stable.
 

·
Registered
Joined
·
125 Posts
Discussion Starter · #7 ·
jackbox;27019 said:
I am trying to do this but the adb pull is telling me that the file does not exist. Are you sure you got the path and file name correct in your post above?
Yes it is correct, I hope you are using this path: (Wireless is with UPPERCASE "W")/system/etc/Wireless
 

·
Registered
Joined
·
425 Posts
[quote name='enjoys1;27022]Yes it is correct' date=' I hope you are using this path: (Wireless is with UPPERCASE "W")/system/etc/Wireless[/QUOTE'] I'm having the same problem with the pull as jackbox. I first tried to edit the file directly on the PDN but it's in read only mode. Anyone know how to change it to rw?
 

·
Registered
Joined
·
3,286 Posts
adb pull /system/etc/Wireless/RT2870STA/RT2870STA.dat ./RT2870STA.datAnd as mentioned - use something like Wordpad, if you are a Windows user. Notepad might screw up the formatting. I personally like notepad++ on Windows, and it's free.
 

·
Registered
Joined
·
425 Posts
Don't know what changed (I hate when that happens) but now the pull is working. I edited the file but when I went to push it back to the PDN it error'd out due to the file being read only. I tried roebeet's recommendation but the first command fails with message "Usage: mount [-r] [-w] [-o options] [-t type] device directory".I hate it when I'm stupid :-(
 

·
Registered
Joined
·
125 Posts
Discussion Starter · #14 ·
nvrpayretail;27301 said:
Don't know what changed (I hate when that happens) but now the pull is working. I edited the file but when I went to push it back to the PDN it error'd out due to the file being read only. I tried roebeet's recommendation but the first command fails with message "Usage: mount [-r] [-w] [-o options] [-t type] device directory".I hate it when I'm stupid :-(
Try these:adb shell mount -o remount,rw -t yaffs2 /dev/block/mtdblock3 /adb shell chmod 755 /system/etc/Wireless/RT2870STA.datadb push ./RT2870.dat /system/etc/Wireless/RT2870STA/RT2870STA.dat
 

·
Registered
Joined
·
425 Posts
[quote name='enjoys1;27326]Try [URL=these:adb]these:adb[/URL] shell mount -o remount' date='rw -t yaffs2 /dev/block/mtdblock3 /adb shell chmod 755 /system/etc/Wireless/RT2870STA.datadb push ./RT2870.dat /system/etc/Wireless/RT2870STA/RT2870STA.dat[/QUOTE'] Thanks for your patience. Well, the mount command wasn't working but now it is! I'm copy/pasting so I know I didn't typo. But now the chmod command is returning this:Unable to chmod /system/etc/Wireless/RT2870STA/RT2870STA.dat: No such file or directoryI'm starting to think that android doesn't like me!
 

·
Registered
Joined
·
784 Posts
Geez, maybe you deleted it!Try this command: adb shell ls /system/etc/Wireless(ls is the equivalent of a ms-dos "dir" command. If the file is there, you should get the following reply on the next line: RT2870STA.dat If the file is no longer there, then just do theadb push ./RT2870.dat /system/etc/Wireless/RT2870STA/RT2870STA.dat to get it there!
 

·
Registered
Joined
·
425 Posts
[quote name='geebekazoo;27363]Geez' date=' maybe you deleted it!Try this command: adb shell ls /system/etc/Wireless(ls is the equivalent of a ms-dos "dir" command. If the file is there, you should get the following reply on the next line: RT2870STA.dat If the file is no longer there, then just do theadb push ./RT2870.dat /system/etc/Wireless/RT2870STA/RT2870STA.dat to get it there![/QUOTE'] It's definitely there - I can see it with ES File Explorer. But it's in read only mode and the push won't replace it. Sigh.........
 

·
Registered
Joined
·
784 Posts
Re-try the following: The chmod command that you were using (from post way above) has incorrect directory structure!!!!!!!!!adb shell mount -o remount,rw -t yaffs2 /dev/block/mtdblock3 /adb shell chmod 755 /system/etc/Wireless/RT2870STA/RT2870STA.datadb push ./RT2870.dat /system/etc/Wireless/RT2870STA/RT2870STA.dat
 

·
Registered
Joined
·
425 Posts
I had noticed the typo before. Took a little break, created a small .bat file and here's the results:M:pandigitalhacksHack-the-Novel1>adb shell mount -o remount,rw -t yaffs2 /dev/block/mtdblock3 /M:pandigitalhacksHack-the-Novel1>adb shell chmod 755 /system/etc/Wireless/RT2870STA/RT2870STA.datUnable to chmod /system/etc/Wireless/RT2870STA/RT2870STA.dat: Read-only file systemM:pandigitalhacksHack-the-Novel1>adb push ./RT2870STA.dat /system/etc/Wireless/RT2870STA/RT2870STA.datfailed to copy './RT2870STA.dat' to '/system/etc/Wireless/RT2870STA/RT2870STA.dat': Read-only file systemM:pandigitalhacksHack-the-Novel1>pausePress any key to continue . . .So it appears to me that the first command is not setting rw mode correctly. I was playing with syntax when you posted about the syntax error in the chmod command. I'm wondering if /dev/block/mtdblock3 / is the right location?????
 
1 - 20 of 33 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top