Android Tablets Forum banner
1 - 1 of 1 Posts

3 Posts
Discussion Starter · #1 ·
Hello all

I have a Versus Touchtab 10.1 dc. It stopped working recently. The tablet worked while plugged in but the battery wouldn't charge.

The first thing I did was to replace the battery. This seemed to be the most obvious solution. After two and a half months my replacement battery arrived from China. I soldered it in and turned the tablet on and hey presto! it was working. I plugged the charger in to give it a full charge and when I came back it was exactly as it had been before.

Next I read a thread on another forum which suggested it might be a faulty charging circuit. I ordered and received a MP1405 charging circuit. The forum talked about getting a smart charger and modifying it but it was for a higher voltage battery so this seemed like a better option.

I attached the circuit between the battery and main board. The battery charges, the tablet runs without the charger being plugged in. I thought the problem was solved.

However, as I was testing the tablet it cut out.

I have tried multiple times to determine why this is happening. I have found the problem occurs when an open app tries to do something. For instance; The "Aldiko" book reader app is open but when you click on a book to open it dies.

Plugging the chager in is all it takes to allow the power to flow again but if anyone has any ideas what may be causing the problem and how I might remedy it I would be very grateful
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.