Android Tablets Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
I have some video-files on my tablet that seems to be similar. Some of them can be played with HW decoding while others only play the sound when using HW decoding, but works if you switch to SW-decoding.
I'm not sure what the rules says about downloaded video, but that's how i got the files. (not sure if it's illegal to download videos here in Sweden anyway, but uploading should be illegal at least.)

the video-files are the same size, and when using programs to tell me what hides in the .avi-file they all seem so similar except for "writing application" and "writing library".
the files with FQM in the name is the ones that doesn't work with HW decoding. i've tried some episodes of both the big bang theory and thundercats, but none of them works. i've tried different players as well, MX video player, rockplayer, mobo video player (doesn't seem to do HW-decoding?), but none of them works.

the videos are 624x352 px, and when played in original size they don't look different between HW and SW. But when maximized to fill the screen the SW rendering looks quite bad, a bit choppy/blocky/aliased, while the HW rendering looks just fine.

i've included the detailed information about 3 different files, video 1&3 works, video2 with FQM in the name doesn't. they're exported from a program called mediainfo.

so, any ideas about what causes this behavior, and how to solve it? i guess i'll just stay away from the FQM-releases for now anyway.
 

Attachments

·
Registered
Joined
·
17 Posts
Well, the TLA file (obviously) was encoded with slightly different options. The FQM and ASAP files use H.263 quantization while the TLA file uses MPEG quantization.

The big question now is whether hardware decoding of the latter file is indeed impossible (which I don't know) or if it is just the player that doesn't delegate the decoding properly.

Which player(s) did you try?
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
...the files with FQM in the name is the ones that doesn't work with HW decoding...

... i've tried different players as well, MX video player, rockplayer, mobo video player (doesn't seem to do HW-decoding?), but none of them works.

i've included the detailed information about 3 different files, video 1&3 works, video2 with FQM in the name doesn't.
i haven't solved the problem, so i'm just avoiding FQM-files
 
1 - 3 of 3 Posts
Top