Android Tablets Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
5 Posts
I have been researching this device. It is rather expensive but it looks to be pretty high quality. Their touchscreen technology is really interesting in that it is supposed to have the best of both worlds (ie resistive and capacitive). The one thing I was wondering... the amlogic chipset doesn't have the best reputation for battery life. So I was wondering if someone who owns this device could possibly shed a little more detail on how long the battery lasts.

Cheers,

Roman

HTTP://topnotchtablets.com
I bought a SmartQ T10 early this July 2011 from here: Allpmp

  1. First, I coudn't make it fully charge. It charged only 50% after 3 days of active charging (I tried native 5V 2000 mA charger, 5V 1000 mA 220V-to-USB charger, and microUSB-to-USB cable using computer).
  2. Then one day it stopped booting, stuck on the white screen with SmartQ logo.
  3. I tried to re-install firmware (official 3.0 version) and failed: The device just turned off.
  4. Since then I can't turn it on ("Power" and "Power+Volume down" buttons don't work). I tried U-boot recovery, but nothing.

It's just dead now and won't boot, so very sad. I have tried to get some help from [email protected]
and my mail conversation with them is collected here: Support mail

I was also contacted by guy in Russia who have exactly the same problem as me and I actually copied the above scenario from him since it's identical with what I experienced.

Please let us know if anyone have any ideas or tips and tricks that could helpful for us.

P.S. I also keep online notes about my SmartQ T10 findings, here: Notes SmartQ T10

P.S.S. Smartdevices.com have now released a new firmware V3.5: SmartQ T10 Firmware V3.5

And this time they added information that the charger should be plugged during the upgrade and they even state the following:
otherwise the system will be damaged because of lack of electricity

It's not that it could be damaged it will be damaged!

So, they already knew that lack of electricity will brick SmartQ T10 and it will never boot again.

But our initial problem is that SmartQ T10 isn't charged in the first place, not even if we had it plugged in for several days, as described above.

It's just very sad
 
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top