Android Tablets Forum banner
1 - 20 of 28 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter · #1 ·
Having an issue this morning where the PDN simultaneously was not loading either the internal (PD_Novel) or external sd card.The external card is fine, and not defective, loading just fine with a card reader.But will not mount in the PDN no matter what. I've tried inserting it after boot, etc.And like I said, also effecting the internal SD Card.Any ideas? Or anything I can do vai adb to help diagnose this?
 

·
Premium Member
Joined
·
1,420 Posts
[quote name='jalandar2;38593]Since it doesn't just slide off' date=' I think it is safe to assume it is not meant to come off. In any event, if anyone has any advice short of disassembly, please let me know.[/QUOTE'] It's held with double stick tap to keep it secure. Yes, it is meant to come off. I wouldn't tell you that if it wasn't true. Take a look at some of the threads that mention changing the micro SDCard and you will see what I am talking about.
 

·
Registered
Joined
·
59 Posts
Discussion Starter · #9 ·
I should have been more clear. It is not intended to be user removed.And before I do that, and then void my warranty and ability to return it, I would rather try less intrusive measures if possible. So I am hoping someone has some other ideas, before I resort to that. If it comes to that, I'd rather return the damn thing.
 

·
Registered
Joined
·
425 Posts
[quote name='jalandar2;38597]I should have been more clear. It is not intended to be user removed.And before I do that' date=' and then void my warranty and ability to return it, I would rather try less intrusive measures if possible. So I am hoping someone has some other ideas, before I resort to that. If it comes to that, I'd rather return the damn thing.[/QUOTE'] Have you tried to flash it? I'm just wondering if it will see/read the SD card using the flash procedure. Use the copy with the mods and if it works you won't have to reinstall anything.
 

·
Premium Member
Joined
·
1,420 Posts
nvrpayretail;38603 said:
Have you tried to flash it? I'm just wondering if it will see/read the SD card using the flash procedure. Use the copy with the mods and if it works you won't have to reinstall anything.
Yeah, I already mentioned that but apparently he is not interested in that bit of advice.
 

·
Premium Member
Joined
·
1,420 Posts
[quote name='jalandar2;38597]I should have been more clear. It is not intended to be user removed.And before I do that' date=' and then void my warranty and ability to return it, I would rather try less intrusive measures if possible. So I am hoping someone has some other ideas, before I resort to that. If it comes to that, I'd rather return the damn thing.[/QUOTE'] Do you really think I would give advice that is designed to void your warranty? Give me a break. This has been done by multiple people on multiple devices that have been returned for one reason or another. No voiding of warranty.Anways, I'm done trying to help you as it has become obvious your not interested in my help.
 

·
Registered
Joined
·
59 Posts
Discussion Starter · #15 ·
Wow, attitude much?All I did was ask if there was anyone else with advice for me to try short of taking it apart, which I would prefer NOT to do, even if you seem to think it is a small matter. Why such an attitude about me not wanting to take my device apart as a first resort?
 

·
Registered
Joined
·
59 Posts
Discussion Starter · #16 ·
A note for how this finally got resolved.I tried updating the firmware with my original 16GB SD Card (which I had confirmed was working by checking on the computer, and is the card i've been using in this device since I bought it and had previously used to flash the device). Even after formating it (a few times)it failed each time.So I ordered a lower capacity 4GB card , which finally arrived today, mainly because I had seen others sometimes have problems flashing with higher capacity cards. I loaded the firmware on it, and it flashed fine. Read the internal sd and the new 4GB card fine. Put the 16GB card back in, and it had some initial issues (claimed the fs was damaged and needed to be formatted). So I once again formatted and it and checked the fs for errors, and put the card back in and it works fine now.Not sure which of the hacks caused the SD cards to stop being recognized. I see someone else had similar problems after beginning to do the hacks, and appears to have resolved it in a similar fashion as I did today.So for now it is working. I have applied the same hacks as I had previously, and still no problem, but then the device worked fine for a few days after the previous hacks were applied and then all of a sudden developed this issue. So if this happens again, I'll update this. I've also decided to not install as many apps this time around, I found I rarely used most of the ones I installed, and while I doubt any of them could have caused this....going with a more minimal approach certainly can't hurt.And Blazingwolf, truly, I meant no offense to you, I was merely trying to avoid taking my device apart, regardless of how simply it may be to do it. Of the 3 "low end" devices I have bought since I started playing with these gadgets (meaning <$200) the PD is the one I have enjoyed messing around with the most, and anytime you open up any device, no matter how careful, you do run additional risks, that I was just trying to avoid if it wasn't necessary (and in this case it wasn't).*shrug* Sometimes my tone doesn't always come across right in my postings, and so if I offended you when I was trying to explain why I didnt want to go that route, I do apologize. I was pretty certain it wouldn't be the fix because I had tried formating the external card to no avail already anyway, and turns out it wasn't the problem anyway.And now thanks to the instructions by nchntrman (and apparently roebeet for the inspiration) I am turning the 4GB card into a recovery card.
 

·
Registered
Joined
·
59 Posts
Well, now I think I have it....I did the fix for the nook app, since the firmware update reverted it, to rename the libpdfhost.so command, and the same thing happened.I reconnected the device, moved the original one back, did the rm -r /data/dal* and rebooted the device, and the cards were back.Edit: I've now tested this a few times, and it is doing it each time I make this change.Some more information: Renaming the file back and doing a remount causes an immediate recognition of the internal and external sd cards being recognized and loaded.
 

·
Registered
Joined
·
1,351 Posts
[quote name='jalandar2;40911]Well' date=' now I think I have it....I did the fix for the nook app, since the firmware update reverted it, to rename the libpdfhost.so command, and the same thing happened.I reconnected the device, moved the original one back, did the rm -r /data/dal* and rebooted the device, and the cards were back.Edit: I've now tested this a few times, and it is doing it each time I make this change.Some more information: Renaming the file back and doing a remount causes an immediate recognition of the internal and external sd cards being recognized and loaded.[/QUOTE'] Wow, that is really weird, I wonder what happened when they changed to 8/6. Guys doing the nook hack didn't report any issues on 7/24. I can't imagine them breaking stuff bad enough that changing the pdf library hosts would cause SD cards to break....ugh.
 

·
Registered
Joined
·
2 Posts
The Novels sold recently through Bed Bath and Beyond come with instructions for opening up your Novel to re seat the MicroSD card. Seems some come loose and cause issues so there is a step by step instruction of how to remove the back and re seat the card. So I hardly think that would void the warranty since they are telling you how to do it. It's an extremely simple process, I did it just to increase the size of the MicroSD and give me more internal memory. Blazingwolfs advice was spot on.
jalandar2;40789]A note for how this finally got resolved.I tried updating the firmware with my original 16GB SD Card (which I had confirmed was working by checking on the computer said:
someone else had similar problems[/URL] after beginning to do the hacks, and appears to have resolved it in a similar fashion as I did today.So for now it is working. I have applied the same hacks as I had previously, and still no problem, but then the device worked fine for a few days after the previous hacks were applied and then all of a sudden developed this issue. So if this happens again, I'll update this. I've also decided to not install as many apps this time around, I found I rarely used most of the ones I installed, and while I doubt any of them could have caused this....going with a more minimal approach certainly can't hurt.And Blazingwolf, truly, I meant no offense to you, I was merely trying to avoid taking my device apart, regardless of how simply it may be to do it. Of the 3 "low end" devices I have bought since I started playing with these gadgets (meaning <$200) the PD is the one I have enjoyed messing around with the most, and anytime you open up any device, no matter how careful, you do run additional risks, that I was just trying to avoid if it wasn't necessary (and in this case it wasn't).*shrug* Sometimes my tone doesn't always come across right in my postings, and so if I offended you when I was trying to explain why I didnt want to go that route, I do apologize. I was pretty certain it wouldn't be the fix because I had tried formating the external card to no avail already anyway, and turns out it wasn't the problem anyway.And now thanks to the instructions by nchntrman (and apparently roebeet for the inspiration) I am turning the 4GB card into a recovery card.
 
1 - 20 of 28 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top