Android Tablets Forum banner
1 - 16 of 16 Posts

·
Zenithink Tablet User / Information Transmitter
Joined
·
6,629 Posts
Zenithink released an Official ICS ROM for the ZT-283 C93 10.1" Tablet!

Zenithink's C93 ROM Download Webpage - http://www.zenithink...93.php?download
Zenithink's C93 0911 ICS ROM Download Link - http://www.zenithink..._0911_V1.23.zip

■Version: 10.1" C93 (1024MB+8GB) Android4.0 2012-09-11_H6_1f
■File Name: ZT283_H6_1f_1GB_Android4.0_0911_V1.23.zip
■File Size: 213MB
■Release Date: 2012-09-11
■MD5: 15dcd9955f5e7f1ace03b1336d429788
■SHA1: 018f750b792b9da74f7fe8b9da71a71f9edcd059
■Download Link: http://www.zenithink..._0911_V1.23.zip

Resource Update
Current version update:
This is the first firmware version for C93.

The method of firmware installation for this model
Using TF card
■First extract the firmware which you get or download, then copy the whole "zt-update" directory into the root directory of TF card.
■Put the TF card into TF card slot, then press the "Back" button at the same time to press the power-on button, then operate as per the reminders shown on the screen, the machine will be installed the firmware and then reboot.

Note: keep charged when the machine is being installed the firmware.
readme.txt:

2012-09-10
Just boot up while plugging AC adapter in

2012-08-23
change back key function

2012-08-09
boot up when capacity > 8% and ac in

2012-08-08
change mmc timeout count

2012-08-01
fix charge bug, When battery level is about 95%, disconnect chargeing the red LED still turn on.

2012-07-30
1. fix usb bug, When connecting the computer, the usb connection don't show unless insert a SD card
2. fix ethernet dones't work bug.
 

·
Registered
Joined
·
4 Posts
hi,

i did flashed this update, in recovery it said updating and stuff, and in google store i have it as a new device (so i guess it DID flashed), but in about i still have ICS.g04ref.20120614

i would not care much about this, just in changelog says
2012-07-30
2. fix ethernet dones't work bug.

and my problem is that ethernet still shows ethernet disconnected.

have tried different cables, switches, computer/laptops, always same error. if thats some help, on switch my led is going on-of and in circles when tablet connected.

tnx
 

·
Zenithink Tablet User / Information Transmitter
Joined
·
6,629 Posts
Discussion Starter · #3 ·
hi,

i did flashed this update, in recovery it said updating and stuff, and in google store i have it as a new device (so i guess it DID flashed), but in about i still have ICS.g04ref.20120614

i would not care much about this, just in changelog says
2012-07-30
2. fix ethernet dones't work bug.

and my problem is that ethernet still shows ethernet disconnected.

have tried different cables, switches, computer/laptops, always same error. if thats some help, on switch my led is going on-of and in circles when tablet connected.

tnx
Well if you look at the build.prop file in the system.patch.zt280.tar.bz file, you can see that it still has the build as ICS.g04ref.20120614, so that's fine (it won't change till the build.prop changes)....

Are you sure you plugged it into the ethernet port and not the usb port? Did you go into setting and turn wifi off and turn ethernet on?
 

·
Registered
Joined
·
4 Posts
Well if you look at the build.prop file in the system.patch.zt280.tar.bz file, you can see that it still has the build as ICS.g04ref.20120614, so that's fine (it won't change till the build.prop changes)....

Are you sure you plugged it into the ethernet port and not the usb port? Did you go into setting and turn wifi off and turn ethernet on?
thanks for the build.prop explanation


yes, i checket the port
i am not THAT strange with these. also tried turning wifi off and eth on, restarting with those settings. i had z102 before, and i know that trick. the only thing i havent tried is another mini usb-rj45 cable. is that just simply cable or does it have some electronics in it?
 

·
Zenithink Tablet User / Information Transmitter
Joined
·
6,629 Posts
Discussion Starter · #5 ·
thanks for the build.prop explanation


yes, i checket the port
i am not THAT strange with these. also tried turning wifi off and eth on, restarting with those settings. i had z102 before, and i know that trick. the only thing i havent tried is another mini usb-rj45 cable. is that just simply cable or does it have some electronics in it?
I'm not sure, all the Zenithink tablets I have use a micro usb ethernet port, not a mini like the C93 has... I think the micro one is just a cable....

Stupid question, have you tried resetting your router (or just turning it off and on) and trying it again? Or trying a different ethernet port on your router?
 

·
Registered
Joined
·
4 Posts
I'm not sure, all the Zenithink tablets I have use a micro usb ethernet port, not a mini like the C93 has... I think the micro one is just a cable....

Stupid question, have you tried resetting your router (or just turning it off and on) and trying it again? Or trying a different ethernet port on your router?
yes, tried different ports, different switch, even tried tablet to laptop and tablet to pc (different pcs and laptops) all combinations :-\
 

·
Zenithink Tablet User / Information Transmitter
Joined
·
6,629 Posts
yes, tried different ports, different switch, even tried tablet to laptop and tablet to pc (different pcs and laptops) all combinations :-\
I'm sorry, I am confused, what does your laptop or PC have to do with connecting the tablet to the internet via the ethernet? Shouldn't you have the ethernet cable go from your router or modem to the tablet directly? I guess I just don't understand your internet configuration/setup....

How did you get your Z102 to connect via ethernet? If you are doing the same for your C93, you may be right and just have a faulty mini usb ethernet adapter...
 

·
Registered
Joined
·
4 Posts
I'm sorry, I am confused, what does your laptop or PC have to do with connecting the tablet to the internet via the ethernet? Shouldn't you have the ethernet cable go from your router or modem to the tablet directly? I guess I just don't understand your internet configuration/setup....

How did you get your Z102 to connect via ethernet? If you are doing the same for your C93, you may be right and just have a faulty mini usb ethernet adapter...
it does not have to do nothing with the internet connection. but ethernet cable disconnected means there is no lan connection. now, if its connected to router, switch, laptop, pc .. eth connection is eth connection and its "disconnected". i was affraid its maybe faulty tablet, but i will take the mini usb adapter apart and see. thought maybe it has something to do with fw update.

thank you anyway
 

·
Zenithink Tablet User / Information Transmitter
Joined
·
6,629 Posts
Discussion Starter · #9 ·
it does not have to do nothing with the internet connection. but ethernet cable disconnected means there is no lan connection. now, if its connected to router, switch, laptop, pc .. eth connection is eth connection and its "disconnected". i was affraid its maybe faulty tablet, but i will take the mini usb adapter apart and see. thought maybe it has something to do with fw update.

thank you anyway
Did it work before the update?

Sorry, I thought I was helping, you probably wanted somebody that has the tablet and that's on the same ROM you are using to answer your questions, I'll shut up now....
 

·
Zenithink Tablet User / Information Transmitter
Joined
·
6,629 Posts
If anyone wants to try a similar ROM based on this 0911 ICS 4.0.3 ROM that I put together and am using on my tablet right now, with a 2GB data partition (1GB is taken from the media partition) and working USB GPS (for pl2303 chip), with some of Christian Troys mods, and fixed some stuff that didn't seem to be working for me, I uploaded it to MediaFire http://www.mediafire...nithink_ROM.zip I only editted the kernel, recovery, and system tar, the rest is the same as Zenithink's 0911 ICS ROM, including the default ICS launcher.

Screenshots from my tablet after I set it up the way I wanted it (installed the apps I wanted) and changed the wallpaper:


















 

·
Zenithink Tablet User / Information Transmitter
Joined
·
6,629 Posts
Not sure if anyone is using the ROM I posted above, but I've updated it: http://www.mediafire...dNov9th2012.zip
Code:
http://www.mediafire.com/file/aprife9bpu5nq5h/C93_ICS_0911_omarahum_modified_Zenithink_ROM_updatedNov9th2012.zip
Alternate ATF Download link - http://androidtabletfirmware.net/index.php/android-tablet-firmwares-downloaded-files/viewdownload/5-cortex-a9/38-c93-ics-0911-omarahum-modified-zenithink-rom-updated-nov-9th-2012

*Downgraded Play Store 3.8.17 to Market 3.3.11 so it will (auto) update to Play Store 3.9.16 ok now (no more bootanimation loops)....
*Updated keyboard to JB 4.2 Keyboard (has swype function built in)....

(Made one for the C97 also - http://www.mediafire...dNov9th2012.zip )
Code:
http://www.mediafire.com/file/o52baawp5ano45p/C97_ICS_0910_omarahum_modified_Zenithink_ROM_updatedNov9th2012.zip
Alternate ATF Download link - http://androidtabletfirmware.net/index.php/android-tablet-firmwares-downloaded-files/viewdownload/5-cortex-a9/39-c97-ics-0910-omarahum-modified-zenithink-rom-updated-nov-9th-2012
 

·
Zenithink Tablet User / Information Transmitter
Joined
·
6,629 Posts
So I've been told Bluetooth doesn't work with my ROM, can someone confirm this? I don't have a dongle, or a device to pair it with, so I can't test... I just want to be sure it doesn't work incase I get PM's or emails asking about it.... Thanks in advanced! (TIA!) (I know the ROM has BT in the Settings menu, and I've included Christian Troy's module, but two people have said it doesn't work... Just would like some confirmation on it.) Thank you again...
 

·
Registered
Joined
·
22 Posts
I tried the BT dongle I bought recently (from F&L) and another one I already owned - neither work I'm afraid


If (either) dongle is plugged in at boot and I try to enable BT the logcat output looks like this:

11-25 18:31:42.654 D/LocalBluetoothProfileManager( 5028): LocalBluetoothProfileManager construction complete
11-25 18:31:42.654 I/EthernetManager( 5028): Init Ethernet Manager
11-25 18:31:42.784 D/libEGL ( 5028): loaded /system/lib/egl/libEGL_mali.so
11-25 18:31:42.794 D/libEGL ( 5028): loaded /system/lib/egl/libGLESv1_CM_mali.so
11-25 18:31:42.794 D/libEGL ( 5028): loaded /system/lib/egl/libGLESv2_mali.so
11-25 18:31:42.864 D/OpenGLRenderer( 5028): Enabling debug mode 0
11-25 18:31:43.204 I/ActivityManager( 3267): Displayed com.android.settings/.Settings: +1s36ms
11-25 18:31:44.164 D/ethernet( 3267): poll state :, left:4096
11-25 18:31:45.264 D/LocalBluetoothManager( 5028): setting foreground activity to non-null context
11-25 18:31:50.784 D/BluetoothAdapterStateMachine( 3267): PowerOff process message: 1
11-25 18:31:50.784 D/BluetoothAdapterStateMachine( 3267): Bluetooth state 10 -> 11
11-25 18:31:50.794 E/BluetoothAdapterStateMachine( 3267): failed to prepare bluetooth, abort turning on
11-25 18:31:50.794 D/BluetoothAdapterStateMachine( 3267): Bluetooth state 11 -> 10
11-25 18:31:50.824 V/BluetoothEventManager( 5028): Received android.bluetooth.adapter.action.STATE_CHANGED
11-25 18:31:50.854 V/BluetoothEventManager( 5028): Received android.bluetooth.adapter.action.STATE_CHANGED
11-25 18:31:51.034 D/DockEventReceiver( 5028): finishStartingService: stopping service​

If I boot without dongles plugged in and then insert later I get logcat output like this:

11-25 19:01:47.520 E/NetlinkEvent( 2267): NetlinkEvent::FindParam(): Parameter 'INTERFACE' not found
11-25 19:01:47.520 W/Vold ( 2267): addMdmDev don't find a match usb device(a12_1) in isKnownMdmDev
11-25 19:01:47.520 D/DevListener( 3269): Changed the permission of file /sys/devices/lm0/usb1/1-1/1-1:1.0/bluetooth/hci0/rfkill1/state to 666
11-25 19:01:47.520 W/Vold ( 2267): addMdmDev don't find a match usb device(a12_1) in isKnownMdmDev​

...then a little later when I try to enable BT in Settings I get:

11-25 19:02:48.150 D/LocalBluetoothProfileManager( 5676): LocalBluetoothProfileManager construction complete
11-25 19:02:48.150 I/EthernetManager( 5676): Init Ethernet Manager
11-25 19:02:48.280 D/libEGL ( 5676): loaded /system/lib/egl/libEGL_mali.so
11-25 19:02:48.290 D/libEGL ( 5676): loaded /system/lib/egl/libGLESv1_CM_mali.so
11-25 19:02:48.290 D/libEGL ( 5676): loaded /system/lib/egl/libGLESv2_mali.so
11-25 19:02:48.350 D/OpenGLRenderer( 5676): Enabling debug mode 0
11-25 19:02:48.660 I/ActivityManager( 3274): Displayed com.android.settings/.Settings: +981ms
11-25 19:02:49.600 D/ethernet( 3274): poll state :, left:4096
11-25 19:02:50.420 D/BluetoothAdapterStateMachine( 3274): PowerOff process message: 1
11-25 19:02:50.420 D/BluetoothAdapterStateMachine( 3274): Bluetooth state 10 -> 11
11-25 19:02:50.420 E/BluetoothAdapterStateMachine( 3274): failed to prepare bluetooth, abort turning on
11-25 19:02:50.420 D/BluetoothAdapterStateMachine( 3274): Bluetooth state 11 -> 10
11-25 19:02:50.440 V/BluetoothEventManager( 5676): Received android.bluetooth.adapter.action.STATE_CHANGED
11-25 19:02:50.450 V/BluetoothEventManager( 5676): Received android.bluetooth.adapter.action.STATE_CHANGED
11-25 19:02:50.510 D/DockEventReceiver( 5676): finishStartingService: stopping service
11-25 19:02:52.260 D/BluetoothAdapterStateMachine( 3274): PowerOff process message: 1
11-25 19:02:52.260 D/BluetoothAdapterStateMachine( 3274): Bluetooth state 10 -> 11
11-25 19:02:52.270 E/BluetoothAdapterStateMachine( 3274): failed to prepare bluetooth, abort turning on
11-25 19:02:52.270 D/BluetoothAdapterStateMachine( 3274): Bluetooth state 11 -> 10
11-25 19:02:52.280 V/BluetoothEventManager( 5676): Received android.bluetooth.adapter.action.STATE_CHANGED
11-25 19:02:52.290 V/BluetoothEventManager( 5676): Received android.bluetooth.adapter.action.STATE_CHANGED
11-25 19:02:52.370 D/DockEventReceiver( 5676): finishStartingService: stopping service​

Is there anything that should be enabled or some special config' to tweak? ...am running your ROM with no changes at this stage.

BTW, I've had no luck with BT dongles with any other ROM apart from CM10 ...though found it was not very reliable, usually ended up causing the tablet to hang requiring reboot.

;-p
 

·
Zenithink Tablet User / Information Transmitter
Joined
·
6,629 Posts
Having a bluetooth dongle recognized by our c-91 upgrade can be damn tricky. After buying 3 different models that seemed not to be recognized at all, I got quite nervous and decided to look a bit further into this stuff.
Here is what I've found:
first of all, the driver is not compiled as a btusb module for zenithink kernel, it seems the driver is compiled into the kernel itself,
I got one of my three not-recognized dongles, plugged in and restarted the tablet.

after that I got to android settings and tried to turn bluetooth on, no result as usual, the slider went back to off after few seconds without further notice.
Normally that would make you assume your dongle doesn't work, and you usually give up, but wait... let's go back to old-style linux tools:

At this point you need a terminal emulator for Android, one that can be granted superuser permissions, I use this one:
https://play.google....pal.androidterm

open the terminal emulator and digit:
su (all this stuff must be made as root, unfortunately)
hciconfig

if your dongle has actually been recognized by the kernel you should get something like this

hci0: Type: USB
BD Address: 00:15:92:3F:0A:57 ACL MTU: 310:10 SCO MTU: 64:8
DOWN
RX bytes:967 acl:0 sco:0 events:28 errors:0
TX bytes:367 acl:0 sco:0 commands:28 errors:0

if you got this, the device is there and recognized, and there is no particular reason Android should not be able to use it, so, on the terminal digit:

hciconfig hci0 up

at this point, if you try hciconfig again you should have:

hci0: Type: USB
BD Address: 00:15:92:3F:0A:57 ACL MTU: 310:10 SCO MTU: 64:8
UP RUNNING
RX bytes:967 acl:0 sco:0 events:28 errors:0
TX bytes:367 acl:0 sco:0 commands:28 errors:0

bingo! but be careful: if you go to Android bluetooth settings and try to turn bluetooth on you will probably have no result yet, and it would seem it get stuck.
we need a last trick, and so, on the terminal emulator you should try to digit

hcitool scan

at this point if your dongle has some sort of status led, it should go on, and that means good news, get back to android bluetooth settings, and there it is!
Your damn dongle is working at last!!!

hope this can be of some help for other users with a bunch of bluetooth dongle lying sadly abandoned on their desk
 

·
Registered
Joined
·
3 Posts
Hello sir.
I know this is an old thread but I would like to try your custom ICS on my zenithink c93 (with 2f)
So far I am not happy with jelly bean.
I tried to go to mediafire and download but it said that it was private.
Wold you be willing to connect me to this so I can download & install?

Thank you.
kerrygg
________________________________________________________________________
If anyone wants to try a similar ROM based on this 0911 ICS 4.0.3 ROM that I put together and am using on my tablet right now, with a 2GB data partition (1GB is taken from the media partition) and working USB GPS (for pl2303 chip), with some of Christian Troys mods, and fixed some stuff that didn't seem to be working for me, I uploaded it to MediaFire http://www.mediafire...nithink_ROM.zip I only editted the kernel, recovery, and system tar, the rest is the same as Zenithink's 0911 ICS ROM, including the default ICS launcher.

Screenshots from my tablet after I set it up the way I wanted it (installed the apps I wanted) and changed the wallpaper:


















 

·
Zenithink Tablet User / Information Transmitter
Joined
·
6,629 Posts
Hello sir.
I know this is an old thread but I would like to try your custom ICS on my zenithink c93 (with 2f)
So far I am not happy with jelly bean.
I tried to go to mediafire and download but it said that it was private.
Wold you be willing to connect me to this so I can download & install?

Thank you.
kerrygg
________________________________________________________________________
Sorry, the ICS ROM I modified from Zenithink was only for the H6_1f tablets.... I do not have a working ICS kernel (boot.img for the 2f's) or know how to make the update.zip for the 2f's...

The ROM download for the 1f' is http://www.mediafire...dNov9th2012.zip and a system patch (needs to be renamed to just system.patch.zt280.tar.bz) http://www.mediafire...ch.zt280.tar.bz for the gsensor fix and build.prop update for latest youtube app to work...
 
1 - 16 of 16 Posts
Top