Android Tablets Forum banner
1 - 20 of 1832 Posts

·
Registered
Joined
·
6,731 Posts
If you appreciate my work and would like to support me with a small donation you can click on button.
If every happy user of this rom would just donate a couple per month I could invest more time in all these Android projects, it'd cost you just like one coffee per month.

Features

* UbiFS (like stock roms)
* Bluetooth USB dongle support
* USB GPS support (cp210x and pl2303)
* Xbox 360 gamepad support (xpad)
* PS3 USB gamepad support (hid-sony)
* Generic / chinese (Pantherlord / GreenAsia) gamepads support (hid-pl and hid-gaff)
* OpenVPN support (tun)
* Veno congestion control algorithm

Instructions

* Unrar the content of this (CWM v5.5.0.4 20121026) archive and put it in the root of a MicroSD.
* Put rom (cm10_elf2_$DATE.zip) and gapps (gapps-jb-$DATE-signed_ubifs.zip) files inside internal or external sdcard.
* Turn on the tablet keeping pressed VOL- and POWER untill you see the green droid.
* Select "Wipe data / factory reset" (you can use volume rocker to move up/down and power button to confirm).
* Flash rom (cm10_elf2_$DATE.zip), gapps (gapps-jb-$DATE-signed_ubifs.zip) and, the required compatibility zip.
* Now select "Reboot system now".
* Enjoy CyanogenMod 10!

Changelog & download links

2012-12-20

* Last CM10 build
* Fixed latest YouTube fc
* Fixed audio with some games
* Other minor stuff
* Updated upstream sources

Rom (md5sum)
Gapps (2012-10-11)

Compatibility zip

* ELF-II v1.7
* Aurora-II v2.8 (if you have troubles you can always use v1.3.1 as fallback)
* Crystal v1.7 (like Aurora's users, if you have troubles use v1.0.3 as fallback)
* Crystal (new batch) v1.1
* Ramos W22 PRO v1.2
* Fire TM v1.6 - CWM v5.5.0.4
* Fire QM v1.7 - CWM v5.5.0.4
* Hero v1.0 - CWM v5.5.0.4

Compatibility zip (AdHoc support)
* Elf-II v1.7
* Aurora-II v2.8
* Fire TM v1.6
* Fire QM v1.7
* Hero v1.0

Known bugs

* You tell me...

FAQs

* If you're coming from a stock based rom, it's better if you use "stock" recovery to format "media" partition (the internal memory). And it'd be better if you don't use Google's backup/restore service to avoid breakages.
* Internal memory is mounted at /storage/sdcard0, external sdcard is mounted at /storage/sdcard1. If you wanna swap them (and make primary your real microsd) just flash this file after flashing rom's zip (you have to do it everytime you flash a new version of the rom)
* If you wanna increase the microphone capture volume open terminal emulator and after typing "su" type "alsa_amixer sset Capture 63"
* If you don't like Nexus 7 fingerprint and wanna use SGS-II instead flash this zip. Remember that changing fingerprint may screw Play Store, if it happens you'll have to perform a "wipe data / factory reset".

Sources

"jellybean-aml" repos

Screenshots









Old Changelog

2012-11-17

* Other minor stuff
* Updated upstream sources

Rom (md5sum)

2012-11-10

* Added reboot to recovery (you must have flashed CWM to the NAND or it will boot to stock recovery)
* Aurora-II / Elf-II: new compatibility zip (fixes stuck g sensor for people that had problems)
* Other minor stuff
* Updated upstream sources

Rom

2012-11-03

* Fixed Netflix 2.x compatibility
* Potential fix for the few games that were still having a choppy/stuttering audio
* Aurora-II / Elf-II: fixed unresponsive WiFi when the screen was turned off
* Other minor stuff
* Updated upstream sources

Rom

2012-10-28

* Updated compatibility zips for Elf, Aurora and Crystal
* Re-inserted missing file that broke wifi
* Increased amplayer buffer; flash videos using latest apk work decently and in hw mode. Sometimes you may not hear audio but toggling fullscreen mode will fix it.
* Other minor stuff
* Updated upstream sources

Rom

2012-10-25

* Updated many compatibility zips, please check the section below
* Fixed HDMI (dual display and single panel) on Fire
* Updated elf/aurora DHD driver (and moved to NL80211 mode instead of WEXT)
* Cherry-picked "bionic: Add ARMv7 optimized string handling routines" commit
* Other minor stuff
* Updated upstream sources

Rom

2012-10-22

* Fire / Flame: new compatibility zip
* Updated amlogic video playback library (now seek is working in apps like YouTube)
* Added "Expanded desktop" capabilities (enable it from Power Menu's settings to be able to hide status bar)
* Other minor stuff
* Updated upstream sources

Rom

2012-10-18 (repack)

* Now ELF-II requires a compatibility zip too. I've removed boot.img from the main rom because if someone with a Fire forgets the compatibility zip he can damage the touchscreen. So better safe than sorry, just add the compatibility zip in the pipe of the flashing files

* ELF-II: updated kernel (added BFQ I/O scheduler as default and enabled cgroup_autosched).
* Aurora-II: updated kernel (new compatibility zip includes a kernel very close to the ELF-II one)
* Crystal: moved to ELF-II kernel
* Ramos W22 PRO: updated compatibility zip, now both cameras should work
* Fire / Flame: initial support for both TM/QM screens
* Removed PPP Widget since it was causing troubles to Crystal's wlan
* Android detects both usbnet/eth ethernet (to use ethernet you have to type these commands from terminal emulator: "su; netcfg eth0/usbnet0 up; netcfg eth0/usbnet0 dhcp")
* Other minor stuff
* Updated upstream sources

Rom

2012-10-10

* Bump Android version to 4.1.2
* Fixed (maybe) pops during sleep
* Crystal: added initial support
* Other minor stuff
* Updated upstream sources

Rom

2012-10-02

* ELF-II: default to 1.5 GHz kernel (clocked at 1.32 GHz)
* Aurora-II: download new compatibility zip v1.3
* Added JB Power HAL (with pulseboost support). Don't install any app like SetCPU because it will be handled at a lower level. I've added a couple of goodies too, you can manage cpu min/max freq with display on/off editing the following values in /system/build.prop
ro.sys.min_cpu_on=408000
ro.sys.min_cpu_off=96000
ro.sys.max_cpu_on=1320000
ro.sys.max_cpu_off=1008000
As you can see if defaults to 408 MHz / 1320 MHz with display ON and 96 MHz / 1008 MHz with display off.
Don't change governor or the power HAL won't be used.
* Added support for amlogic ril. Supported modems will work out of the box, the other can be used with the included PPP Widget
* Updated upstream sources

Rom

2012-09-28

* Fixed screen unresponsiveness with some games (Angry Birds after a pinch for example)
* Fixed camera detection, now Face Unlock will work.
* Updated upstream sources

Rom

2012-09-23

* Updated camera HAL library with a jelly bean one (from zenithink c97 firmware). Now all video chat programs should work (it's been tested with Skype and GTalk).
* Updated libaml-ril.so (from c97 jelly bean)
* Replaced CM's Superuser (that right now has problems "remembering" permissions) with SuperSu
* Updated upstream sources

Rom

2012-09-22

* Fixed choppy audio in game
* Reverted "older" libsurfaceflinger because it seems fixed upstream
* Changed something in the rild (again)
* Updated upstream sources

Rom

2012-09-17

* Fixed video recording (again!)
* Fixed touch problem with some games
* Changed WiFi wake lock implementation
* Minor change to ril daemon
* Removed 20 pixels "frame" limit from touchscreen's driver
* Updated upstream sources

Rom - Gapps

2012-09-14

* Fixed 3-dot menu thing (if it still doesn't work be sure that under "Settings -> System -> Hardware buttons" "Menu button"'s entry is assigned to "open/close menu")
* Added an option under Display Settings to enable/disable Tablet UI (this feature replaces the build.prop entry)
* Added "u3gmonitor", an app included in AllWinner releases that should automatically launch usb_modeswitch on dongles that require it. Report any change because if it doesn't work I'll remove it. Note that if your dongle is recognized as a SD card you have to disable Mass-Storage mode (refer to Google because every dongle is different).
* Some minor changes
* Updated upstream sources

2012-09-13

* Spoofed as Nexus 7 (if you have any trouble with Play Store clear both "Google services framework" and "Google play store" data)
* Fixed FC on license check of some games (specially gameloft one)
* Updated upstream sources

Rom - Gapps

2012-09-12

* Fixed video recording
* Bluetooth dongle now supports hotplug
* Different options under "Settings" if you're using tablet or phablet UI (for example to customize status bar toggles)
* Reverted default governor to "conservative", if you need more power you can set it from performance settings. Use "performance2" not "performance" or it will cap cpu to the higher frequency
* Experimental: older surfaceflinger library, let's see if it really improves performance with some games or it is only placebo
* Updated upstream sources

Rom - Gapps

2012-09-09

* Camera is working again
* Fixed volume rocker audio control
* Re-added move 2 internal SD feature
* Added a new menu entry in "Display settings" to toggle HDMI dual/single view
* Updated upstream sources

Rom - Gapps - Camera recording FIX

2012-09-07

* Fixed USB storage in Tablet UI
* Fixed HDMI connection (if you wanna use the dualdisplay feature just remove the "#" character from "#ro.vout.dualdisplay2=true" entry in file /system/build.prop)
* Updated upstream sources

2012-09-05

* Added NTFS and ExFat support
* Added usb_modeswitch
* Changed max frequency to 1320 MHz and default governor to performance2
* Fixed camera preview
* Fixed camera orientation on remote side
* Fixed audio capture
* Updated upstream sources

Rom - Gapps

2012-09-01

* First release, pretty much everything is working. If you wanna use the "phablet" (aka Nexus7) ui have a look at FAQs section, I've created a system property to manage it.

Rom - Gapps - Payed apps fix
 

·
Registered
Joined
·
19 Posts
Hey

Bug report:
something wrong with the mounts
1. cannot install more than a few apps gives me "Can not install on usb storage or sd card" (even after clearing cache...)
2. when connected to the PC, it doesn't give me the option to add the device as a usb storage

reverting to cm9...
 

·
Banned
Joined
·
33 Posts
Appears to be just a cm10 svn compile with the am logic kernel included crashes very often, loss of performance and battery life.

Cool to have cm on elf 2 but this will need more then just a compile and a signed rls to be workable someone should publish a Google code svn of the cm10 with the kernel rather then have a lone Porter.

Sent from my GT-I9100 using Tapatalk 2
 

·
Registered
Joined
·
6,731 Posts
Discussion Starter · #12 ·
tragidy, start your own porting since you're so good with words
 

·
Registered
Joined
·
6,731 Posts
Payed apps fix

just flash it and they will install.

for the other things you have to read the "FAQs" section:
* trebuchet crashes in the drawer when orientation changes, it's a collateral damage of the "disable phablet ui" workaround; I suggest you to use Apex.
* tablet->pc connection works ONLY in phablet ui mode
* google search works IF you install your language pack for Now! Only english is included, and without the proper language pack you'll get FC

@tragidy
cool then stop bothering a guy that has busted his *arse in the past days to get this thing FULLY working, I don't have any of the instability you mention.
please feel free to cherry-pick my commits and then release your porting

edit: you see, I refuse feedback and I've fixed the only present big issue as soon as I came back home
 

·
Registered
Joined
·
6,731 Posts
I've disabled it, i can provide a different framework-res.apk with move2sd enabled but i don't suggest you to use it. Internal memory may get corrupted and you'll lose all the apps moved there. If you wanna move apps 2 sd (do you really need it? with ~1 gb of /data storage you'll install hundreds of apps), use link2sd (you just have to repartition your real microsd from cwm and dedicate some sd-ext space for the partition used by link2sd, i suggest you to use ext2, not ext3/4 that are journaled)

edit: flash in the order rom/gapps/fix or rom/fix/gapps but the rom always first because formats /system partition
 

·
Registered
Joined
·
375 Posts
For the install to SD thing:
You could create a patch that has the framework-res with move2sd and a modified vold.fstab that uses the microsd as sdcard0 and asec sdcard. That way the users with high storage capacity requirements could install this patch and could use their microSD without using multiple partitions on it and without having the interal sdcard getting corrupted.
I see that you use 2 sdcards in this, I don't know if my suggestion could work in these conditions.

BTW 1 GB on stock-based rom is not enough for most users, since the tablet has 8 or 16GB internal sdcard, they want to use it. Why have 1GB if you have +8 or +16 to spare.

Personally I am fine with 1GB.

Thanks for your work, I will try this as soon as I can.
 

·
Registered
Joined
·
6,731 Posts
Discussion Starter · #18 ·
there's no need to hijack vold.fstab with cyanogenmod, have a look at build.prop's entries:

ro.vold.switchablepair=/storage/sdcard0,/storage/sdcard1
persist.sys.vold.switchexternal=0

if you put 1 to the last one you'll have internal/external memories switched.

honestly i'd prefer keeping move2sd disabled and who's interestead should use link2sd, if anyone disagrees may compile the rom by itself or decompile framework-res.apk, change emulated=true to emulated=false in storage_list.xml and recompile/push the .apk
 

·
Registered
Joined
·
7 Posts
I just can't get Google now to work. I'm from US so English is what I need. Voice search is not working in any app. I touch the microphone and instantly say didn't get that speak again, on every app that uses voice search. It worked flawlessly on your eleven ROM... Was looking forward to using Google now.... I downloaded a microphone test app , and it seem that its not working.... confused, lol...
 
1 - 20 of 1832 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top