Android Tablets Forum banner

[rom] CyanogenMod 10.1 for C97 / C93 (update 2013-05-18)

142262 Views 451 Replies 78 Participants Last post by  omarahum
If you appreciate my work and would like to support me with a small donation you can click on button.
If every happy user of this rom would just donate a couple per month I could invest more time in all these Android projects, it'd cost you just like one coffee per month.


* Unrar the "common" rar file and put "zt-update" folder to the root of a microsd.
* Put rom (cm-10.1-$ and gapps (gapps-jb-$ files inside internal or external sdcard.
* Turn on the tablet keeping pressed VOL+ and POWER. Press VOL+ to confirm and you'll boot to CWM recovery.
* If this is your first install flash this file that will format /system, /data and /cache partitions and from "Wipe" menu erase "Android secure".
* Flash rom (cm-10.1-$, gapps (gapps-jb-$ and, if you're using a different device, the required compatibility zip.
* Now select "Reboot system now".
* Enjoy CyanogenMod 10.1!

Changelog & download links


* Updated upstream sources

Common 2013-03-03
ROM (md5sum)
Gapps 2013-03-01

Compatibility files for C93 H6 1F

Common 2013-03-03
Compatibility v1.1

Compatibility files for C93 H6 2F

TWRP recovery (create a folder named "zt-update" in your MicroSD and unzip there the recovery.img file; the bootloader will do the rest when you use the buttons trigger combination)
Compatibility v1.1

Note that if you're running the latest C93 stock firmware "ZT283_H6_2f_1GB_Android4.1_0202_V1.6" you will have to use this TWRP and this comp zip.
If you accidentaly used the previous files you'll see that partition's got fucked up and you'll have to flash the stock firmware to fix them


* Use another launcher (I suggest you "Nova" or "Apex") because Trebuchet screws the layout.
* Bluetooth stack has changed: USB bluetooth is not working right now; only devices with UART (internal) bluetooth works.
* If your device has only a front camera you won't have a camera launcher icon, but you can install this app


* If you don't like Nexus 7 fingerprint and wanna use SGS-II instead flash this zip. Remember that changing fingerprint may screw Play Store, if it happens you'll have to perform a "wipe data / factory reset".
* WiFi now can stay enabled with display turned off. Note that if WiFi is enabled the tablet won't enter deep sleep so if you're more interestead in battery life instead of an always on WiFi change policy (on "Advanced" WiFi settings) from "Always" to "Never".
* Internal memory is mounted at /storage/sdcard0, external sdcard is mounted at /storage/sdcard1. If you wanna swap them (and make primary your real microsd) just flash this file after flashing rom's zip (you have to do it everytime you flash a new version of the rom)
* If you wanna format your internal memory (it's corrupted, filled of crap, etc.) just flash this file from recovery. If it fails try to unmount internal storage from "Mount" section.
* It's better if you don't change governor because the included "ondemand" has been customized to support "boostpulse" feature of jelly bean power hal. You can control min/max cpu frequency with display on/off editing these entries in /system/build.prop file (they're listed with their default value): "ro.sys.min_cpu_on=408000", "ro.sys.max_cpu_on=1200000", "ro.sys.min_cpu_off=96000", "ro.sys.max_cpu_off=1008000".


See less See more
  • Like
Reactions: 1
1 - 20 of 452 Posts
Could anyone please explain this step:

* Put rom (cm-10.1-$ and gapps (gapps-jb-$ files inside internal or external sdcard.

It just means to place all the zips that you have downloaded onto your sdcard, the only file you need to extract/unrar is the Common one that has the zt-update folder in it, which is the folder you need to put on your (FAT32 formatted) sdcard to enter recovery (like with the stock ROMs), then from the recovery (I'm not sure of he is using CWM or TWRP recovery with this ROM), you flash the zips from wherever you put them (the root of the sdcard the the easiest place)...

i'm trying to flash CyanogenMod 10.1 in my zt-283 C93, but the after rebooting the touch screen is too big and i cant see all of the buttons or words (the sreen size doesn't fit in my C93)!

any help on this?

i've flashed the files,, and the "common" for C93

thanks in advance.
The common file is supposed to be unrared, and the zt-update folder put onto your (FAT32) sdcard... And the compatibility file is supposed to be flashed last....
I unzipped the zt-update folder, and added the common and gapps zip folders to the sd card, then shut the tablet off. I then Restart it while holding Power and pressing or holding volume + and when it turns on it flashes

Volume + Pressed
prepare enter mcc update mode
hw testing started...
skip recovery

Then it reboots like nothing happened

I have also tried holding the power and back back button at the same time, this brings up a totally different screen

Then it enters a Camera + mode

Then says the following

Found 'LK:ZT283_I1_2a', dismatch 'LK:ZT283_H6_1F'
do *kernel update? 'CAMERA+' key sure, otherwise cancel

I then hit camera + and the message appears again

Found 'LK:ZT283_I1_2a', dismatch 'LK:ZT283_H6_1F'
do *kernel update? 'CAMERA+' key sure, otherwise cancel

i then hit + again, and then it updates

I then go to my tablet info section, and it does not show that cm10 is installed.

Why I am doing this is I have only had this tablet for 2-3 weeks, and about a week and a half ago i suddenly lost access to 5.7gb of my internal storage. I was only able to access the 881mb. Somehow the 5.7gb of internal memory got unmounted. This also stopped me from mounting any external sd cards. All of my apps that were linked to the internal memory that was unmounted were no longer accessable. I then downloaded the ICS C93 Mod off of slatedroid and restored it. This fixed my problem.
Well yesterday this happened again, So I restored it again with the same update, and currently the tablet is back to normal, just like when I bought it.
What I would like to do now is to Put Cm10 on it or root it where I can download and use a Partion app, where I can manage my own partitions without. Or does anyone know why my device is doing this and how to fix it?
Volume+Power is for the C97, Back+Power is for the C93's... If it is saying Found 'LK:ZT283_I1_2a', dismatch 'LK:ZT283_H6_1F', it means you have a C93 and are trying to flash C97 files onto your tablet... You are supposed to use/unrar the common file for the C93 (that has the zt-update folder in it) and be flashing the C93 compatability zip file last via CWM/TWRP recovery (first ROM zip, then Gapps zip, then C93 compatability zip)....
Do these Tablets have internal Bluetooth cause I can never seem to turn on Bluetooth, want to tether to phone as wifi only last about and hour and my cell is dead.
No, the ZT-283's don't have internal BT....

Christian Troy's CM10 and AOKP (JB 4.1.2) ROMs support a BT usb dongle, the Zenithink stock ROMs do not support any BT...
Yeah, it just wont take. Looks like I killed it. Might get one of box chip ones in the mean time and hope in the future I can revive it somehow
Have you tried flashing a Zenithink ROM or my ICS ROM with the Zenithink autoscript file? (Then remove the autoscript so it doesn't autoflash.)

Are you sure the Back key isn't stuck or being pressed inadvertently?

(It's funny, Gazman's C93 tablet can't go into recovery and yours won't get out of it....)
Camera launcher app for the C93 (This is so you can launch your camera to video record or photo yourself).

Make sure you flash the camera fix zip. This is not needed for the C97.
tried that last file and now i'm stuck on the error - has stopped working - i click on OK and its stuck in a loop.
Thought I'd try 10.1 tonight, and used the files in the first post for the C93 (0224 ROM), and had the same problem with " has stopped".... Then tried to flash the 0217 and wouldn't go past the bootanimation.... Not sure what I am doing wrong.... Oh well, back to ICS for me...

Wonder what version CM10.1 ROM most C93 H6_1f users are using....
See less See more
@omarahum try this from an old reply,I had the rocess " error looping and this worked for me on the C93

Posted 16 December 2012 - 06:07 AM
evilsoul, on 15 December 2012 - 04:15 PM, said:
unfortunately I experienced frequent system freezes...I think the problem on my tablet is the new kernel.
I also tried to use the old kernel/mali libs with this rom, but the process "" crashes continuosly.
Any suggestions?


Try flashing this http://www.mediafire...sxabqdh1t3vfrjn
Thanks for the tip, I'll try it out this weekend... I thought that at one point CT did repack the C93 common with the evilsoul kernel, and thought that the 0128 common was based off of it, guess I was wrong... Thanks again!
Ah, the 0128 kernel packed in the C93 common and the one from F&L are different! Will definitely try this ROM tonight or tomorrow, just need to do the 2GB Data Partition mod first.... Thanks!
It just does that. Not sure why. Maybe Zenithink wants the tablet on while charging. I dunno to be honest. You can hold the power button down for 10 seconds to get it to shut off while charging.
Actually, that was a bug they were not aware of, I told them about it last year, and it was fixed since the 1214 ROM (I haven't tried any of Zenithink's Jelly bean ROMs except for the first one, which was way too buggy for me.).... The automatic turning on when you plug it in is on purpose, Zenithink said it had something to do with a bug with the display.... But the rebooting instead of turning off while plugged in was a mistake...

Shutting the tablet off by pressing the power button for 10 seconds has caused data corruption on my tablet three out of five times I've done that, so be careful....

I flashed CM 10.1 with the 0222 spl (same spl as in the 1214 ROM), and it does shut off properly now while plugged in....

The only issues I am having with CM 10.1 is some random reboots, apps suddenly closing and going back to the desktop, and Adobe Flash issues with the Browser... Otherwise, I am pretty happy with this ROM... I love how smooth HBOgo plays videos with this ROM.... Still need to see if USB GPS will work properly, but will wait for it to get a bit warmer outside before I test it... Will probably flash back to ICS now that I've made a tar backup of CM10.1....
See less See more
No, didn't switch memories on my C93.... It may be because of the number of apps I have installed, my data partition is 85.5% full (1.71 GB of 2GB used up), but I don't have any problems with the ICS ROM I use that have all the same apps installed minus Temple Run 1 and 2... I love CM10.1, just wished Flash Player would work correctly with the Browser, for now have to watch embedded videos fullscreen since it doesn't scale down into the window... Concerning the random reboots, it may also be due to the launcher I am using, Holo Launcher HD, as half the time the random reboot happens is when cold booting and unlocking the lockscreen, instead of going to the desktop it reboots back to the bootanimation....
move to html5, flash should be always avoided, it's not even safe using a 7 months old release of the most buggy and insecure software of the WWW (it's been patched already many times since the day android's support has been dropped, security fixes, not enhancements)

just use an ipad UA and pretty much every site will use html5 contents.
Thanks, I'll try that... I'm using Adobe Flash for Android 4.x version that came out on Feb. 12, 2013.... I'm just used to using the Desktop User Agent, haven't tried the iPad UA in a long time....

Edit: Hmmm, I guess the iPad user agent doesn't work if you have Adobe Flash installed...

Edit2: Uninstalled Flash Player, using iPad UA, but now places where there was flash content is just blank now on some sites or says it's incompatible...

@Christian Troy, Do you know what Zenithink does to make their 10.2 version Flash Player work with their ROMs? I guess maybe I have to wait for Zenithink to put out a 4.2 ROM with a compatible Flash player... (Tried their flash player that's bundled with their 4.1 ROMs and now it doesn't crash the browser (like it did with the early CM10 ROM), but just shows a blank space for embedded videos, if you tap on the area, you can hear the audio, but no graphics/video display)....
See less See more
There isn't.
I built extra modules using ainol tree.
If you google Ainol source, you may find what you need.... (Just make sure it's the source for the Amlogic MX/M6 CPU, and it's for the 3.0.8 kernel....)

Also, you may want to check out his github -
what kind of problems do you have?
When playing an embedded video with the Browser (with the Desktop User Agent), the video plays full screen in the background instead of scaling down to fit the window/frame, so you only see a portion of the video unless you choose the option/toggle to view it full screen...
what kind of problems do you have?
edit: sorry, i see now. Try this
Thanks, but the same thing happens with this version as the newest version....
See less See more
How can I change my c93 UA to iPad? And back again? I'd like to see how HTML5 works.
(On CM10.1) Open the Browser, tap the menu button, scroll down to Settings and tap on it, tap on Advanced, then User Agent.....
Hi Christian,

I downloaded last night.

1. Wiped out all boxes
2. install cm-10.1-20130303-UNOFFICIAL-c973.
3. gapps-jb-20130301-amlogic
4. c93-cm10.1-compatibility-1.1
5. reboot
6. add wi-fi
7. add gmail account

Did, I do any thing wrong?
I believe he wants you to flash this zip also (the line right under 2013-03-03 in the first post)....
*** If you're having problems with some videos flash this zip (I'm doing some tests with newer video libraries, but seems no too stable right now) ***
Hi there. I've downloaded this mod (for C93), and so far it seems to be the best of them. However, as I am a newbie, I still have questions.

1. Is Ethernet supported on this mod? I've seen no ON/OFF switch, so I'm asking, is it perhaps automatic or something, or is it just not supported?
2. Are there other themes that I could download and add to settings => Themes menu?
3. This ROM is describing the tablet as a Nexus (in settings). Does that mean I can download special apps that only work on Nexus tablets, but not on others... (if there are any, I know there are apps like that for samsung)
4. Gallery doesn't open images, there are just albums with 0 pics inside. Is that my error or is it caused by ROM.?

That's what I found so far, if I find more bugs I'll post them.
I can answer the first question.....
Turn wifi off, attach the ethernet adaper and ethernet cable, then from a terminal app type:
dhcpcd eth0
Then the ethernet should work.... Source - SkinnyBytes post - http://www.slatedroi...786#entry602786

Gallery app seems to be working fine for me....
Thank you for this answer. I found out what's wrong when using gallery, tablet can't find files on SD card... I checked storage file, but file manager only finds files in internal storage. Music player also can't find any of the tracks on SD card...
Ah, I was (I've switched back to my ICS ROM now) using the line persist.sys.vold.switchexternal=1 in my build.prop, is yours set to 0?
Omarahum, I think we all want to know why you've switched back to your ICS ROM? Which by the way I think is the fastest on this tab. If it had full G sensor I'd use it in a flash.
There was no one particular reason, I really liked CM10.1, and since I mostly use my tablet while connected to some sort of charger, I never realy noticed if the battery drained faster or not (as some people have reported on their C93).... Since I was using all the same apps as I did on my ICS ROM, plus a few more games that could take advantage of Christian Troy's g-sensor fix, my 2GB data partition was getting almost full, and I guess some other apps I installed were causing me some problems, like with the CM FileManager, which was working perfectly well when I first installed all my old apps, all of a sudden would Force Close everytime I tried to open a txt file with it's editor, but if I used another app like Root Explorer and chose to open a txt file with CM's FileManager's Editor it worked fine... Also because of all the apps I had installed, when my tablet fully booted with CM10.1 it only had about 220MB of free RAM, while on ICS I always have over 500MB of free RAM.... I also noticed that when watching embeded flash video in the Browser at 1080p (with Destop UA in Full screen mode), the video would stop and start a lot, like this one -, so wanted to see if the same thing would happen on my ICS ROM (never noticed a problem before).... So instead of reflashing CM10.1 and starting from scratch, I thought I'd just flash back to my ICS ROM and compare and contrast the two till there was another update from CT after Easter.... I have many backup tars of the system and data partitions of both ICS and CM10.1, so I can flash back and forth between the two if I want to without having to setup everything up... I'll probably flash back to CM10.1 and try out different data tars backups I have to see which one works best (help me figure out which apps are causing the troubles), and then try to uninstall any apps I don't really need/use much.... I haven't been feeling well lately, so I just wanted a fully working tablet, which I knew my last backup of ICS was, and do all the CM10.1 app problems figuring out when I feel a little better....
See less See more
1 - 20 of 452 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.