Android Tablets Forum banner
1 - 20 of 21 Posts

·
Registered
Joined
·
50 Posts
Novo7 Flames 0201 Official AML Firmware

QM Screen:
Download Link1
Download Link2

File: Ainol-E4-20130131-qimei-usbburning.zip
Size: 280,339,646 bytes
Modified: February 5, 2013, 10:02:10
MD5: 948089FA311077BD5A4B91326113EB15
SHA1: 0014FE49DA12A9636B6D15F28F07BACAB6DC1EA0
CRC32: 8D58CB96

TM Screen:
Download Link
Mediafire (Thanks to fuser-invent)

Flash tool:
AML Flash Tool (USB-Burning-tool-v1.6.2.0128):
Download Link1
Download Link2

Flash Tutorial:
bbs.ainol
myphone (Thanks to Frontier)
post #14 (Thanks to dd_yulius)

TWRP Custom Recovery (Thanks to CT our mother of ROM
)
TM
QM

File Transfer
MTP
ADB

android.process.acore pop up error after setup Google Play?
put this Contact.apk to /system/app/ and chmod rw-r--r-- (Thanks to hithotguest)

Stuck with this firmware?

Try This

Original Thread:
bbs.ainol
 

·
Registered
Joined
·
50 Posts
Discussion Starter · #7 ·
Please confirm for those who have successfully used the flashing tutorial on Lokum.
I have TM, can't test yet..
 

·
Registered
Joined
·
50 Posts
Discussion Starter · #19 ·
TM screen is up now
 

·
Registered
Joined
·
50 Posts
Discussion Starter · #25 ·

·
Registered
Joined
·
50 Posts
Discussion Starter · #54 ·
Has anyone been able to get a copy of the TM firmware ? - I cant even get the site to load thats linked in the first post
cek OP

After several failures with USB connection, I finally managed to flash this firmware.
This is my sort review for TM screen with MMA gsensor.
- Very low screen brighness at boot.
- Auto brighness can't be activated
- I can't use MTP mode(need driver)
- Camera option only VGA and QVGA, other than that everything fine including photospare
- Popping and mosquito sound completely gone
- There's no more fake/ghost charging (battery bug)
- Louder speaker sound
- Pairing bluetooth to my phone very fast
- Bluetooth reverse tethering fine (bluetooth tethering not tested yet)
- It seems Internal storage/sdcard0 sharing space with Data partition (13gb)
- I managed to get into TWRP (for 2 GB data partition) in sdcard1
 

·
Registered
Joined
·
50 Posts
Discussion Starter · #103 ·
Do you have a micro SD card inside when doing thid?
If yes, remove it, as it seems the aml tool hangs at that stage if a MICROSD card is found.
yeah, i've read that on bbs.ainol.
in my case (on XP) after failed detect device and get stuck, then the device detected on other port.
[T 4][21:05:05]: erase nand, you are in erase mode: nand rom_protect off;nand scrub 0;poweroff
[T 4][21:05:05]: sendCommandWithReply: nand rom_protect off;nand scrub 0;poweroff maxCount:0
[T 4][21:05:07]: rematchPortInfo
[T 4][21:05:18]: rematchPortInfo
[T 4][21:05:19]: rematchPortInfo
[T 4][21:05:20]: rematchPortInfo
[T 4][21:05:21]: rematchPortInfo
[T 0][21:06:39]: load spl ...
[T 0][21:06:40]: Transfer Complete! total size is 18712 Bytes
[T 0][21:06:49]: load uboot ...
[T 0][21:06:50]: load uboot ...
[T 0][21:06:52]: load uboot ...
[T 0][21:06:53]: load uboot ...
[T 0][21:06:55]: load uboot ...
[T 0][21:06:57]: load uboot ...
[T 0][21:06:58]: load uboot ...
[T 0][21:07:00]: load uboot ...
[T 0][21:07:02]: load uboot ...
[T 0][21:07:04]: load uboot ...
[T 0][21:07:05]: load uboot ...
[T 0][21:07:07]: load uboot ...
[T 0][21:07:09]: load uboot ...
[T 0][21:07:10]: load uboot ...
[T 0][21:07:12]: load uboot ...
[T 0][21:07:14]: load uboot ...
[T 0][21:07:15]: load uboot ...
[T 0][21:07:17]: load uboot ...
[T 0][21:07:19]: load uboot ...
[T 0][21:07:20]: load uboot ...
[T 0][21:07:22]: load uboot ...
[T 0][21:07:23]: load uboot failed 15 times,maybe because the spl code run err
[T 0][21:07:24]: failed because no connected device ,current step is 1
[T 4][21:07:27]: load spl ...
[T 4][21:07:28]: load uboot ...
[T 4][21:07:29]: Transfer Complete! total size is 520348 Bytes
[T 4][21:07:35]: test command exec: crc 0x8f800000 520348 4e80a205
[T 4][21:07:35]: command exec: crc 0x8f800000 520348 4e80a205
[T 4][21:07:35]: sendCommandWithReply: crc 0x8f800000 520348 4e80a205 maxCount:30
[T 4][21:07:37]: begin run 8f800000
[T 4][21:08:00]: finish run 8f800000
[T 4][21:08:01]: rematchPortInfo
[T 4][21:08:03]: command exec:set_chgcur 0
[T 4][21:08:04]: command exec:video dev bl_off
[T 4][21:08:05]: command exec:video dev disable
[T 4][21:08:07]: command exec:sf probe 2
[T 4][21:08:08]: command exec:sf erase 0 1000
[T 4][21:08:09]: command exec:nand rom_protect off
[T 4][21:08:11]: command exec:nand scrub 0
[T 4][21:08:23]: command exec:nand info
[T 4][21:08:25]: command exec:defenv
[T 4][21:08:26]: command exec:setenv bootargs ${bootargs} a9_clk_max=600000000
[T 4][21:08:27]: command exec:setenv recovery_command --usb_burning
[T 4][21:08:29]: command exec:save
[T 4][21:08:30]: load uimage ...
[T 4][21:08:31]: Transfer Complete! total size is 4704256 Bytes
[T 4][21:08:37]: test command exec: crc 0x82000000 4704256 cc9e1542
[T 4][21:08:37]: command exec: crc 0x82000000 4704256 cc9e1542
[T 4][21:08:37]: sendCommandWithReply: crc 0x82000000 4704256 cc9e1542 maxCount:30
[T 4][21:08:38]: command exec:bootm 0x82000000
[T 4][21:08:40]: boot uImage ...
[T 4][21:09:22]: find disk: G:
[T 4][21:09:23]: recoveyCommand: wipe_data prepareCommand:
[T 4][21:09:23]: send command : wipe_data ok!
[T 4][21:09:43]: wipe_data success(wipe_data):eek:k
[T 4][21:09:44]: recoveyCommand: update:update.zip prepareCommand:
[T 4][21:10:26]: copy successed:update.zip
[T 4][21:10:26]: send command : update:update.zip ok!
[T 4][21:12:41]: update:update.zip success(update:update.zip):eek:k
[T 4][21:12:42]: recoveyCommand: shutdown prepareCommand:
[T 4][21:12:42]: send command : shutdown ok!
 

·
Registered
Joined
·
50 Posts
Discussion Starter · #108 ·
i'm not going to touch this rom, if you want working netflix on 4.2 use one of my latest aosp roms
a bad news
but that's okay, I'm planning to go back to your PA
 

·
Registered
Joined
·
50 Posts
Discussion Starter · #110 ·
still. I put it on a flat surface. I can not reach terminal emulator, it constantly go to the settings menu by itself and touch screen sometimes work sometimes not.
 

·
Registered
Joined
·
50 Posts
Discussion Starter · #112 ·
mma8452

[email protected]:/ $ su
WARNING: generic atexit() called from legacy shared library
[email protected]:/ # getevent -p
add device 1: /dev/input/event2
name: "axp20-supplyer"
events:
KEY (0001): 0074
input props:
<none>
add device 2: /dev/input/event5
name: "ft5x06"
events:
KEY (0001): 014a
ABS (0003): 0030 : value 0, min 0, max 255, fuzz 0, flat 0, resolution 0
0032 : value 0, min 0, max 200, fuzz 0, flat 0, resolution 0
0035 : value 0, min 0, max 1280, fuzz 0, flat 0, resolution 0
0036 : value 0, min 0, max 800, fuzz 0, flat 0, resolution 0
input props:
<none>
add device 3: /dev/input/event4
name: "mma8452"
events:
REL (0002): 0002 0006 0007 0008 0009
ABS (0003): 0000 : value -24, min -2048, max 2047, fuzz 0, flat 0, resolution 0
0001 : value 33, min -2048, max 2047, fuzz 0, flat 0, resolution 0
0002 : value -1009, min -2048, max 2047, fuzz 0, flat 0, resolution 0
0018 : value 0, min 0, max 0, fuzz 0, flat 0, resolution 0
0019 : value 0, min 0, max 0, fuzz 0, flat 0, resolution 0
input props:
<none>
could not get driver version for /dev/input/mice, Not a typewriter
add device 4: /dev/input/event3
name: "AML-RT5631 hp switch"
events:
SW (0005): 0002
input props:
<none>
add device 5: /dev/input/event1
name: "key_input"
events:
KEY (0001): 0074
input props:
<none>
add device 6: /dev/input/event0
name: "adc_keypad"
events:
KEY (0001): 0066 0072 0073 008b 009e
input props:
<none>
[email protected]:/ #
 

·
Registered
Joined
·
50 Posts
Discussion Starter · #116 ·
Try this.

If it still doesn't work i'll to enable some debug stuff and you'll have to see what's going on from "adb shell" "tail -f /tmp/recovery.log"
It seems now all been normal, except can't mount cache, and device not detected on adb. So i just copy log to SD
Starting TWRP 2.4.1.0 on Sun Feb 10 18:03:48 2013
I:=> hardware id from cpuinfo: 'Amlogic Meson6 g06 customer pl'
I:=> serial from cpuinfo: '000000000000000c'
I:Internal path defined: '/data/media'
I:External path defined: '/sdcard'
I:Mount: Unable to find partition for path '/data'
TW_NO_REBOOT_BOOTLOADER := true
RECOVERY_SDCARD_ON_DATA := true
I:Lun file '/sys/class/android_usb/android0/f_mass_storage/lun0/file'
Starting the UI...Pixel format: 1280x800 @ 32bpp
Pixel format: RGB_565
framebuffer: fd 5 (1280 x 800)
=> Linking mtab
=> Processing recovery.fstab
I:processing '/boot'
I:processing '/system'
I:processing '/cache'
I:Unable to mount '/cache'
I:Actual block device: '/dev/block/cache', current file system: 'ext4'
I:processing '/data'
I:processing '/sdcard'
I:processing '/sd-ext'
I:Created '/sd-ext' folder.
Updating partition details...
E:Unable to mount '/cache'
I:Actual block device: '/dev/block/cache', current file system: 'ext4'
I:Data backup size is 211MB, size: 12732MB, used: 225MB, free: 12344MB, in data/media: 13MB.
I:'/sdcard' was 'exfat' now set to 'vfat'
I:Unable to mount '/sd-ext'
I:Actual block device: '', current file system: 'auto'
I:Unmounting main partitions...

Partition Logs:
/boot | /dev/block/mtdblock4 | Size: 8MB
Flags: IsPresent
Primary_Block_Device: /dev/block/mtdblock4
Display_Name: boot
Backup_Path: /boot
Backup_Name: boot
Current_File_System: mtd
Fstab_File_System: mtd
MTD_Name: boot
Backup_Method: flash_utils

/system | /dev/block/system | Size: 881MB Used: 451MB Free: 430MB Backup Size: 451MB
Flags: Can_Be_Wiped Wipe_Available_in_GUI IsPresent
Primary_Block_Device: /dev/block/system
Display_Name: System
Backup_Path: /system
Backup_Name: system
Current_File_System: ext4
Fstab_File_System: ext4
Backup_Method: files

/cache | /dev/block/cache | Size: 0MB Used: 0MB Free: 0MB Backup Size: 0MB
Flags: Can_Be_Wiped Wipe_During_Factory_Reset Wipe_Available_in_GUI IsPresent
Primary_Block_Device: /dev/block/cache
Display_Name: Cache
Backup_Path: /cache
Backup_Name: cache
Current_File_System: ext4
Fstab_File_System: ext4
Backup_Method: files

/data | /dev/block/data | Size: 12732MB Used: 225MB Free: 12344MB Backup Size: 211MB
Flags: Can_Be_Wiped Wipe_During_Factory_Reset Wipe_Available_in_GUI IsPresent Has_Data_Media Is_Storage
Symlink_Path: /data/media/0
Symlink_Mount_Point: /emmc
Primary_Block_Device: /dev/block/data
Display_Name: Data
Backup_Path: /data
Backup_Name: data
Storage_Path: /data/media/0
Current_File_System: ext4
Fstab_File_System: ext4
Backup_Method: files

/sdcard | /dev/block/cardblksd1 | Size: 15185MB Used: 9227MB Free: 5957MB Backup Size: 9227MB
Flags: Can_Be_Wiped Removable IsPresent Is_Storage
Primary_Block_Device: /dev/block/cardblksd1
Alternate_Block_Device: /dev/block/cardblksd0
Display_Name: sdcard
Backup_Path: /sdcard
Backup_Name: sdcard
Storage_Path: /sdcard
Current_File_System: vfat
Fstab_File_System: exfat
Backup_Method: files

/sd-ext | | Size: 0MB Used: 0MB Free: 0MB Backup Size: 0MB
Flags: Can_Be_Wiped Wipe_During_Factory_Reset Wipe_Available_in_GUI Removable
Primary_Block_Device: /dev/block/cardblksd2
Display_Name: SD-Ext
Backup_Path: /sd-ext
Backup_Name: sd-ext
Current_File_System: auto
Fstab_File_System: auto
Backup_Method: files

I:Loading package: TWRP (/script/ui.xml)
I:Loading package: TWRP (/data/media/0/TWRP/theme/ui.zip)
I:Loading package: TWRP (/res/ui.xml)
I:Loading resources...
I:Loading variables...
I:Loading pages...
I:Loading page main
I:Loading page main2
I:Loading page install
I:Loading page flash_confirm
I:Loading page flash_zip
I:Loading page flash_done
I:Loading page clear_vars
I:Loading page confirm_action
I:Loading page action_page
I:Loading page action_complete
I:Loading page filecheck
I:Loading page rebootcheck
I:Loading page reboot
I:Loading page mount
I:Loading page usb_mount
I:Loading page usb_umount
I:Loading page wipe
I:Loading page backup
I:Loading page backupname1
I:Loading page backupname2
I:Loading page backup_run
I:Loading page restore
I:Unable to open '/data/media/TWRP/BACKUPS/000000000000000c'
I:Loading page restore_select
I:Loading page renamebackup
I:Loading page restore_run
I:Loading page settings
I:Loading page timezone
I:Loading page advanced
I:Loading page partsdcard
I:Loading page htcdumlock
I:Loading page lock
I:Loading page filemanagerlist
I:Loading page filemanageroptions
I:Loading page choosedestinationfolder
I:Loading page filemanagerrenamefile
I:Loading page filemanagerrenamefolder
I:Loading page filemanagerchmod
I:Loading page filemanagerconfirm
I:Loading page filemanageracction
I:Loading page decrypt
I:Loading page trydecrypt
I:Loading page terminalfolder
I:Loading page terminalcommand
I:Loading page sideload
I:Set page: 'clear_vars'
I:Set page: 'main2'
I:Switching packages (TWRP)
E:Unable to mount '/cache'
I:Actual block device: '/dev/block/cache', current file system: 'ext4'
E:Unable to mount '/cache'
I:Actual block device: '/dev/block/cache', current file system: 'ext4'
E:Can't mount /cache/recovery/command
Command: "/sbin/recovery"

ro.secure=1
ro.allow.mock.location=0
ro.debuggable=1
persist.sys.usb.config=mass_storage,adb
ro.build.id=JOP40G
ro.build.display.id=cm_elf2-userdebug 4.2.1 JOP40G eng.alan.20130210.175845 test-keys
ro.build.version.incremental=eng.alan.20130210.175845
ro.build.version.sdk=17
ro.build.version.codename=REL
ro.build.version.release=4.2.1
ro.build.date=dom 10 feb 2013, 18.02.02, CET
ro.build.date.utc=0
ro.build.type=userdebug
ro.build.user=alan
ro.build.host=Audrey
ro.build.tags=test-keys
ro.product.model=Nexus 7
ro.product.brand=Google
ro.product.name=nakasi
ro.product.device=grouper
ro.product.board=g06ref
ro.product.cpu.abi=armeabi-v7a
ro.product.cpu.abi2=armeabi
ro.product.manufacturer=Asus
ro.product.locale.language=en
ro.product.locale.region=US
ro.wifi.channels=
ro.board.platform=meson6
ro.build.product=grouper
ro.build.description=nakasi-user 4.2 JOP40C 527662 release-keys
ro.build.fingerprint=google/nakasi/grouper:4.2/JOP40C/527662:user/release-keys
ro.build.characteristics=tablet
ro.cm.device=elf2
sys.uses.ext4=1
ro.opengles.version=131072
hwui.render_dirty_regions=false
ro.sf.lcd_density=160
keyguard.no_require_sim=true
hw.cameras=1
ro.ui.cursor=osd2
ro.hardware=amlogic
sys.fb.bits=32
media.amsuperplayer.enable=true
media.amplayer.enable-acodecs=asf,aac,m4a,ape,flac,alac
media.amplayer.enable=true
media.amsuperplayer.m4aplayer=STAGEFRIGHT_PLAYER
media.amsuperplayer.defplayer=PV_PLAYER
media.amplayer.thumbnail=true
media.amplayer.widevineenable=true
media.amplayer.stopbuflevel=0.1
media.libplayer.seek.fwdsearch=1
gadget.nand.force_sync=true
ro.hdmi480p.enable=false
ro.vout.dualdisplay2=true
ro.vout.dualdisplay3=false
ro.sys.min_cpu_on=408000
ro.sys.min_cpu_off=96000
ro.sys.max_cpu_on=1320000
ro.sys.max_cpu_off=1008000
service.adb.root=1
ro.com.google.locationfeatures=1
ro.setupwizard.enable_bypass=1
dalvik.vm.execution-mode=int:jit
dalvik.vm.lockprof.threshold=500
dalvik.vm.verify-bytecode=false
dalvik.vm.dexopt-flags=v=n,o=v
dalvik.vm.dexopt-data-only=1
persist.sys.timezone=Europe/Rome
persist.sys.language=en
persist.sys.country=US
persist.sys.use_dithering=0
persist.sys.purgeable_assets=0
windowsmgr.max_events_per_sec=240
view.touch_slop=2
view.minimum_fling_velocity=25
ro.additionalmounts=/storage/sdcard1
ro.vold.switchablepair=/storage/sdcard0,/storage/sdcard1
persist.sys.vold.switchexternal=0
dalvik.vm.heapstartsize=8m
dalvik.vm.heapgrowthlimit=64m
dalvik.vm.heapsize=384m
dalvik.vm.heaptargetutilization=0.75
dalvik.vm.heapminfree=512k
dalvik.vm.heapmaxfree=8m
ro.com.android.dateformat=MM-dd-yyyy
ro.carrier=unknown
ro.rommanager.developerid=cyanogenmod
ro.url.legal=http://www.google.com/intl/%s/mobile/android/basic/phone-legal.html
ro.url.legal.android_privacy=http://www.google.com/intl/%s/mobile/android/basic/privacy.html
ro.com.google.clientidbase=android-google
ro.com.android.wifi-watchlist=GoogleGuest
ro.setupwizard.enterprise_mode=1
ro.com.android.dataroaming=false
ro.cm.version=10.1-20130210-UNOFFICIAL-elf2
ro.modversion=10.1-20130210-UNOFFICIAL-elf2
ro.config.ringtone=Orion.ogg
ro.config.notification_sound=Deneb.ogg
ro.config.alarm_alert=Hassium.ogg
net.bt.name=Android
net.change=net.bt.name
dalvik.vm.stack-trace-file=/data/anr/traces.txt
ro.factorytest=0
ro.serialno=
ro.bootmode=unknown
ro.baseband=unknown
ro.bootloader=unknown
ro.revision=32
init.svc.recovery=running
init.svc.brightness=running
init.svc.adbd=running

E:Unable to mount '/cache'
I:Actual block device: '/dev/block/cache', current file system: 'ext4'
E:Can't mount /cache/recovery/log
E:Can't open /cache/recovery/log
E:Unable to mount '/cache'
I:Actual block device: '/dev/block/cache', current file system: 'ext4'
E:Can't mount /cache/recovery/last_log
E:Can't open /cache/recovery/last_log
E:Unable to mount '/cache'
I:Actual block device: '/dev/block/cache', current file system: 'ext4'
E:Can't mount /cache/recovery/last_install
E:Can't open /cache/recovery/last_install
E:Unable to mount '/cache'
I:Actual block device: '/dev/block/cache', current file system: 'ext4'
W:Can't unlink /cache/recovery/command
I:Attempt to load settings from settings file...
I:Unable to mount '/cache'
I:Actual block device: '/dev/block/cache', current file system: 'ext4'
I:Unable to mount '' to write version number.
I:Switching packages (TWRP)
I:Set page: 'settings'
I:Set page: 'timezone'
I:Set page: 'main'
I:Set page: 'clear_vars'
I:Set page: 'main2'
I:Set page: 'advanced'
I:Set page: 'confirm_action'
I:Set page: 'action_page'
I:Copying file /tmp/recovery.log to /sdcard/recovery.log
 

·
Registered
Joined
·
50 Posts
Well, it's 2:15 am here and this is Monday

But before I leave, this stuff may be useful for those using Windows XP and want to use MTP.

The easiest way:
leave xp and go get vista or 7 system

The easy way:
install windows media player 10 or higher or Media Transfer Protocol Porting Kit

The tricky way:
1. open device manager>other devices>MTP>details. Select and copy (ctrl+C) "Hardware Ids" content
2. put your hardware ids to the code below

Code:
%GenericMTP.DeviceDesc%=MTP, PUT-YOUR-HARDWARE-IDS-HERE
3. open c:\windows\inf\wpdmtp.inf (hidden file) and replace --HERE--- text on spoiler with that code.

================
[Generic]
;
;Device is identified by Microsoft OS descriptor
;If your device does not support it, use specific VID & PID for identification
;
%GenericMTP.DeviceDesc%=MTP, USB\MS_COMP_MTP
--HERE--

[VendorModels]
================

4. open device manager>other devices>MTP>driver>update driver
5. tada..
 

·
Registered
Joined
·
50 Posts
This is how I managed to switch to other rom on my TM flame, and it should also work for QM

1. Go grab feiyu 0103: TM | QM
2. Extract and put uImage_recovery to the root of sdcard
3. Turn off the device
4. Press "volume-" + "power" (be patient)
5. Wipe data, cache, and media
6. Apply update from EXT (navigate to feiyu 0103 rom zip)
7. Reboot
8. Yes i know, the device reboot to the system recovery (3e) not to the rom.
9. Reflash feiyu 0103 without wipe
10. Reboot.. That's it!

Extra steps for TM with MMA GSensor
No need to cry, I know you stuck on bootanimation
Just go to the extra steps below..
11. Extract and put this TWRP to the root of sdcard (overwrite the old one)
12. Boot to that TWRP (dont ask me how)
13. Mount System
14. With TWRP built in File Manager, navigate to /system/lib/hw/ and delete sensors.amlogic.so
15. Reboot
16. You have been set free now

Otherwise go to this thread and pay attention to Compatibility zip > Fire Multiuser section.
 

·
Registered
Joined
·
50 Posts
Discussion Starter · #159 ·

·
Registered
Joined
·
50 Posts
Thanks it partially worked. After sticking at boot animation i overwrite it with 1031.
yes of course. the extra steps for mma gsensor just to make the rom boot up. Actually after the second flash the partition layout etc already fixed and ready for another rom


BTW i've moved on to pa multiuser based on this 0201 kernel
 

·
Registered
Joined
·
50 Posts
Discussion Starter · #168 ·
stay away from win8!

Sent from my Blade
 

·
Registered
Joined
·
50 Posts
Discussion Starter · #173 ·
Hi, seems I am stucked with this official one

Following steps above I have installed feiyu 0103, but since here I can not move anywhere else. CM10.1, Paranoid, Feyiu HSF, none of those is working for me.
Touch screen is not working in TWRP.
I was also able to flash 1031 but it does not help.
I should never left CM10.1 home
I have no idea whats wrong since dd_yulius with QM and me with TM have managed to flash feiyu 0103 and moved to another rom from there. And remember, 0103 have 2gb data partition. You need "something" to do to move to 1gb data partition rom like CM.
 

·
Registered
Joined
·
50 Posts
Discussion Starter · #247 ·
Can somebody upload it to some other server because bbs is pathetic and dropbox link says too much traffic so cannot give download links.
And i think i have to remove dropbox link. it's make my account suspended all the time

As alternative try this:
TM: Part1 | Part2
QM: Part1 | Part2
 
1 - 20 of 21 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top