Android Tablets Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
268 Posts
Flashed the ROM according to the tutorial here: http://www.myphone.gr/forum/showthread.php?p=4533949#post4533949

The problem is that after enabling Google Play services (i.e set-up my account) the system at 5 second intervals pops up messages like "unfortunately process android.process.acore has stopped" which is not fatal, but it's very annoying.

Tried all suggested solutions (clear Contacts, Google, etc app data), seems to stop for a while, but after re-entering my Google account data, it appears again
 

·
Registered
Joined
·
268 Posts
Can anyone with a better English explain how exactly this Contacts.apk thing has to be done because I didn't get it from this post. Do I have to tap on the contacts.apk from the app folder after changing permissions to install it or just exit the file explorer and restart.
Just copy Contacts.apk in /system/app using ES File Manager, change the file permissions to rw-r--r-- and reboot.
 

·
Registered
Joined
·
268 Posts
shoot i wanted to install this firmware to create a 4.2 comp zip with real multi user support, only for the fire but I can't.

I tried following all rules but if I select the "erase nand" thing after it finishes the device is not recognized anymore, if I unplug and replug it to flash the zip without the erase nand thing it fails loading uboot and I have to flash the unbricker.

If I try to flash directly the zip without erase nand before that it stays at 77% for something like 10/15 minutes, after that i turn if off and procede with the unbrick again.

Terrible firmware delivery system.
The system is a bit picky, but it works.
Let's start from the beginning (you can also read my tutorial in myphone.gr using Google translate - see OP).
Start by selecting "erase nand" AND "no hub support". The tricky part is to put the device in uboot loading mode; assuming that you've already installed the necessary AMLburningtool USB drivers, press and hold either POWER+VOL- or POWER+VOL+ until you see AMLtool recognize your Fire. Flash the first part and when it finishes (indicated by a GREEN port icon), press STOP and disconnect the tablet.

Next, uncheck "erase nand" but leave the other option checked (no usb hub) and try the same procedure again (POWER+VOL- or POWER+VOL+) until the tool recognizes the tablet. Then START and flash the actual ROM.
 

·
Registered
Joined
·
268 Posts
Yes I've tried, it gets stuck, I hit stop, unplug and turn off the device, turn if on with power+vol-, connect to usb (it's recognized as chip M6 and detected on another port), hit start again, uboot failure.

Tried on a native windows 7 (as admin, no av and no firewall since i never use 7) and an emulated xp.

That's the log from xp

current pc version is: xp
current tool version is: v1.6.2.0128
-----importUpgradeFile-----filenameC:\Documents and Settings\Alan\Desktop\Ainol-E4-20130201-tima-usbburning.zip
[T 0][14:51:56]: load spl ...
[T 0][14:51:57]: load uboot ...
[T 0][14:51:58]: test command exec: crc 0x8f800000 520348 4e80a205
[T 0][14:52:01]: command exec:set_chgcur 0
[T 0][14:52:02]: command exec:video dev bl_off
[T 0][14:52:03]: command exec:video dev disable
[T 0][14:52:04]: command exec:sf probe 2
[T 0][14:52:05]: command exec:sf erase 0 1000
[T 0][14:52:06]: command exec:nand rom_protect off
[T 0][14:52:07]: command exec:nand scrub 0
[T 0][14:52:18]: command exec:nand info
[T 0][14:52:19]: command exec:defenv
[T 0][14:52:20]: command exec:setenv bootargs ${bootargs} a9_clk_max=600000000
[T 0][14:52:21]: command exec:setenv recovery_command --usb_burning
[T 0][14:52:22]: command exec:save
[T 0][14:52:24]: load uimage ...
[T 0][14:52:30]: Transfer Complete! total size is 4704256 Bytes
[T 0][14:52:38]: test command exec: crc 0x82000000 4704256 cc9e1542
[T 0][14:52:38]: command exec: crc 0x82000000 4704256 cc9e1542
[T 0][14:52:38]: sendCommandWithReply: crc 0x82000000 4704256 cc9e1542 maxCount:30
[T 0][14:53:33]: command exec once more: load uimage
[T 1][14:54:40]: load spl ...
[T 1][14:54:40]: Transfer Complete! total size is 18712 Bytes
[T 1][14:54:49]: load uboot ...
[T 1][14:54:50]: load uboot ...
[T 1][14:54:51]: load uboot ...
[T 1][14:54:52]: load uboot ...
[T 1][14:54:53]: load uboot ...
[T 1][14:54:54]: load uboot ...
[T 1][14:54:55]: load uboot ...
[T 1][14:54:56]: load uboot ...
[T 1][14:54:58]: load uboot ...
[T 1][14:54:59]: load uboot ...
[T 1][14:55:00]: load uboot ...
[T 1][14:55:01]: load uboot ...
[T 1][14:55:02]: load uboot ...
[T 1][14:55:03]: load uboot ...
[T 1][14:55:04]: load uboot ...
[T 1][14:55:05]: load uboot ...
[T 1][14:55:07]: load uboot ...
[T 1][14:55:08]: load uboot ...
[T 1][14:55:09]: load uboot ...
[T 1][14:55:10]: load uboot ...
[T 1][14:55:11]: load uboot ...
[T 1][14:55:11]: load uboot failed 15 times,maybe because the spl code run err
[T 1][14:55:12]: failed because no connected device ,current step is 1

When it fails there's no other option then unbricking it since it always goes in m6 chip mode.

They're great in screwing things, I have to admit it. The light sensor is another example, it was perfectly working and now in direct noon sunlight doesn't report more than 10 lux

The cute thing is that if I wanna bypass that *shiny software and flash bootloader.img from that rom it finishes in chip m6 mode too.
Do you have a micro SD card inside when doing thid?
If yes, remove it, as it seems the aml tool hangs at that stage if a MICROSD card is found.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top