Android Tablets Forum banner
Not open for further replies.
1 - 1 of 1 Posts

· Premium Member
2,102 Posts

We have a significant problem with some users' ability to set up the ADB because of windows problems. My hope is to get all the solutions in one, stickied, closed, up front post, so we can make it easier for everyone. This is a work-in-progress. I'm not done, I'm still working on it. This problem seems most common in vista and in 64-bit Windows builds. My hope is to find a series of options that ultimately solve every instance of this problem without further board-clutter on it.

This refers to a ".inf" file from the zip put up on the site by Nate the Great. Realize that other packages may include .inf files of the same name, and you may need to keep Nate's files in a separate directory.Nate's hack files have worked, without variation, for a lot of people Beginners Guide to hacking the Pandigital Novel

Some people have found that deleting all of the usb drivers under control panel/system/device manager (hardware) with the device unplugged, then plugging it in and pointing to the .inf file in Nate's files when it asks for drivers has worked.Some people have found that going to the "unidentified driver" icon (usually "Android Composite ADB Interface" or "USB Composite Device" with a triangle and exclamation point) in control panel/system/device manager (hardware), right-clicking, then telling it to update the driver, and then telling it not to search for a driver but pointing it to Nate's .inf file from his files (whatever directory you have that in) has worked.

Some people have found that they have had to edit the .inf file in nate's files because their device id either is not the same as his was, or has changed due to a reflash or some added software.Meth pointed out how to do this the hard way, and I quoted him here: pandigital novel rooted [shamelessly stolen from Mogrith, who deserves all credit]

No ADB driver in Win 7 Fix This is the short version!

A. Be sure you have drivers from SDK.

  1. Run sdk setup in sdk folder
  2. Check for USB drives in installed packages. If there goto step B
  3. Select update all and accept the usb driver package.

B. Open Device manager

  1. click on actions select Add legacy hardware
  2. select 2nd option Install the ...
  3. Double click show all devices then click on have disk
  4. Enter path to Android SDK USB drivers finish the Wizard.

C. Open Devices and Printers

  1. Right click on android device select properties
  2. hardware tab update drivers or change settings
  3. select android phone ADB interface ---offered by HWgeek for MAC users.
    1. Go to Android SDK | Android Developers and download the current SDK
    2. File is zipped. Unzip. You will get android-sdk-xxxx (where xxxx version/platform)
    3. Move this folder to whereever you want to keep the SDK
    4. In subfolder tools is adb
    5. open up a terminal window, navigate to the folder android-sdk-xxxx/tools
    6. Turn on and plug in your Pandigital novel to your mac
    7. ./adb device <-- this will run the adb program, first time it will start up the adb daemon
    8. output should look like:List of Devices attachedPD_Novel devices

These have not solved all instances of this problem. It is not a Pandigital Novel problem, but a windows driver problem. I'm still working on it.Please pm me with constructive ideas for how to add to or clarify this, if you think something needs to be added, changed, or you find something that works. Do not pm me to whine or ask for help directly, I will be overwhelmed and stop reading the pms.

Edited 3/24/11 (format fixes) Please report any broken links or additional mistakes. Thanks, -MrsB
  • Like
Reactions: mrsburnout
1 - 1 of 1 Posts
Not open for further replies.