Android Tablets Forum banner
241 - 248 of 248 Posts

·
Registered
Joined
·
1 Posts
Sorry for ressurect this old Post!

I didn't use my Hannspad since an year now. Some weeks ago I decided to change this situation by installing an other system on it.

I decided to use a mer based plasma active system and maybe later sailfish os beacuse it is also mer based. With using the v5 kernel from imayoda, I managed to boot my system from sdcard.

But in fact 3D driver is missing and I have to use fbdev in X, the system is unusable.

So I tried now for several days to compile my own kernel for this. Since kernel 3.10 there is Tegra2 support in mainline kernel. Actually I use kernel 3.13.

But I don't get my system to boot. I tried to unpack bootv5.img and repack it with my own kernel zImage, but it only works with original zImage. I'am using "mkbootimg" and "unmkbootimg" for this task.

I have already tried it with an old Tegra4Linux kernel, but the same problem. I also tried to use same config for this with old kernel.

I used gentoo since years know and also on different other arm devices (raspberry-pi, odroid-u3). Because of this configuring and compiling a kernel ist not that hard task for me.

I tried to crosscompile it on my gentoo 64bit machine and I also tried it natively on my odroid but it doesn't boot.

I think I miss something essential and I hope somebody can help me...i'm not very familiar with the tegra stuff.

@imayoda (or anybody else):

can you provide me a guide how you manged to compile your kernel an packed it to a boot.img?

I realized that your ramdisk ist empty?!?

I would appreciate for any help!
 

·
Registered
Joined
·
384 Posts
Discussion Starter · #246 ·
hi there, in order to use those filesystems you need to compile a soft float kernel.. ubuntu now switched to hard float and i belive even the arm compiler.

yes, ramdisk is full of zeroes..

i suggest you to append "rootwait" to the kernel cmd, or it will not boot past kernel.

where is your kernel hanging? do you have some output?

it's quite interesting the 3.x kernel because 2.6 was very limited at that time i was trying to improve ubuntu.
 
241 - 248 of 248 Posts
Top