Android Tablets Forum banner
1 - 20 of 248 Posts

·
Registered
Joined
·
384 Posts
Thanking Gtab/Vega dev slm4996, now, after some tinkering, we can boot native ubuntu on out tablets.

Disclaimer:
This operation has no guarantee and can seriously damage your hard worked, money earned Tablet. I'm not responsible for any damage you do on your hardware. You do this at your own risk.
This even require some skills using linux console and nvflash, so this is your last chance to stop if you feel unsure about it..

What you need:
-Sd card (at least 4GB and good class of 4 or more..)
-nvflash ready to work
-Hannspad

How to:
-Prepare a fresh SD with ext2 or ext3 partiotion on it (at least 3GB). There are many ways to make it; parted, gparted, fdisk etc. etc. choose what you love.
--it is important that ext partition on SD card is the first one on it. You can get a second partition on Fat32 (decide your size) so that android will mount it and you'll be able to use the same SD card... optionally you can even make a third partition SWAP.. if you want to get some extra speed under some circumstances (128-512MB will be enough) Warning! SWAP may kill faster SD cards

-use nvflash to put boot.img on the 11 partition (make a backup before as it is your recovery.. after this procedure you will still be able to boot android but there will be no more recovery. It will be converted into your ubuntu kernel+ramdisk boot.)
WARNING
Latest android roms have different partition layout so you might need to change the 11 with 9, the actual recovery partition.

Code:
nvflash --bl bootloader.bin --read 11 recovery-backup.img<br />
nvflash --resume --download 11 boot.img --go
#######alternate kernel flash method#######
you can proceed to kernel flash (or recovery restoration) by android root shell
Code:
su<br />
flash_image recovery /sdcard/bootv5.img
#######
you have to put bootv5.img in internal sdcard
-next step is to explode rootfs.tar.gz into the root of the ext partition on the sd cards preserving folder scheme and permissions. (be also aware to expand the tar file inside the sd.. cd to it)

Code:
tar xzvpf rootfs.tar.gz -C /path/to/sdroot
Once you're done, insert SD, hold volume+ and power until you read on the screen "recovery key detected"..
Enjoy!

password is "user"

Improvements (first public version):
-kernel cmd rootwait.. our tegra behaves strange on mmc detection
-fixed some gdm errors
-improved composition; now some transparency and hinting is activated.
-larger scrollbars and panels on default theme.. easy to use with fingers
-uninstalled firefox and installed midori... it's waaaay faster

I don't know the status of:
-OTG usb
-bluetooth
if you can test, please leave a feedback

Files:
boot.img
rootfs.tar.gz no longer available

Version 2
Improvements:
-brand new kernel built with linaro gcc (faster) vram "hacked" (430 MB available for system)
-zram swap (64MB in memory compressed cache.. yes black magic
) hardcoded inside kernel
-usb OTG should work and some usb drivers included (try it cause i have not and OTG adaptor..sad)doesn't work

-fstab mounting noatime (best sd writes reduction possible)
-openssh server listening on port 22 on any IP address
-right click emulation (there's a mouse icon near processors, if you press it and fast point to your target you'll get right click... black magic too until better touch support)
-better accessibility in panels and keyboard
-some minor bugs fixed in userspace

remember to flash both bootv2.img and rootfsv2.zip (unzip it first)

Files:
rootfsv2.tar.gz.zip no longer available
bootv2.img

Version 3
Improvements:
-os upgraded to 11.10 Oneiric Ocelot (some setbacks on machine halt.. guess there will be ubuntu update for them)
-long press to emulate right click (how to: tap and re-long-tap and wait a second... try to be precise as pixel radius is very small)
-32MB framebuffer and more than 440MB for system
-zram revisited for max 32MB ram occupation
-browser changed to chromium with finger scrolling enabled (bit buggy too)
-flash... ehm... gnash enabled (still very slow but flash working on sites)
-possibility to set max tegra frequency by the lower-right sputnik button (1GHz for 2 minutes)
-somewhat smoother on faster cards
-vnc server listening on port 5900
-ssh server listening on port 22

remember to flash proper boot.img (v3 one)

Files:
bootv3.img
rootfsv3.tar.gz no longer available

Sadly for me it's end of line.. so no more developing it as long as nobody helps with kernel.. sry


Update
Help arrived fortunatelly from Mambasoft (aka master-chief in openmamba distro -->have a try with it<--)
Many many many, almost infinite thanks to him !

Version 4
Improvements:
- faster
- fasterrr
- USB activated in Host mode (still requires external powered hub)
- Working WIFI + BT
- Usefull hw buttons everywhere
- Almost working standby
- 1.2GHz overclock

Files:
bootv4.img flash with nvflash
bootv4.img.tar.gz kernel v4
precise-beta.tar.gz UBUNTU 12.04 ROOTFS
11.10xubuntu.tar.gz XUBUNTU 11.10

UPDATE V5
Version 5
Improvements:
- faster compressor for zram memory (snappy)
- added modules for DM9*** ethernet chipsets (request)

Files:
bootv5.img.tar.gz flash with nvflash
modules.img.tar.gz overwrite original /lib with the one contained inside this tar (do it as root user)

IMPORTANT NOTE
- do a filesystem check/repair after tar extraction.. easy peasy in gparted (it will correct inodes)
- Precise Unity image is quite unstable, frequent crashes and has low memory to work with..
- Oneiric Xubuntu is the one you should use, as it works very good, stable and has enough free ram for even gimp or internet browser.. if you want flash in browser, issue
Code:
sudo apt-get install gnash mozilla-plugin-gnash
.. 360p works good
- both versions have right click binded on menu button, other editable functions are bindable to the other capacitive keys.
- xubuntu supports better long press for right click emulation
- Audio still not working, so if anybody has some experience on alsa and soc, could use to give a hand
 

Attachments

·
Registered
Joined
·
2 Posts
Can anyone comment on the performance of xubuntu on the hanspad? I guess my biggest question is can it handle movie playback ok? If it can then trivial things like browsing the net, playing mp3s etc it should be fine with .... just curious as I may buy a second hannspad to replace the computer in my car
 

·
Registered
Joined
·
67 Posts
The installation won't work for me

Can somebody make a video tutorial, please?!
rofl!!

Perhaps it would be easier if we sent someone to your house to install it for you?

This is clearly VERY early days for the experts that know what they are doing to have a play. If this is beyond you then back off and wait for it to mature.
 

·
Registered
Joined
·
211 Posts
Perhaps it would be easier if we sent someone to your house to install it for you?
Let's take him up on this offer !
*cough*sorry


4dro1d, I can't give you a video tutorial because I can't do this myself due to a lack of 4gb micro-sd card, but are you definately running this through linux, or are you attempting it from within a windows install?

Don't want you to think I'm treating you as an idiot or anything, but if you fail to notice the instructions are from a linux install/live-cd (ubuntu or puppy linux will work well) then you'll get unstuck pretty quick (and I myself have happily followed instructions without noticing system requirements
).

Chief
 

·
Registered
Joined
·
384 Posts
Discussion Starter · #13 ·
View attachment 2557

thank you guys for your help! -.-
it's booting....!!!!
i think you're getting errors maybe for a corrupted sd card installation (bad superblock error) try to repair the filesystem or maybe just reinstall... is it booting?

can anybody confirm that's working.. any suggestions or bugs found .. i'm goin to optimize the filesystem a lot before diving inside kernel research so any advice is appreciated
 

·
Registered
Joined
·
384 Posts
Discussion Starter · #18 ·
true dual boot is still far.. however, with CWM sacrifice we can actually dual boot os (eg. ubuntu + android)..

only pain is when you need recovery operations for android.. you'll have to download the recovery from the market and after all reinstall boot.img over CWM again (in order to get ubuntu armed again)

btw:

working on right click emulation and filesystem improvements..

i'm pretty sure that you can really enjoy ubuntu on decent sd cards (class 6 or better)

i have a class4 and it saturates in multitasking i/o
 

·
Registered
Joined
·
35 Posts
Looking good but I do not get any virtual keyboard so how do I enter the password? It boots to the gdm login screen after a few dialogs with error messages but there is no way to enter the password.
 
1 - 20 of 248 Posts
Top