Android Tablets Forum banner

Orphan M7003 rom dump.tar for stock firmware

50078 Views 177 Replies 38 Participants Last post by  Labovski
I followed the directions from this post How to /dump/ the ROM image ? - Android @ MoDaCoto get the /system files off of my stockish m7003. There are links on that forum of how to make both a system.img or update.zip from that kind of file. I'm not sure what to try though. What method have you guys tried to use to flash the bad images to your devices. I can't get mine to talk to my computers(vista,linux), so I'm not sure where to go from here.Here is the dump.http://dl.dropbox.com/u/5705143/dump.tar
1 - 20 of 178 Posts
Thanks a million for the dump. My device needs the original firmware to come back alive. hope that someone can help you achieve this.
Did you flash bad firmware to your device? If so what method did you use. I can't get my into a recovery mode or to connect to my computer.
Is there a method that can be used to make a script file? This is the best way to flash firmware on this device.
Bad firmware. Used a script folder.
Do you hold any buttons special to get a script folder to upload? There are some links on the forum I posted above that makes a update.zip which looks similar formatted to the script folders.
No. You place the script folder in a microsd card formated, then you insert it into the apad when it is turned off. Then you turn it on and it starts to flash. After it is done, it will tell you to remove card and the device reboots... your done with the flashing process.
Has anyone tried any M001 roms? I'm trying to gauge how similar the core of the devices are. Might be able to incorporate my dump into one of those scripts. Can someone try those firmwares for me? Don't want to brick mine yet till we know we don't need anything else off of it.Mine is running the same CPU and kernel as the M001 already.
First OFF YOU ROCK!!! thanks for getting this out there. To answer your question m001 is very similar to what we have on the m70003 only major difference is the battery settings, which could be an issue, and the touchscreen drivers and button config. Other than that m001 OSs' runs smoothly on the m70003
So does anyone know how the drivers for the touchscreen work. I see in some of the m001 firmwares there are Touchscreen.ko drivers. Are these in the filesystem somewhere where I could take it out of my stock device? Or does it not stay in that format?Could we inject the touchscreen driver into the m001 firmware? Thats the main problem right? The touchscreen doesn't work?
I am realy looking forward to this getting ready as a script folder. I mistakenly flashed Ecotox's Script on my M70003 and now my home bottons do not work, thus locking my screen. As Xnorex stated everything else seems to run OK even a USB mouse.
So far I've tried untaring android_fs.tgz and replacing the system folder with the system folder provided in iplays dump file on Ecotox's firmware and no luck, it loads but goes black. Im still looking up how to create a script folder but no luck so far. Really wish one of the devs on this board would chime in, I think by now we deserve a sticky in one of the Dev forums!
i have tried flashing all the roms available slatedroid 1.2, ecotox... they are all the same, touchscreen, buttons doesn't work.matt
http://dl.dropbox.com/u/5705143/dumptwo.tar Whole filesystem UserSpace is huge. Sorry for the size 1.5GBI'll point out that the tar is corrupted(maybe) but I think you can still use parts. I couldnt get the exclude command to work.I've noticed alot of the files on my stock device are the same or named the same as the ecotox firmware. Files I think have to do with the drivers.What you someone should try first. In another forum I asked about the key mappings. So try taking the files from /system/usr/keylayout from my .tar (old on will work) and put them into the ecotox firmware. The goal here is to see if we can unlock the screen first. Remove the files in that folder from the ecotox firmware and replace with the files from mine. They are different.Let me know how this turns out. You can also try replacing the .ko files in the ecotox firmware with the ones in my new tar. In the exotox firmware they are in two places, in the android_fs and the drivers folder.P.S. I really have no clue. Surely theres someone who knows that can chime in.
See less See more
This is great Guys. I know that soon we will. Have a working script file.
I tried downloading DumpTwo but i can't, are you able to just up the *.ko files? or is this file uploaded anywhere else? if you need places to upload it to let me know.
ok never mind, I'm downloading it with IE apparently there is an issue when trying to download it with chrome. Once I get this I'll try what I can!
[quote name='xnorex;8497]ok never mind' date=' I'm downloading it with IE apparently there is an issue when trying to download it with chrome. Once I get this I'll try what I can![/QUOTE'] Wierd, first time I tested the Dl it started fine. Second time it didn't start. Both in chrome.
1 - 20 of 178 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top