Android Tablets Forum banner
101 - 104 of 104 Posts

1,014 Posts
Discussion Starter · #101 ·
Yes fards, you. You are mentioned a couple of times here:

You mean pulled in the patches from the github repo you are working on? It's been a little while. Suppose I should give that a shot.
However I also made the realisation that Ubuntu has far better support for compiling ARM than Debian so I set up a VM and grabbed what I needed.

Another motivation was realising what was supported in my little experiments.
<br />
make ARCH=arm ARM_CPU_TYPE=cortex-a9 CROSS_COMPILE=arm-linux-gnueabi- uImage<br />
The cortex-a9 option specifically.

When I get a little time I'm going to put together an SD card that a self built linux kernel actually has a hope of doing something on, turn on kernel debugging to file and see what happens. IF I can get a current kernel to get partway through booting even with hardware support for pretty much everything disabled I'll be very happy indeed.

edit: I mean kernel logging. I have kernel debugging enabled already..
I actually meant the entire /customer to use their drivers etc

1 Posts
Sorry to revive an old thread but this is driving me completely nuts!

Hopefully you guys can help me out, I've been trying for a few days to compile my own module for Geniatech ATV120 (same kernel as ATV1200 and it seems its the same kernel as the Elf II), I've gotten as far as compile the modules and first I got Exec Error, but after making the changes to get the exact kernel version I now get "disagrees about version of symbol module_layout"

A user by the name of fma965 built a module hid-sony.ko and it works perfectly on my atv120, but fma965 has told me that he forgot how he did it and lost all files related to this

so I did this:
modinfo hid-sony.ko and I got this
filename: hid-sony.ko
license: GPL
alias: hid:b0003v0000054Cp0000024B
alias: hid:b0005v0000054Cp00000268
alias: hid:b0003v0000054Cp0000042F
alias: hid:b0003v0000054Cp00000268
vermagic: 3.0.8-g525c782 SMP preempt mod_unload modversions ARMv7
I did the same for my module
filename: joydev.ko
license: GPL
description: Joystick device interfaces
author: Vojtech Pavlik
alias: input:b*v*p*e*-e*1,*k*2C0,*r*a*m*l*s*f*w*
alias: input:b*v*p*e*-e*1,*k*130,*r*a*m*l*s*f*w*
alias: input:b*v*p*e*-e*1,*k*120,*r*a*m*l*s*f*w*
alias: input:b*v*p*e*-e*3,*k*r*a*6,*m*l*s*f*w*
alias: input:b*v*p*e*-e*3,*k*r*a*8,*m*l*s*f*w*
alias: input:b*v*p*e*-e*3,*k*r*a*0,*m*l*s*f*w*
vermagic: 3.0.8-g525c782 SMP preempt mod_unload modversions ARMv7
so everything seem correct, when to load it with insmod on my ATV120 and I got the "disagrees about version of symbol module_layout" error
ok, back to ubuntu. ran this:

modprobe -dump-modversions hid-sony.ko
0x4e362f07 module_layout

I noticed the module layout so I ran the same on my module
modprobe -dump-modversions joydev.ko
0x82bedd05 module_layout

that seems to be my problem, I know nothing about module layouts, but doing some google research I found I need the same Module.symvers but for the life of me I just cannot get the same one, can anyone help me out building modules with this 0x4e362f07 module_layout ?
I am using this source: git://
I also tried with the 2013 source, but could not even get it to compile :S

I extracted the Module.symvers from my running kernel, by unpacking the boot.img and using a python script, but when ever I copy the Module.symsver on my compile folder it gets overwriten byt the one generated, so it makes no difference

any idea or help would be GREATLY appreciated!


2 Posts
101 - 104 of 104 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.