Android Tablets Forum banner

Need Help Updating Firmware ONDA vx610w

15013 Views 25 Replies 9 Participants Last post by  petrb123
I've had no problem updating an ainol advanced, because there are easy to follow directions online, but I cant seem to manage to update the firmware on the Onda vx610w.

My issue occurs when you come to the point on livesuit where you are suppose to press down on a key while you push down on the power button several times. I feel like Ive tried everything. Ive pressed down on the home key and then connect my tablet to laptop then push down on power 10 times, but it doesnt work. Ive tried the same with the menu and the escape button. Ive even tried simply pushing down home key and these keys at the same time.

Whenever I connect my tablet.. I hear it connect to the laptop before within a second before Im able to do anything. Then a yellow exclamation pop up appears.

Help would be much appreciated. This is really frustrating.

Update: I found a guide online that said it was necessary to turn it off, unplug it. Then push down the menu button and reconnect it.. It still doesn't work I only get a yellow exclamation pop up. What am I doing wrong?
1 - 1 of 26 Posts
I had also same flashing problem. I have ONDA VX610W deluxe V5 and these steps work for me:

1) turn off tablet
2) hold menu button
3) connect usb cable
4) 3 times press power button (still hold menu button)
5) livesuit recognize tablet and I can move on to flash tablet
1 - 1 of 26 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.