Android Tablets Forum banner
1 - 1 of 1 Posts

1 Posts
Discussion Starter · #1 ·
Greetings fellow Slatedriods!

Sorry for resurrecting this side of the forum, however I recently found a couple of these MK808 Andriod TV stick devices I had in storage. Since I have had a lot of fun with Raspberry Pi's ( especially the Pi3 and both the Pi Zero and Zero 2 ) It would be interesting to see how well these Rk3066 based devices run under Linux.

Now, I have had these devices for quite a while and I have Rooted and Flashed the firmware of these devices many moon's ago, I think the very day I got them, and they are currently running a FinlessBob 1.7 ROM.

I fired these up to see if they are still working as I seriously doubt that either of these have been power cycled in about 8 years , I am pleased to say that both devices power up and load into the Andriod OS 4.1.1

Build :
2013-03- finless.1.7c
rk30sdk-eng 4.1.1 JRO03H Finless MK808 1.7c rom test-keys

I should point out that both have "Superuser" installed under Android

The PCB's are silk-screened with "MK808B_V1.0_2012.10.24"

So I found this site that detailed the process of getting a build of Debian, Picuntu and Ubuntu onto these devices - and this is where the problems begain.

Getting the Device to flash the Olegk0 linux kernel.

No matter how I try under Windows 10, I cannot get the ADB drivers to install and recognize the connected device - it does show in device manager - however no matter the varient of ADB drivers I use, the latest being "Rockchip_DriverAssitant_v4.4" it simply cannot start the device and as such the Flashtool cannot see the device to write too.

Since I have a seperate Windows 7 PC, I tried the same again with the following drivers

The device was connecting in the correct boot mode ( power cycling the OTG usb port while holding reset button - no video display ) - Windows knows the deviced connected however it cannot start the device.

( Rockchip_Android_Tool_v1.37 )

( DriverAssitant_v4.8 )
DriverVer= 08/28/2014,11.0.0000.00000

As with Windows 10, even under Windows 7 neither of these drivers worked with the OS, no matter how I tried.

I probably spent way to much time with this looking for working ADB drivers ( I have some that worked for the Kindle perfectly fine so I know its not a connectivity issue. despite my efforts I could not get windows drivers to work with the RK3066/MK808 devices. However, not to be defeated, I knocked together a Debian Linux box from an old HP dn7600 series PC - after installing I attmpeted to follow this guide from Afonso Raposo - as this method flash the Kernel and NAND from a host Linux -

Afonso Raposo was able to get a Debian build running in 2020 - I followed the guide and was able to get the rkflashtool to compile after modifications, althought with depreciated warnings - however while it would claim the device for programming - it just halted.

( this was in SuperUser Root account in Terminal )

Every read / binary dump of either the Kernel / ROM or Perameters of the NAND returned an empty file.

As with above the MK808 device was booted into the correct mode ( powered and connected by the OTG usb port and with the reset button pressed down on boot - no video was displayed )

Using "lsusb" It was stated to be in boot loader mode.

So clearly I have either messed something up, miss-read instructions and or skipped an obvious step - however its mostlikely all three.

I was wondering since I have Superuser installed on both of the devices - could I not use this in someway to flash the kernel and or NAND? is there a newer Flashtool for Linux that I could try?

Currennt Kernel Version :
lfwang_V_300j1 #28
SMP PREEMPT Thu Jan 10 14:29:47 CST 2013

So fi you have any ideas on how I can get the Kernel onto this device ( JTAG is an option ) I would humbly appreciate it.

Thanks for reading fellow Slatedroid!

(all posts made with recycled bits)
1 - 1 of 1 Posts