Android Tablets Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
15 Posts
I have been fooling around trying different roms, editing build.prop to get full market, editing RT2870STA.dat to get better wifi connection, editing init.sh for better sound.

Got it to where it was pretty good using uberoid v8 and modroid v9, still having sporadic issues with wifi but I found a solution and have tested several roms and modroid v11 is what I am settled on as it suits my needs perfectly and is quick and streamlined.

Now wifi works great, I am running 1.5.3, full market etc...

Here is how I fixed the wifi issue:

Followed this post - http://techknow.freeforums.org/how-to-get-wifi-working-when-all-else-fails-proven-method-t1120.html

basically I need to get a working rom (original manufacturer or custom like uberoid, modroid or udroidx)
All of the roms I have tried had issues with wifi, even the rom that came with the tablet when I bought it.

I eventually found this rom from eken's website: http://www.epad.hk/Specs.asp?M=ZX07d, I also tested the older http://www.epad.hk/Specs.asp?M=M009D. Wifi worked awesome on both of these using the manufacturer rom, connected immediately, could turn off wifi and reconnect, come out of hibernation and reconnect without having to reboot.

So I used modroid v11 and deleted all the files in
c:\Modroid-v11-lite\FirmwareInstall\env
and copied the env_uboot file from the eken c:\zx07d_1.5.2 rom into this folder
c:\zx07d_1.5.2\FirmwareInstall\env\env_uboot -> c:\Modroid-v11-lite\FirmwareInstall\env

I then deleted the uzImage.bin file from modroid v11 and copied the uzImage.bin from the eken zx07d_1.5.2 rom into this folder
c:\zx07d_1.5.2\FirmwareInstall\uzImage.bin -> c:\Modroid-v11-lite\FirmwareInstall\

I then deleted the wmt_scriptcmd file from modroid v11 and copied the wmt_scriptcmd from the eken zx07d_1.5.2 rom into this folder
c\zx07d_1.5.2\wmt_scriptcmd -> c:\Modroid-v11-lite\

So basically using the rom from http://www.epad.hk/Specs.asp?M=ZX07d I copied the files replacing the orginals from:
c:\zx07d_1.5.2\wmt_scriptcmd
c:\zx07d_1.5.2\FirmwareInstall\uzImage.bin
c:\zx07d_1.5.2\FirmwareInstall\env\env_uboot

to

c:\Modroid-v11-lite\wmt_scriptcmd
c:\Modroid-v11-lite\FirmwareInstall\uzImage.bin
c:\Modroid-v11-lite\FirmwareInstall\env\env_uboot


Copied the contents ofc:\Modroid-v11-lite\ to my formatted sd card and installed on my tablet.

Works awesome! Wireless issue no more!
Did the market fix (clear cache)
Installed flash
Installed apps I use

no need to edit build.prop, market works. No need to edit RT2870STA.dat as of yet, wireless is working perfectly. No need to adjust the sound boost in init.sh, already done in modroid


Tablet is near as perfect as I could have imagined it.

I want to give a shout out to all those who do so much heavy lifting and help constantly:
wicknix for modroid
HardcoreHacker for uberoid at http://techknow.freeforums.org/
netizenmt for tips and fixes (fixed wifi perfectly)
MrTasselhof for his instructional videos and loads of info
leeh33 for tips and fixes (build.prop fixed my issues in the past with the market) and his new modified uberoid that works great and has the newest market http://techknow.freeforums.org/uberoid-v8xl-tweaked-as-hell-t1148.html
Dawg Fan for tips and fixes from http://techknow.freeforums.org/
lucsp for uberoidx and incorporating 1.5.3
and so many others who have posted wisdom, tips and their experiences
seriouslycgi, DoctorDroid, dragon2knight, CoffeeFreak, Joe G, and to many others posters on both forums if I left you out I am sorry but I have closed half my tabs and eager to load up some apps!
 

·
Registered
Joined
·
3 Posts
Hi,

Thanks for the advice...still the same problem though!

i used Modroid v11. I replaced the three files from ekens own update on their site 1.5.1 I think and it now lets me scan for networks but still just doesn't let me connect. The wireless will remember the network but won't make any attempt to connect. I've used lots of roms, uberoid v6, singularity v4 and 5 and modroid 6,6.5 and 11 and have not been able to connect to the net once. If you have any advice I'd really appreciate it!

ck
 

·
Registered
Joined
·
1 Posts
I also bought a M009s, based on the review saying it would run BBC iplayer. When I go there, I see they are looking for flashplayer 10.3
Does anyone know if there is a 10.3 flash that can be installed onto a WM8650?
I also bought it for my son, and want to sort this before I hand it over on Christmas.
cheers.
 

·
Registered
Joined
·
3 Posts
I just got a MID wm8650 for free and the thing wont stay connected to the internet and it has a error of google chat authentication failure. This is my first tablet so im going to have to take a closer look to understand what im doing but looks like this might be the fix.
 

·
Registered
Joined
·
3 Posts
I have modroid successfully running with wifi connected on my 7inch MID 7 wm8650. I had to replace the env_uboot file in the FirmwareInstall/env folder with the one I have linked below. Make sure you rename the file you are downloading from "MID703" to "env_uboot" then copy all the files to a microSD card, and boot your tablet to install the rom.

http://www.filesavr.com/69YSJCFM96BNYTZ

I hope this helps
 

·
Registered
Joined
·
3 Posts
I have modroid successfully running with wifi connected on my 7inch MID 7 wm8650. I had to replace the env_uboot file in the FirmwareInstall/env folder with the one I have linked below. Make sure you rename the file you are downloading from "MID703" to "env_uboot" then copy all the files to a microSD card, and boot your tablet to install the rom.

http://www.filesavr.com/69YSJCFM96BNYTZ

I hope this helps
Additional info:
I believe I have the "green led" edition that I have read about on various forums (I am guessing this because the led on my tablet is green when on and charged). I am running modroid v11 beta
 

·
Registered
Joined
·
3 Posts
Hi
I've managed to use modroid V9 ok for Wm 8650 7" tablet and the wifi is working however I can't get Skype v 2.7 to allow sign on .i see in Modroid v11 that this is acknowledged .Is it the same for Mod v9 is so is a fix planned ?

By the way , thanks to all for the great improvements to the base Android 2.2
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top