Android Tablets Forum banner

Maybe the kernel don`t support this NAND Flash

21262 Views 27 Replies 9 Participants Last post by  longbow22
Hello,I`m new here and a new owner of an Eken M001. I bought it on ebay and received it today. A fast test seems good, it starts up and worked. Then we have to go and I turned it off with a long press on the powerbutton. He asked me to disable the phone module. I agreed and since them only get a black screen...
I`ve tried to flash a new room (stands here in the forum), but only get the fellowing errormessage:--> Erase File-System partition Fail! Exit!Maybe the kernel don`t support this NAND FlashThis error comes with original Eken M001 1.7.4 firmware...Now my quest is: Is it broken (then flashmemory)? Hope you can help me.With kind regardsISDNRaiser
See less See more
1 - 7 of 28 Posts
It has nothing to do with the SDCard. I posted in the relax thread and then realized I wished I hadn't, because I don't want to clutter it up, so here is something to try.This is part of; lines 35 - 51. It tries to run the command
flash_eraseall /dev/mtd9
This is to completely wipe the system partition before copying any files. If the command doesn't exit with a status of 0 (Means no problems) then you get the message you are receiving. What you could do instead is comment out that section of code and go down to line 65 to add the following code (below 65 and above the "fi" in 66)
pointY=$(($pointY + $height))string="Now Exiting since we haven't cleared the partition...."echo $stringgui-echo $pointX $pointY "$string"exit 0
Now when you run the flash you it will skip the formatting the nand partition and just try to mount it. You will either get an message about it failing to mount or one about it working followed by the message above. The reason for exiting is because it's not a good idea to continue on with writing a bunch of files over the partition without erasing it first. If it comes back and says it can mount the partition let me know and I can tell you what to put in to manually erase all files before copying in the new ones from the rom. If it fails to mount then there is a problem with your unit's NAND and the only solution would be to replace it.
See less See more
O.k. that's good, it means that your nand is mountable, but for some reason flash_eraseall isn't completing successfully. What you can do is keep the flash_erase code and the accompanying verification cases commented out, delete the code I had you add between lines 65 and 66, then add the following starting on line 67 (after "fi").
pointY=$(($pointY + $height))string="--> Erase File-System ......"echo $stringgui-echo $pointX $pointY "$string"rm -rf /mnt/mtdif [ $? -ne 0 ] ; then	string="Erase File-System Fail! Exit!"echo $stringgui-echo $pointX $pointY "$string"exit 0else	string="Erase File-System OK!echo $stringgui-echo $pointX $pointY "$string"fi
The bbcode is adding some extra line breaks, so makse sure you don't have any after the "then" or the "else". It also changed my greater than symbol in the first string line to ">", so make sure you fix that too. That should hopefully get the flash to complete for you.
Hmm.. try changing the code to
rm -rf /mnt/mtd/*
and reflashing
You can try it. Just remove the code I had you add and leave the initial flash_eraseall stuff commented out.
Glad to hear you got it running again. The kernel is fairly stable for most people, but overclocking is still extremelynew to these tablets and it seems there are many mixed experiences for how how some people can safely overclock their units. When you flashed the 1.9.1 and mercury roms were you able to do it without modifying the update script, or did you still have to bypass the partition format?
Very interesting. I wonder if maybe the overclock was causing the whole SoC to get too hot and affecting the NAND.
I would see if you can get it replaced under warranty.
1 - 7 of 28 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.