Android Tablets Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
With the new firmware 919 I get many applications that used to install on 715 now marked as "not compatible" for my device.
any clues?
 

·
Registered
Joined
·
5 Posts
That's right, I guess that the new market apps has a diffrent way of detecting the device, other that the build.prop file. What is strange that it seems to be show all the apps on the v2 Market, but it keeps updating itself to the newest version. So I did the following to get the Market working and giving me (I think) all of the apps:

1. Make sure you have root privileges and Titanium Backup installed.
2. Go to Titanium Backup, find Market Updater. MAKE A BACKUP. Then press uninstall.
3. Go to Settings -> Applications -> Manage -> All, find Market, press Uninstall Update.
4. Reboot your tablet, you should have a working old Market.

Downside of the method is that once you download or update an app, and then try to look for it again, it doesn't show up until you reboot.

Naturally, you do it on your own risk.
 

·
Registered
Joined
·
80 Posts
I have the same problem and this fix did not work for me. After some research I found information pertaining to editing your build.prop file, though I dont know what needs to be changed exactly. Can someone pastebin a copy of the text inside of their Dropad A8X's build.prop file that also has a working Market?
 

·
Registered
Joined
·
42 Posts
sure! I'm using fw 705.

# begin build properties
# autogenerated by buildinfo.sh
ro.build.id=FRF91
ro.build.display.id=sec_smdkc110-eng 2.2 FRF91 eng.root.20110705.112928 test-keys
ro.build.version.incremental=eng.root.20110705.112928
ro.build.version.sdk=8
ro.build.version.codename=REL
ro.build.version.release=2.2
ro.build.date=2011年 07月 05日 星期二 11:32:42 CST
ro.build.date.utc=1309836762
ro.build.type=eng
ro.build.user=root
ro.build.host=S&G
ro.build.tags=release-keys
ro.product.model=A8X
ro.product.brand=Dropad
ro.product.name=A8X
ro.product.device=A8X
ro.product.board=smdkc110
ro.product.cpu.abi=armeabi-v7a
ro.product.cpu.abi2=armeabi
ro.product.manufacturer=sec
ro.product.locale.language=hdpi
ro.product.locale.region=
ro.wifi.channels=
ro.board.platform=s5pc110
# ro.build.product is obsolete; use ro.product.device
ro.build.product=smdkc110
# Do not try to parse ro.build.description or .fingerprint
ro.build.description=sec_smdkc110-eng 2.2 FRF91 eng.root.20110705.112928 test-keys
ro.build.fingerprint=generic/sec_smdkc110/smdkc110/smdkc110:2.2/FRF91/eng.root.20110705.112928:eng/test-keys
# end build properties
#
# system.prop for smdkc110
#

rild.libpath=/system/lib/libreference-ril.so
rild.libargs=-d /dev/ttyS0
ro.sf.lcd_density=175
dalvik.vm.heapsize=64m
wifi.interface = eth0
ro.sf.hwrotation=90
#
# ADDITIONAL_BUILD_PROPERTIES
#
keyguard.no_require_sim=true
ro.com.android.dateformat=MM-dd-yyyy
ro.com.android.dataroaming=true
ro.ril.hsxpa=1
ro.ril.gprsclass=10
ro.config.notification_sound=OnTheHunt.ogg
ro.config.alarm_alert=Alarm_Classic.ogg
media.stagefright.enable-player=true
media.stagefright.enable-meta=false
media.stagefright.enable-scan=false
media.stagefright.enable-http=false
ro.kernel.android.checkjni=0
ro.setupwizard.mode=DISABLE
net.bt.name=Android
dalvik.vm.stack-trace-file=/data/anr/traces.txt
 

·
Registered
Joined
·
80 Posts
Much obliged but there are major changes between android 2.2 (the 705 firmware) and 2.3 (the 917 & 919 firmware). I highly doubt this will work properly since I am running 919, hence the topic "market with 919fw" but I would think this would give me less issues than I am having right now.

Here is my build.prop file: http://pastebin.com/rag9Tt4S

I just did a wipe & reset of my tablet and the market seems to be working, but it didnt update to the latest version. I have seen reports of removing the Market Update using Titanium Backup but that didnt seem to fix the "Incompatible with your device" error on apps I know work (like the Linux Installer, but there are issues with it anyways so dont get excited yet). I dont mind the older version market, I prefer it to be honest as I dont care for movies and books in my Android market, but I would still like to get this fixed for the others experiencing this issue.
 

·
Registered
Joined
·
5 Posts
Regular market fix wont work. You will have to find a 2.3.1 build.prop file....
I wonder is there a chance to register our devices as samsung / motorola one? I'll have a chance to look at Motorola prop file after a few days.

I believe that XML files describe available hardware. Market looks at these files and decides which program is available for you. In Market topic there is a pack with XML files. It's good to be copied in proper location (described in market).

My market workaround - when I find "not-for-you" software in market I google it and download it from any site.

P.S. Try "Blackmarket" app. Lots of paid software for free. Downloaded apps not working always, but it worth to try.
 

·
Registered
Joined
·
22 Posts
If you set density to 160 the "not compatible" problem disapear, but the notification bar fails !
Sorry for my english
 

·
Registered
Joined
·
8 Posts
Hi all,
I'm new here maybe you guys can assist.
After putting new FW919 the market works few times then
i will have white screen message " No Connection-Try again"
but i will never connect to market again.
Thw work ariund was uninstall new market ver 3.xx.
But now even old market does not work.
wifi working fine.
only after I reflash the unit it will work again.
 

·
Registered
Joined
·
143 Posts
I still don't get it how to get a full market in 0919 FW. I understand that you can go back to the previous market (2.3.6), but I don't understand why that would give me full market since it doesn't give me full market on 0705 FW? Or should I try to do the market fix for Gingerbread in combination with the 2.3.6 market version?

Thanks,
Anton
 

·
Registered
Joined
·
30 Posts
In this order this works for me:

1st: Go to "Manage Applications" and tab "Market"
2nd: "Force stop"
3rd: "Clear cache"
4th: "Clear data"
5th: Now I set density to 160 with the "LCD Resolution" app.
The app will restart the tablet.
Sometimes the notification bar is scrambled. Ignore it.
6th: Start "Market" ,tab some app's and quit.
7th: Restart Dropad so density will automatically go back to 200.
8th: Start "Market" and test it. At this time the market shows
me 9 updates that before I did all this, where incompatible.

The only app i could not find at the market is Telesport.
But when jou go to the website off the Telegraaf you'll find a link to it.
When klikking on it, you'll have the choice off open it in the market.
If you do that you get the message: "This item cannot be installed in your country"
There are probably more apps with that notification.
At XDA-Developers are some discussions about this problem.
I haven't had the time to check it out, but will do asap.
 

·
Registered
Joined
·
143 Posts
In this order this works for me:

1st: Go to "Manage Applications" and tab "Market"
2nd: "Force stop"
3rd: "Clear cache"
4th: "Clear data"
5th: Now I set density to 160 with the "LCD Resolution" app.
The app will restart the tablet.
Sometimes the notification bar is scrambled. Ignore it.
6th: Start "Market" ,tab some app's and quit.
7th: Restart Dropad so density will automatically go back to 200.
8th: Start "Market" and test it. At this time the market shows
me 9 updates that before I did all this, where incompatible.

The only app i could not find at the market is Telesport.
But when jou go to the website off the Telegraaf you'll find a link to it.
When klikking on it, you'll have the choice off open it in the market.
If you do that you get the message: "This item cannot be installed in your country"
There are probably more apps with that notification.
At XDA-Developers are some discussions about this problem.
I haven't had the time to check it out, but will do asap.
Hi Leove,

And this works from the "stock" 0919 FW? No other tweaks/hacks installed?

What are your experiences with the 0919 FW? I have my Dropad now more or less working with the 0705FW and don't know if it's worth it to go for the 0919 FW. What do you think?

Thanks,
Anton
 

·
Registered
Joined
·
30 Posts
Hi Anton,

Yes it works for the stock 0919 and there are no other tweaks/hacks installed.

As for the upgrade, I bricked mine so I thought to myself why not try 0919.
Well I'm not going back because to my opinion it feels better.
The only thing that I can't understand is why the available memory is going lesser after a while.
But I am using Advanced Task Manager in automatic mode to bring the available mem back.
So for the time being that's alright for me. Nothing is perfect.
And there's always the possibility to go back to 0705.

If you think of upgrading, do you have the stock with the English text?
It tells you precisely howto because you have to do it twice.
Thirst with the u-boot-config_fused.bin file.
Second with the other files. Only if I could do it over again,I should not
put the logo.bin on the SD-card because my DROPAD logo its replaced for an Android logo.
And I think when you do not put the logo.bin on the SD, you keep the original DROPAD logo.
I have tried reflashing without the Logo.bin but it seems that a with a reflash
the Android logo will not be whipped. But if you don't care about the logo............

And for the rest, everything works fine for me. Have not tested HDMI port, but I don't use it.

I hope this helped you in you're decision off upgrading but its you're choice.
 

·
Registered
Joined
·
143 Posts
Hi Leove,

Thanks for your reply. Guess I should upgrade :)

I upgraded before to 2.3 but couldn't get the market to work. Now you've solved this I guess I should do this once again!

Cheers,
Anton
 
1 - 16 of 16 Posts
Top