Android Tablets Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
81 Posts
i have 2 that were purchased at the same time, they were well taken care of and after shutting them down (within a few weeks of each other, they died, i saw this thread so i grabbed them out again, well one of them started up after about 20 seconds on the charger (sitting in a laptop bag since december), so im doing a full charge now, but the other one is still dead. i emailed merimobiles about it weeks ago and they sent a form to fill out and send the devices back, i dont know if i will though. i guess it has something to do with the battery or charging, as it wont work on charger either.
 

·
Registered
Joined
·
81 Posts
this, and another, thread prompted me to take another look at mine again, it was D.E.A.D no leds when you pressed power and no response on screen, i was about to send it back for repairs or keep it for parts, i havent been able to use it for months because it was dead. so i took it apart, i tried to charge and power on but nothing, in the past ive pressed the reset button in all kinds of different ways, but when you take it apart it looks as though the reset is slightly off from the hole, so i put it on to charge, red led came on tried to power on after about 30 seconds charge and nothing so i pressed the reset (as i could actually see the reset button, i knew it was being pressed properly) for about 10 seconds. BOOm green led came on and its back to life again. modroid loads.

im putting linux on an micro sdcard asap

im so relieved its back they would have laughed if i had sent it over for reapirs and all they had to do was hit reset switch.

my advice is if its not working try reset switch for 10 seconds, if still no good try letting it sit for a week, then reset switch, then if your not willing to send it back to china for repairs try taking it apart wiggle the battery plug etc and reset with visual confimation for 10 seconds while charging.
 

·
Registered
Joined
·
81 Posts
if i were you id first ask the seller (and anyone else selling the VIAWM8650SILVER2 in that link where you can get the original firmware or new updates id probably not mention you tried to upgrade to a mod they might get lazy and not want to help. just say its not fully loading so something might be corrupt.

it sounds maybe like its different enough to not be taking the firmware mod, or id try uberoid or just search google for any firmware for that device (VIAWM8650SILVER2 or GHS M8)
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top