Android Tablets Forum banner
1 - 20 of 31 Posts
G

·
Discussion Starter · #1 ·
Its not working the screensize mess up. So olease help anyone have the original firmware for the m003Claus
 

·
Registered
Joined
·
83 Posts
AFAIK, Eken hasn't released a firmware update yet, so you might try emailling them. Otherwise, someone with an M003 could dump their flash and make a loadable firmware from it.The M001 firmware wont work because the LCD is a different type and most likely has different signalling for the framebuffer driver, plus a different digitizer too. Additionally, as it has an external USB port, it may well have more driver support for USB devices other than the WiFi.
 
G

·
Discussion Starter · #3 ·
actully i got 2 m003, but i am a totally noob to android, so dont know how to extract the firmware. And the eken homepage is down, so cant email them :'(
 

·
Registered
Joined
·
784 Posts
Depending on my available time, i should be able to dump NAND to SD from the system once i have ttl serial hooked up.Perhaps tomorrow.I feel sorry for you.. i almost flashed the M003 myself, to see if it would get a bit faster.. but i figured out the screen controller would be different.If it's all kernel modules and kernels are a match, we could have one firmware to boot on both. (just load different modules on boot, or load both, supporting both screen types..)You know what would be great ? If we can put a smartphone inside such a housing with big screen and bigass battery pack.. It would be everything i ever wanted
(fast, wifi, 3g, gprs..)
 
G

·
Discussion Starter · #7 ·
Exactly what i wanted, my htc legend with a screen like m001/m003, that would be nice. I think my dream will come true within the next 6 month, things are going fast right now. I really will apreciate a working firmware for my m003, so hope you have the time to do it. I also thought abaut the screensize, but because of the low performance i did the upgrade anyway, and hoped that eken have made a firmware working on both device ( the 1.7.1 upgrade)Claus
 

·
Registered
Joined
·
784 Posts
Can we move this topic to M003 board ?The problem is in the ENV commands that are in the 'scriptcmd' files. I now have the same problem.We need to know the original values for it..
I now have the same problem when i attempted to boot with a modified 'scriptcmd' from fookie.This sets the ENV for the lcd, overwriting the old values.If i had connected the damn thing by rs232 i would have been able to read out the original values.. now i'm just as screwed as you.. aargh!!These are the values set by the script, and are wrong for M003:
Code:
setenv lcdparam 1,30000,8,800,480,48,40,40,3,29,13setenv LCDC_FB 7900000setenv pwmparam 0,4,599,449
 

·
Registered
Joined
·
324 Posts
Total confusion now... Is the Eken M003 the same as the iRobot aPad (Moonse)? Are the mods mixing up the devices and moving threads to the wrong board? I thought the EKEN M003 had its own board (the one above this one in the list).
 

·
Registered
Joined
·
164 Posts
[quote author=gevrik link=topic=266.msg2869#msg2869 date=1275068020]Total confusion now... Is the Eken M003 the same as the iRobot aPad (Moonse)? Are the mods mixing up the devices and moving threads to the wrong board? I thought the EKEN M003 had its own board (the one above this one in the list).[/quote]yes we are, the iRobot M003 and the EKEN M003, are DIFFERENT devices, prehaps we need a new board?
 

·
Registered
Joined
·
784 Posts
Ok, i fixed the screen issue. But, there's another important problem.The battery levels are also set by the scriptcmd, and so we now have M001 levels instead of M003 which has a different battery.. oops..There's still some things to work out before i can release a fix.1. Bootup image and such is screwed, needs to be set to 800x4802. X/Y needs to be set to 800x600I mailed eken if they could send me an update, even an old one is welcome.. hope they send it to fix the battery problem.My M003 is currently tarring & gzipping its filesystem, it's taking a lot of time to do so.. slow cpu :(Once that is done i can start looking around in the filesystem to see what the differences are, if any.I could pack up the M001 firmware with a resolution fix, but it would be quick & dirty and keep the problems with the battery. Hope eken can help me out here.. (Maybe it would help if others can mail them for the update script for m003 as well.)
 

·
Registered
Joined
·
784 Posts
Ok, to fix the screen size:1. Download the attached file, & rename it to just scriptcmd.. not scriptcmd.txt2. Drop the renamed scriptcmd into the eken 1.7.1 update on SD and overwrite the old one.3. Boot with the SD card attached. The updater will never update, but the ENV settings will be ok, for at least the screen size.Now i'm just waiting on a reply from eken for a full update. At least i can use my M003 again now..p.s. this screws up the boot screen a bit. sorry
 

·
Registered
Joined
·
784 Posts
I have the 1.7.1 on it now as well (M001) with this fix, it seems a bit faster, notably the home screen slides left/right better. I would still advise not to run M001 on M003 at this point since we can be sure that the battery levels are wrong. (Worst case, you could over-charge the battery to a point where it heats up & explodes.)I'd suggest to wait for eken's update..
 

·
Registered
Joined
·
8 Posts
[quote author=Asure link=topic=266.msg2971#msg2971 date=1275083718]Ok, to fix the screen size:1. Download the attached file, & rename it to just scriptcmd.. not scriptcmd.txt2. Drop the renamed scriptcmd into the eken 1.7.1 update on SD and overwrite the old one.3. Boot with the SD card attached. The updater will never update, but the ENV settings will be ok, for at least the screen size.Now i'm just waiting on a reply from eken for a full update. At least i can use my M003 again now..p.s. this screws up the boot screen a bit. sorry
[/quote] I've tried to replace the file but the boot screen won't load with the sd card inserted. It does however install regularly without the replacement file, but once I replace the file and boot; it stays on the boot screen without the loading bar. Does it have to be a specific update? I updated with the original eken 1.7.1 and I've tried to replace the file in a number of different roms, but no luck. Which rom must I apply the file to?
 
1 - 20 of 31 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top