Android Tablets Forum banner
1 - 20 of 23 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I found this in my searching online. It is in a foreign language but I used google translate to attempt to read it. It would be great to have hibernate option instead of shutdown. If this is a real working method can we get this added to mods.http://www.kaskus.us/showthread.php?t=4281059&page=19If you want to check the environment that relate to hibernate UI , please go to the terminal ( eg pake Better Terminal ) , then from the prompt , type :getenv hibernation_uiIf the contents yes, and Hibernate not exit the menu , mean - iPad iPad of us are different (even though my firmware is also from EKEN , M002 ) .If the contents no, please changed so yes, By:setenv hibernation_ui yesAfter that , restarting ...
 

·
Registered
Joined
·
27 Posts
[quote name='nitulus;11597]I found this in my searching online. It is in a foreign language but I used google translate to attempt to read it. It would be great to have hibernate option instead of shutdown. If this is a real working method can we get this added to mods.[URL]http://www.kaskus.us/showthread.php?t=4281059&page=19[/URL]If you want to check the environment that relate to hibernate UI ' date=' please go to the terminal ( eg pake Better Terminal ) , then from the prompt , type :getenv hibernation_uiIf the contents yes, and Hibernate not exit the menu , mean - iPad iPad of us are different (even though my firmware is also from EKEN , M002 ) .If the contents no, please changed so yes, [URL=By:setenv]By:setenv[/URL] hibernation_ui yesAfter that , restarting ...[/QUOTE'] Hehehe ... that was my article I beliefe :)If you want to "enable" it by default, just add "setenv hibernation_ui yes" in the scriptcmd ...
 

·
Registered
Joined
·
27 Posts
[quote name='ricsi;11658]Hmmm ... but it does not work.If I enable it' date=' and choose hibernate, the "desktop" restarts and that is it.no hibernation is done ... is it just my M001 or does it not work generally?[/QUOTE'] Have you try to press MENU button after that? And check what is displayed in the screen? Sometimes, the display is turning off, but the hibernation UI is displayed in the screen (need to press MENU button to complete the task).Hope it is your case ...
 

·
Registered
Joined
·
82 Posts
[quote name='rizapn;11609]Hehehe ... that was my article I beliefe :)If you want to "enable" it by default' date=' just add "setenv hibernation_ui yes" in the scriptcmd ...[/QUOTE'] I opened scriptsmd with the notepad in Win7, but I can only see some gibberish. Do I use special software to see the code or what?
 

·
Registered
Joined
·
82 Posts
Ok, I was able to view the script with the Eken ES file explorer. I made the edit from NO to YES.However, I used the copy of the original scriptcmd file. Now I have to replace it with the one the the machine already using.I can't find the folder where the original file is installed.Help?
 

·
Registered
Joined
·
27 Posts
[quote name='Mr ILIA;12552]Ok' date=' I was able to view the script with the Eken ES file explorer. I made the edit from NO to YES.However, I used the copy of the original scriptcmd file. Now I have to replace it with the one the the machine already using.I can't find the folder where the original file is installed.Help?[/QUOTE'] You can NOT just edit the scriptcmd file like that. You HAVE to create the new scriptcmd file properly. Try to search "mkimage" in this web, or googling by that keyword to learn how to create that scriptcmd file.The "easiest" way to enter setenv command is using a Terminal application, such as Better Terminal ...
 

·
Registered
Joined
·
27 Posts
enotar;12713 said:
I did use setenv and set to yesMenu appear but just shut down the MID and when you turn it on it just reboot from scratch; no hibhernate done!
Hmm ... looks like my assumption/opinion (about the hibernate function is already in the firmware) is wrong then
Probably, my device is NOT 100% equal with EKEN. I did reflash my device (FlyTouch) with EKEN ROM (M002 version), and the hibernate function is still work perfectly.
 

·
Registered
Joined
·
646 Posts
[quote name='rizapn;12723]Hmm ... looks like my assumption/opinion (about the hibernate function is already in the firmware) is wrong then [IMG]http://www.slatedroid.com/public/style_emoticons/<#EMO_DIR#>/smiley.gif[/IMG] Probably' date=' my device is NOT 100% equal with EKEN. I did reflash my device (FlyTouch) with EKEN ROM (M002 version), and the hibernate function is still work perfectly.[/QUOTE']Can you explain how exactly it works?Thank you
 

·
Registered
Joined
·
27 Posts
[quote name='enotar;12724]Can you explain how exactly it works?Thank you[/QUOTE] Which explanation? The effect of hibernation? In my FlyTouch device' date=' when we long-press the power button, it will displaying the selection menu. If we press Hibernate, then it will ask "The device will be hibernate. Sure?" (something like that). If we press Yes, then, the device will be turned off instantly (without any shutdown screen). And when we press the Power button next time, the device will be turn on instantly (no need to wait for ANDROID, etc screen). BUT, the LED is really turned off (NOT like standy-by mode when we short-press power button).Or (more/deep) explanation about "setenv hibernation_ui yes" ? If this is the question, my answer is "I don't know" [IMG]http://www.slatedroid.com/public/style_emoticons/<#EMO_DIR#>/smiley.gif[/IMG] I just copy it from the original FlyTouch environment (using [B']textout -1 -1 $hibernation_ui[/B]) ... what I knew is only: it set the hibernation_ui environment to become yes
 

·
Registered
Joined
·
119 Posts
Well, I tried it. Put the setenv command in, clicked the hibernate button in the power-off menu, got prompted, clicked yes and the M002 (yup, M002, not M001) immediately went off with the LED turning off. Waking it up did light up the diode and screen showing the home screen, but the tablet is frozen until hard-reset. So this would be a no-go for my M002.Maybe its just Vestinious being unable to deal with the hibernation, though. It would take Roger to take a look at it, but Im not quite sure if he could do anything about that. After all, the hibernation feature is defaultly turned off for a reason, no doubt.
 

·
Registered
Joined
·
119 Posts
Yeah, I can easily imagine that. The question is simple, though - is that because of hardware incapability or because of software? If the former, there is nothing anyone outside the VIA company can do about it. If the later, its just a matter of time and effort in the hands of developers.
 

·
Registered
Joined
·
15 Posts
I'm using Relax 2.01, and although I can get the menu option by using the setenv command, like Enotar's experience I get a nice, fast shutdown, but when I switch on again, I get the full standard boot. Hibernation would really make the Eken 001 a spectacularly useful device, as at the moment the standard slow boot just stops the machine being genuinely useful.
 
1 - 20 of 23 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top