Android Tablets Forum banner
1 - 2 of 2 Posts

6 Posts
I have a Rikomagic MK 802 IIIS mini PC with the following specs:
Model MK802 IIIS 8GB Dual Core
CPU RK3066 Dual Core - Cortex-A9 Up to 1.6GHz
GPU Quad- Core 2D/ 3D/ OpenGL ES2.0(AMD Z430)/ OpenVG1
OS Android 4.1
Memory 8GB Flash
Expansion Micro SD T-Flash(Maximum support 32GB)
Video Format WMV/ASF/MP4/3GP/3G2M4V/AVI/MJPEG/RV10/DivX/VC-1/MPEG-2/MPEG-4/H.263/H.264/1280*720P HD 30 fps, 1080P/720*480 D1 30fps
Picture format Max.8000x8000 JPEG BMP GIF PNG
WiFi 802.11 b/g/n
Flash Supports flash 11.1
HDMI(male),Micro SD slot, USB host*1,USB OTG*1, USB power port; LED(Blue)

I managed to severely brick this MK802 IIIS mini-pc.
On short: After trying to restore a full NAND backup (8 GB containing Android factory installation) with Linux program rkflashtool, although there were no errors displayed during restore operation, the device does not boot anymore.
The full story here: (see the post titled "Very frustrating: seems that rkflashtool restore isn't working on Rikomagic MK802IIIS" and the next one)

I tried with NO success the following Windows programs in a vmware XPsp3 virtual machine (manual driver installation went OK, and before each test I'll mention, I put the device in flashing mode by powering up through OTG while holding the reset button pressed with a paperclip, for 5-6 seconds):
- RK Batch tool 1.5
- RK Batch tool 1.7
- RK Android tool, various version that come with custom ROMs such as Finless ROM and NeoTV ROM

RK Batch tool 1.5 / 1.7 both versions behave the same: when I connect the device, the box 1 turns to blue (not green). Now:
* ) when I try to upgrade to stock firmware, the operations run fine until the download firmware step. The download starts normal, and the progress runs in normal "rhythm" until about 9%. When it reaches 9%, the download rhythm "accelerates", meaning that it starts to count the progress quickly, from 10% to 100%(it reaches 100% in seconds). At 100%, it reports: "Download firmware failed".

If I re-plug the device imediately after this operation, the box 1 turns green as it should be. BUT, if I attempt the upgrade again, it stops at "Waiting for loader" step.
Then, if I attempt to replug again, the box 1 is again blue.

**) when I try the "recover" option, it starts to do the recovery (it executes OK some steps, such as checking device, resetting device, doing lowerlevel format), but at the 2nd device reset, it stops at "Waiting for loader".
If I try to replug, the box 1 stays blue.

RK Android tool (tested with various versions) sees the newly connected device in "Loader" mode. Now:
*) When I try to install everything(loader, boot, kernel, system), it executes some of the steps (checking device, lowerformat, resetting), but it fails at downloading firmware (in the same manner as RKBatchTool).

**) RK Android tool gives me success if I install only a minimal set (loader+parameters), but this does not help me, because the device is not booting with this minimal set.

NOTE_1: Obviously I tried all combinations of RKBatchTool + RKAndroidTool (for example: 1)erasing IDB in RKAndroid and then re-connect in RKBatch to do upgrade/recovery, or 2)Attempting to install each separate component in RKAndroid tool), but with NO SUCCESS.
NOTE_2: I even re-tried to restore once again my 8GB NAND backup using rkflashtool for Linux, but with NO success.

So, to put it short: The conventional recovery methods for MK802 IIIS are not working for me.

Therefore my main question: Is there a "stronger" method to reset NAND and re-flash the Rikomagic MK802 IIIS ?
By "stronger", I mean some hardware reset procedure, by short circuiting pins on NAND chip, like the one briefly mentioned here for MK808 model:
Is there anything similar for MK802 IIIS?

At this point I am completely out of ideas on how to continue my investigations, so any suggestion or advice is VERY welcomed.
Thank you in advance.


PS: I will attach high-res pictures with my device(case opened), so you will see the NAND chip.
PSS: I can attach screenshorts with outputs from RK Batch Tool / RK Android Tool or any other related output, if this helps..
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.