Android Tablets Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
4 Posts
I have an ICOO D70PROII tablet, that I bought 3 years ago, but it has been dead for an year now (I have delayed this post for too long).

The problem started when suddenly, the process google.android.acore (and another important process, which I can't remember) FC every 5 seconds.

I tried to make a soft reset and I even reinstalled the software using the rkbatchtool, but nothing worked. After booting, the process keep force-crashing.

In one last try, I came across with RKAndroidTool (v 1.35), and tried all the flashing again, but then everything went to hell. I accidentaly clicked on "Erase NAND (IDB)". When the process finished (I didn't want to interrupt it, just in case) the tablet never booted again.

It is now plain dead. I won't boot, no software can detect it (not even in the Device Manager). Nothing. The battery was at 100% before everything started, so it can't be the problem. And of course, I have leave it plugged to the current for 6 hours or more just to be sure.

And it won't show any vital signs.

It's possible to resurrect it? Or should I just throw it away? I was pretty happy with it :(

Note: I'm running Windows 7 x64, and before the "Erase NAND" thing I didn't have any problem detecting the tablet.

Cheers
 
1 - 1 of 1 Posts
Top