Android Tablets Forum banner
901 - 920 of 940 Posts

·
Registered
Joined
·
11 Posts
Hello,

I have deep-bricked tablet on D5H-88V-MX-V1.1 board with AML8726-MX processor. I don't have original U-boot file, and the display is always black. I can flash with AmlogicBurningTool, then I can get in the ADB shell or copy files between tablet and computer.

I have android firmware, recovery, boot.img, bootloader.img and logo.img designed to my tablet, but I don't have u-boot.bin.

I connected the computer to UART of my tablet, I can see the U-boot logs and some sort of Linux-like system booting (but even no ls commands itp). I cannot get to U-boot console even if I set bootdelay to 5. I attached the logs from flashing and from booting.

I'm using the instructions and files from:

http://www.mediafire.com/file/0aqbj6wuly1goyz/ENG_NOVO10HERO_Unbrick_Instruction_0_4_RC.pdf

What can I do to get my tablet working back?

Thanks in advance
 

Attachments

·
Super Moderator
Joined
·
1,185 Posts
I have android firmware, recovery, boot.img, bootloader.img and logo.img designed to my tablet, but I don't have u-boot.bin.

What can I do to get my tablet working back?
Make a bootable sd card. You have a u-boot for it. It's the same as bootloader.img.

My package containing instructions is in the previous post.
 

·
Registered
Joined
·
11 Posts
Thanks cxz! It worked now! I created bootable SD card and ran u-boot from AmlogicFlashTool:

mmc rescan

fatload mmc 0 0x82000000 u-boot.bin

go 0x82000000

But my power button isn't working in the system and recovery (physically it's ok, because it powers on the tablet). Also, when I turn off the tablet, it turns on back again. When it's powered off and I connect the charger it displays empty battery icon for a while, and powers on immediately.

I tried different firmware, but it isn't even booting..

Is it boot.img, u-boot or android problem? What can I do to fix it?

Thanks for your help!
 

·
Super Moderator
Joined
·
1,185 Posts
Thanks cxz! It worked now! I created bootable SD card and ran u-boot from AmlogicFlashTool:
mmc rescan
fatload mmc 0 0x82000000 u-boot.bin
go 0x82000000

But my power button isn't working in the system and recovery (physically it's ok, because it powers on the tablet). Also, when I turn off the tablet, it turns on back again. When it's powered off and I connect the charger it displays empty battery icon for a while, and powers on immediately.
I tried different firmware, but it isn't even booting..
Is it boot.img, u-boot or android problem? What can I do to fix it?

Thanks for your help!
When you boot using that bootable, you don't need the FlashTool.
Just erase nand with aml_autoscript and use a stock recovery on that sdcard.
It's name should usually be "uImage_recovery" but it can be "recovery.img" too.
So using both names is easiest. I'll add this to the readme as
it isn't said. Also naturally one doesn't extract the update.zip
itself but the firmware package that contains it - and usually that
uImage_recovery and factory update script file.

buttons
It could be that the firmware isn't exactly the correct one.

Or if you used some other tablets u-boot.orig file then you have its environment.
aml_autoscript_back2default-environment.zip
https://yadi.sk/d/8YMPngpN3GMVbZ

reread: system and recovery - the environment doesn't affect those
 

·
Registered
Joined
·
11 Posts
Thanks for very fast replies!
That is a bit weird, because the firmware is exactly for my board model. Maybe can I modify the boot.img or one of this/system files to get the power Button working? Is this stored in boot.img, system or in kernel? I'm not good at Android modifying but I have done some modifications to boot.img some time before.
 

·
Super Moderator
Joined
·
1,185 Posts
The keys are defined under system/usr/keylayout.
Normally power's value is 116.

With toolbox getevent you can get its value.
In my case

toolbox getevent -i
name: "key_input" -> /dev/input/event1
toolbox getevent /dev/input/event1
0001 0074 00000001
0000 0000 00000000
0001 0074 00000000
0000 0000 00000000

0x74 -> 116
 

·
Registered
Joined
·
11 Posts
Okay, I have typed these commands and - nothing. The power button isn't discovered by any of these commands. Even not in /dev/input/event1 or /dev/input/event0 or toolbox getevent. There are tons of event6 but pressing the power button does nothing.

Any other ideas? 80
 

·
Super Moderator
Joined
·
1,185 Posts

·
Registered
Joined
·
11 Posts
The buttons don't work, I can enter into recovery. The bootloader is recognizing the Button because the tablet Powers on. But why the system does not recognize it?
 

·
Registered
Joined
·
11 Posts
I didn't try flashing the bootloader (u-boot.bin) from the not-working firmware (but for my board). I'll try this with SD card and AmlBurnTool (only this method helped me, because i had the wrong u-boot in my tablet). It seems that i'm running Android designed for my board but with one camera (my tablet has 2 cameras). It might be the cause of not working button I think. Anyway, thanks cxz for explaining the bootloader.img file!
 

·
Registered
Joined
·
11 Posts
I flashed the not-working firmware, it's actually working but it boots about 400 seconds because of touch screen driver problem. But the power button does not work. I found that all these firmwares are for D5H-88V-MX-V1.2 board, when my board is V1.1. There is no firmware in the internet? No tablets with this board?

Is there any way I can modify the firmware to get the power button working (I mean real power button, no volume buttons mapped to power, etc.)? Or maybe have you got a firmware which will work on my board?
 

·
Registered
Joined
·
11 Posts
I downloaded this dump, in build.prop it's ro.product.board d5h88vh_8188 like in other not working firmwares, and my board is v1.1 not v1.2. I'll try this dump tomorrow.
 

·
Registered
Joined
·
11 Posts
Hey, I flashed the boot.img, recovery.img and system.tar and the U-boot just says "can't get kernel image" and restarts... My board is v1.1, and there isn't any firmware on the net which is designed for my board? I'm slowly starting to give up with this tablet...
 

·
Registered
Joined
·
11 Posts
Hmm... I discovered that even U-boot doesn't recognize my power key. When I run getkey in U-boot console, it always returns true. It explains why the tablet is powering on when I turn it off or plug in the charger. Is there any way maybe of decompiling U-boot and editing it? I don't think that there is U-boot for my board in the Internet.

Thanks
 

·
Super Moderator
Joined
·
1,185 Posts

·
Registered
Joined
·
11 Posts
Yes, the power key doesn't work anywhere, but the volume keys do.

I connected the volume+ button and power button, so pressing one presses the second. I'm now playing with U-boot environment variables, I'm changing the power key to volume+ key, changing the boot logo.img and keymapping in Android and recovery, so I think my problem is solved right now.
Thanks for instructions how to flash the right U-boot!
 

·
Registered
Joined
·
5 Posts
Please helpI can not find firmware compatible with the tablet PC that the manufacturer does not support

cpu : amlogic 8726 mxs a prm 306.00 dmxcn012

Chip touch Screen : silead gsl1680

nucleo : dual core

board : meson6

wifi : ap6181

camera : dual camera

Screen : 7"

Tv function

This dead I only want a firmware or rom to revive
 

·
Super Moderator
Joined
·
1,185 Posts
This place is as good as any, but odds for finding a firmware for a unknown device are generally bad.

If you haven't over flashed it with a wrong firmware and you cannot enter the recovery (to do factory reset etc.)

you could test if you can dump its partitions with my usb tools package.

http://www.slatedroid.com/topic/111538-tools-usb-dumper-tools-package-for-aml8726mx-by-cxz/

Even if partitions dump okay, finding error preventing the boot can be next to impossible...
 
901 - 920 of 940 Posts
Top