Android Tablets Forum banner
61 - 72 of 72 Posts

·
Registered
Joined
·
63 Posts
I've just reflash it with fonix again, and it's okay now, but i think it's not a solution coz it means the problem within the software config (not the hardware). If the power management software could change it why we couldn't? BTW how to unmount the USB flash disk? there's no option in the storage setting.
 

·
Banned
Joined
·
1,054 Posts
@kukalikuk Depends on your firmware if you use evolution (Shameless plug) then you get 8+ ours web browsing, good right? has web browsing and doing some light music, with a little gaming yesterday and still managed a good strong 7 hours 50 minutes before it told me I had 15% battery left.

With other firmwares I think your looking more around 5 - 6 hours.
 

·
Registered
Joined
·
63 Posts
7hrs50mins and still 15% remains? that's better, mine is only managed to 7hr something to get the device to 0% for nonstop wifi browsing and display. I've checked to Evolution's thread and there's so many version, which one should I use? is the 3.0 beta stable enough and will give the 8+ hrs battery life? and how to unmount the USB flash drive? thanx for the answers.
 

·
Registered
Joined
·
63 Posts
It's a patch in 1010, search_hotspot_patch.tgz
you could add it to phoenixmod or any other FW.
But i suspect it drain battery faster if connected to ad-hoc using this patch rather than editing the wifi_suplicant file.
 

·
Registered
Joined
·
3 Posts
Don't know if this is already posted, but here it goes.

For this to work you need to have a rooted device and you need write access to the file:
/system/etc/wifi/wpa_supplicant.conf

This is how it should look, note that i in this example don't use any WEP encryption

ctrl_interface=DIR=/data/system/wpa_supplicant GROUP=wifi
update_config=1
ap_scan=2

network={
ssid="Ad-hoc ssid here"
scan_ssid=1
key_mgmt=NONE
mode=1
priority=1
}
network={
ssid="Your Accesspoint ssid here"
psk="your wpa key here"
key_mgmt=WPA-PSK
priority=2
}


I use this to tether to my iphone 4.
If i turn off the tethering on the phone i need to turn the wifi off and on again for the tab to find my accesspoint again.

If you want to use WEP try to add this wep_key0="insert your key here" in the network section of the ad-hoc network.

Hopefully this will help someone out.
Hi Zoppatorslk,

I have followed your suggestion in order to enable adhoc wifi networks on my Tablet iMiTo AM801 running Android 2.3.1 without success.

The fact is that after I changed the content of the wpa_supplicant.conf file according to your entries, the system does not detect any change at all in the wifi configuration and continues to list only infrastructure (i.e., non adhoc) networks.

In my system I found the above configuration file in the following location:
/system/etc/wifi
It was just a template configuration file, not showing any specific network configuration inside.
I changed it, rebooted my system, but no change in behavior at all.
I also tried to specify the key_mgmt=WEP and wep_key0="my key" but, as I said, the system does not see any chenge in the configuration at all.

Do I have to give particular permission to this file? Do I have to copy it to a particular location of the Tablet file system?
And what about the path /data/system/wpa_supplicant that is reported in the network configuration you propose? Do I have to check if it corresponds to a file in the system?

I would really appreciate if you could provide me any support in solving my problem. I'm trying to share my wifi from my HTC TyTn II running WMWiFiRouter to my Tablet.

Thanks in advance,
Plecto
 

·
Registered
Joined
·
1 Posts
Following worked for me... (phone: Chinese H7000 2.2 stock rom)

1st of all I have /data/misc/wifi/wpa_supplicant.conf
instead of the conventional /data/system/wpa_supplicant or something.
next.. here's what I did..

Step1: Turn OFF WiFi and Modify file /etc/wifi/wpa_supplicant.conf with following lines

ctrl_interface=DIR=/data/misc/wpa_supplicant GROUP=wifi
update_config=1
ap_scan=2
network={
ssid="JoikuSpot_E71"
scan_ssid=1
key_mgmt=NONE
mode=1
priority=1
}
network={
ssid="Home_WiFi"
psk="12345678"
key_mgmt=WPA-PSK
priority=2
}

STEP2: Delete (or backup) file /data/misc/wif/wpa_supplicant.conf (This is kinda crucial, at least in my case, because this is system generated based on your original wpa_supplicant.conf in the etc/wifi folder)
STEP3: Restart phone (or use "fast reboot" app), Turn ON WiFi and you will only see & connect to the WiFi networks that you have entered in the wpa_supplicant.conf file.

I can now connect to JoikuSpot on E71.
But do not scan any network else the data/misc/wifi/wpa_supplicant.conf gets overwritten. (You can simply delete this file and start wifi again in case you've scanned. Not a problem)

MY QUESTION:
I have 3 access points i need to connect to:
1. Joiku on E71 (Configured)
2. Home-WiFi (Configured)
3. Office WiFi - Manual IP config. --- HOW do i add the office settings (IP, DNS, WPA and all) in the wpa_supplicant.conf so that i do not have to switch between the stock wpa_supplicant.conf and the modded one (like fbelleri has to each time)
Is it as simple as adding one more network bracket paragraph? { } , if yes, what is the code for IP settings and DNS etc?
Thanks
 
61 - 72 of 72 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top