Android Tablets Forum banner
21 - 30 of 30 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter · #23 ·
thank you sir for your help ,
though the problem is not completly gone it has improved a lot from previous one.

please update us in future also if there is a permanent solution

thank you
 

·
Registered
Joined
·
1 Posts
i seem to have run into a similar problem with my allwinner a10 tablet. Its a knc md710, running on ICS 4.0.3. After flashing back to factory firmware following a failed use of lordsbm's script for all Allwinner A10, i cannot get it to display correctly. The screen is just not centered even if returned to a factory rom. I hope someone knows how to fix this.
 

·
Registered
Joined
·
4 Posts
I bough this tablet recently, and i managed to have a lot of firmwares to it
this is my tablet xtouch x716 (same as LY-F8AS)
Xtouch X716

i was trying the Onda V10 elite firmware on it and it screw up my touch oriantation, now the touch has a huge shiftting and the three soft side buttons is not working.

I tried to flash the original firmware and it didn't fix this issue it still the same, i also flashed the other firmware that was working right but not working also.

I searched the internet for the ploblem and found that something called "ft5x_ts.ko" is been replaced by the onda firmware, so i tied the touch fix for ly-f1s, momo9, aurora and it didn't fix my problem.

I am using ICS 4.0.3. and my problem is the same as the video in the 1sh post.

Please help my to get my touch screen fixed with the proper patch or some this like this.
 

·
Registered
Joined
·
1 Posts
hi i have an allwinner tab similar hardware to ainol novo 7 advanced

i flashed few firmwares on it of different tabs( ployer momo 9 , ly f1) and they were working good

except novo 7 advanced firmwares ( touch was not working at all )

then i flashed a different firmware(onda v140) on it and the screen went white when powered on .
then again i flashed my default firmware everything is working now but touch screen is responding very differently . this is a capacitive touch . i have even tried flashing those firmwares which were working perfectly before but now the problem is common in all firmwares i flash .

see the video


then after that i tried flashing onda firmwares for 7 inch tablet that has auto recalibration of screen function after flash.

the touch points changed from previous one.

now my question is since this is a software/drivers issue how can i get it back

is my tablet bricked ? any chance f bringing it back to life.
rest everything is working fine including camera. and i am able to use adb on pc and run commands easily ..
please help anyone
I've also the same problem, about orientation. My tablet is Soulycin S8
 

·
Registered
Joined
·
1 Posts
this occurs when a firmware for ips screen tablet (eg ainol aurora) is flashed on a tablet which does not have ips screen .
Then a white screen appears on the tablet and some thin coloured lines on the tablet divides the tablet vertically into 3 parts
like
! 1 ! 2 ! 3 !
And then if we flash the stock rom again (everything works normally except touch)

The middle part no 2 ( in fig ) is totally not responsive

when we touch in part 1 area the touch happens in part 3 with mirror effect (eg when we swipe from left to right screen moves from right to left horizontally, though vertical orientation is ok) and vice versa i.e
touch in part 3 area touch happens in part 1 area with mirror effect

I HOPE SOMEDAY SOMEONE POST A SOLUTION TO THIS PROBLEM PLEASE
Screen / Digitizer calibration fix - Solution found!!

Background story:
I bought a momo8 tablet and stepped on it one month later. The digitizer was cracked. Then I bought a new digitizer to replace the old one. It was a pain in the [email protected]@ removing the old digitizer with the strong adhesive attached to it. Long behold, the touchscreen/digitizer coordinates were all reversed!! Left was right, right was left, you guess it. The term is operating an electronic device while intoxicated
There were some partial truth to the term.. Well, I tried cursingit, sleeping with it. Nothing works.
The above is just for your amusement only.
I was able to fix the problem after some exhaustive research. To make a long story short, the problem was a misconfiguration (I don't know how it got misconfigured after I changed the digitizer hardware). My finding and the final conclusion to the problem was software in nature.
Let me begin with the overview of the solution (as the details may be overwhelming to some, if you can follow the summary you're in good shape)
Now my android version is ICS, Im not aware or know if other version still have the same configuration setting. (you could try if desperate enough)
Summary:
1. Get a terminal and be able to have root access (su - "super user" access)
2. modify script.bin and script0.bin (these are the main configuration file the digitizer uses.) Wait it's in binary form, you can't just modify it yet. read on.
3. Reboot. That's it!

The painstaking details. pls forget any inacurracy and lack of details.
Let's look at the problem again. My X Y axis were backwards. Momo8 for 8inch screen size. My LCD screen resolution was 1024 by 768. What is the resolution of my digitizer? (Sorry for the rhetoric, but this is the key).
In terminal window. I typed "dmesg" and i get something below somewhere in that load of info
4.809718] ===========================ft5x_ts_init=====================
<6>[ 4.829719] ft5x_ts VERSION [email protected]@20120407.1250
<7>[ 4.829719] m_inet_ctpState return false,continue deteck
<6>[ 4.869725] ctp_fetch_sysconfig_para.
<6>[ 4.869725] ctp_fetch_sysconfig_para: after: ctp_twi_addr is 0x38, dirty_addr_buf: 0x38. dirty_addr_buf[1]: 0xfffe
<6>[ 4.889724] ctp_fetch_sysconfig_para: ctp_twi_id is 2.
<6>[ 4.900646] ctp_fetch_sysconfig_para: screen_max_x = 1024.
<6>[ 4.900646] ctp_fetch_sysconfig_para: screen_max_y = 768.
<6>[ 4.911785] ctp_fetch_sysconfig_para: revert_x_flag = 0.
<6>[ 4.911785] ctp_fetch_sysconfig_para: revert_y_flag = 0.
<6>[ 4.922694] ctp_fetch_sysconfig_para: exchange_x_y_flag = 0.
<6>[ 4.922694] ctp_fetch_sysconfig_para: screen_rotate_flag = 1.
<3>[ 4.934364] ft5x_ts: script_parser_fetch err.
<6>[ 4.934364] ctp_fetch_sysconfig_para: minetPowerEnreserver = 0.
<7>[ 4.944905] script parser fetch err.
<4>[ 4.944905] touch panel tp_en request gpio fail!
<6>[ 4.953272] ft5x_ts_init: after fetch_sysconfig_para: normal_i2c: 0x38. normal_i2c[1]: 0xfffe
<7>[ 4.962027] script parser fetch err.
<4>[ 4.962027] ctp_init_platform_resource: tp_reset request gpio fail!
<6>[ 4.972055] ctp_wakeup.
<6>[ 5.029915] ctp_detect: Detected chip ft5x_ts at adapter 2, address 0x38
<6>[ 5.040115] ====ft5x_ts_probe begin=====.
<7>[ 5.040115] I2C communication client->addr=56
<7>[ 5.549767] ft5x06 Chip ID=0x79
<7>[ 5.549767] I2C communication ok
<6>[ 5.559767] input: ft5x_ts as /devices/virtual/input/input2
<6>[ 5.559767] ==register_early_suspend =
<6>[ 5.559767] CONFIG_FT5X0X_MULTITOUCH is defined.
<6>[ 5.619782] ctp_set_irq_mode: config gpio to int mode.
<6>[ 5.619782] INTERRUPT CONFIG
<6>[ 5.619782] ==ft5x_ts_probe over =
<6>[ 5.659783] init: command 'insmod' r=0
<7>[ 5.679779] ===========================goodix_ts_init=====================
<7>[ 5.695885] goodix_ts VERSION [email protected]@20120207
<7>[ 5.701011] m_inet_ctpState return true,just return
<6>[ 5.701011] init: command 'insmod' r=-1
<7>[ 5.729783] HA2608 i2c touch panel device driver module init
<6>[ 5.729783] ite_ts_init VERSION [email protected]@201200210.1912
<6>[ 5.744718] init: command 'insmod' r=-1
<6>[ 5.869794] SSL Touchscreen driver, (c) 2011 Solomon Systech Ltd.
<7>[ 5.869794] m_inet_ctpState return true,just return
<6>[ 5.909800] init: command 'insmod' r=-1
<6>[ 5.949805] =====================================Novatek_TouchDriver================================
<6>[ 6.009827] Novatek_TouchDriver VERSION [email protected] Novatek_TouchDriver_20120412.1417
<7>[ 6.009827] m_inet_ctpState return true,just return
<6>[ 6.059820] init: command 'insmod' r=-1
<7>[ 6.079808] ssd253x-ts_1F [email protected]_inet_ctpState return true,just return

Notice the sysconfig_para - exchange_x_y_ flag=0, and revert_y_ flag=0, revert_x_flag=0. Guess what happens if you change all that to = 1? You guessed, it will change everything backwards again, which is what you though you want. That's what I did, but the BIG butt, yes the pain in the but.
. The movement was normal but I lost a section of the screen. it's like the digitizer cant reach it. Long story short again. The correct digitizer resolution for my table is 800 by 600. And so I found out, it's very counter intuitive because the physical dimension of the digitizer is larger than the lcd screen.'s physical dimension. And I fixed the resolution to the correct one. And long behold, my movements were backwards again!
Long story short again. The finding was if the resolution of the lcd screen and the digitizer is incorrect, you will get weird movement response not limited to x y axis inversion.

Okay lets get to the solution.
Where is the location of the script.bin and script0.bin (btw: these two file seems to be copies, I don't know why so just edit them both)..
it's in another partition that you would have to mount to get access to.
e.g:

su
mkdir bootfs
mount -w -t vfat /dev//nanda /boofts

I recommend you backup script.bin and script0.bin in case to need to revert back to the original messed up version

okay now you can access, copy, and even delete script.bin and script0.bin in bootfs directory (bootfs directory is a temporary directory that be gone after you reboot, don't worry you can access it by remounting)
Remember script.bin and script0.bin is in binary form , you can't realistically edit it in that form. So you need a program to change it to text file then you can read it and edit it.
There are linux program and windows program to convert it to text from and back to binary form. (just do a google search something like bin to fex, i dont know why they call it fex, text intoxication perhaps) I used a windows program, but linux is just fine. After you edit the text form, remember to convert it back to bin form and mount the /dev/block/nanda partition described aboved and replace the script.bin and the script0bin with the one you modified.

Some tips and clues. If your screen appear normal but only you can't access certain part of the screen or it seems like you are touching 1 to 2cm from the actual point, it's probably your digitizer resolution.
If your screen appear like there are dead space, maybe it might involve the lcd resolution (which can be changed as well).

Good Luck!
 

·
Registered
Joined
·
1 Posts
Hi! I think I need your help atp.I wanna contact with you because I have exactly the same problem like yours, with momo 8. I changed the screen and the digitizer, and now the vertical and horizontal touch is reversed could you tell me everything step by step pls? (actually how can I get a terminal and access to the root). THx :help:

Update:I find the solution for the root now I just need to know where are the script.bin and script0.bin (i cant find any file in system/bin/dmesg?
 
21 - 30 of 30 Posts
Top