Android Tablets Forum banner
81 - 100 of 138 Posts

·
Registered
Joined
·
25 Posts
I take it the other partitions backed up okay? Sometimes you just can't get it to backup partitions and you just have to count your losses.
Only partitions 13 and 14 give read errors, the other partitions backup succesfully as far as I can tell. For the time being I've removed partitions 13 and 14 from the RunME!.bat so the backup process skips these partitions. I've cut the system.img from the stock update zip file of which the link is provided in the guide, pasted it in the NvFlash folder and renamed it "part-13.img". In the hannsconf53.cfg file I've changed the size in the CAC section and removed the name of partition 14. This nvflash folder with all of its content I've burned onto a CD. When I want to return to stock this nvflash backup should now work, right?

Thanks again for the guide(s) and help :)

I assume nvflash automatically detects that I've got a 1653 model? And that it is unknown what kind of personal data is exactly stored in partition 14? I don't mind if I lose personal data and return to completely stock, I just would like to know what I will lose before I do :)
 

·
Registered
Joined
·
17 Posts
Hi all

Tablet has been running HannsTitan without issue for months, then last week I turned it on after it had been sitting un-used for a few weeks and it would not get past the green Hanns logo. Tried the reset button but still no good.... Found this post and thought I'd just restore to stock and start again. However having followed the steps in the guide my tablet now seems to be stuck in APX mode...

I downloaded the original image, moved/renamed the boot/system image files to the NVflash folder, edited the 53config file to remove the ref to image14 and made sure the file size for 12/13 matched the actual file sizes. The process seems to run OK with no errors (see below) but when I power on the tablet ir just boots back into APX mode?

Any ideas???

Warning! You are about to overwrite your '53 device to a stock state. Are you sure you want to do this?
.
By pressing any key twice, you will start restoring your tablet!
.
If you do not want to, then close down this command prompt window!
.
Press any key to continue . . .
Press any key to continue . . .

Nvflash started
rcm version 0X20001
System Information:
chip name: t20
chip id: 0x20 major: 1 minor: 3
chip sku: 0x8
chip uid: 0x171411c0432125d7
macrovision: disabled
hdcp: enabled
sbk burned: false
dk burned: false
boot device: nand
operating mode: 3
device config strap: 0
device config fuse: 0
sdram config strap: 0

sending file: hanns.bct
- 4080/4080 bytes sent
hanns.bct sent successfully
downloading bootloader -- load address: 0x108000 entry point: 0x108000
sending file: bootloader.bin
| 941356/941356 bytes sent
bootloader.bin sent successfully
waiting for bootloader to initialize
bootloader downloaded successfully
setting device: 1 0
creating partition: BCT
creating partition: PT
creating partition: EBT
creating partition: NVC
creating partition: MBT
creating partition: BLO
creating partition: MSC
creating partition: KLO
creating partition: OGO
creating partition: SOS
creating partition: LNX
creating partition: APP
creating partition: CAC
Formatting partition 2 BCT please wait.. done!
Formatting partition 3 PT please wait.. done!
Formatting partition 4 EBT please wait.. done!
Formatting partition 5 NVC please wait.. done!
Formatting partition 6 MBT please wait.. done!
Formatting partition 7 BLO please wait.. done!
Formatting partition 8 MSC please wait.. done!
Formatting partition 9 KLO please wait.. done!
Formatting partition 10 OGO please wait.. done!
Formatting partition 11 SOS please wait.. done!
Formatting partition 12 LNX please wait.. done!
Formatting partition 13 APP please wait.. done!
Formatting partition 14 CAC please wait.. done!
done!
sending file: part-4.img
/ 2097152/2097152 bytes sent
part-4.img sent successfully
sending file: part-5.img
/ 2097152/2097152 bytes sent
part-5.img sent successfully
sending file: part-6_53.img
\ 131072/131072 bytes sent
part-6_53.img sent successfully
sending file: part-7.img
/ 4194304/4194304 bytes sent
part-7.img sent successfully
sending file: part-8_53.img
/ 16777216/16777216 bytes sent
part-8_53.img sent successfully
sending file: part-9.img
/ 4194304/4194304 bytes sent
part-9.img sent successfully
sending file: part-10.img
/ 16777216/16777216 bytes sent
part-10.img sent successfully
sending file: part-11.img
/ 8388608/8388608 bytes sent
part-11.img sent successfully
sending file: part-12.img
- 3170304/3170304 bytes sent
part-12.img sent successfully
sending file: part-13.img
- 181934016/181934016 bytes sent
part-13.img sent successfully
Please now refer back to the guide section "Finishing the Restoration Procedure.
" included with this backup system/the slatedroid forum thread.
Press any key to continue . . .

EDIT - http://www.slatedroid.com/topic/22606-its-proper-bricked/page__st__40__gopid__333191#entry333191 This worked for me!!! yaayyy!!!
 

·
Registered
Joined
·
25 Posts
AAAAArrrrg.... Where is the update.zip file? Im ripping my hair out here...
Why isnt it included in the attached file? It also isnt available on the hanspree website anymore. Does anyone have a link to this??
No need to rip any hair out ;-)
I overlooked the link the first time too.
There are actually multiple links to the update.zip file you're looking for in this thread.

Here is the link again:

UPDATE.ZIP

btw. I had the same problems with downloading the update.zip from the Hannspree website (see my prior posts on this), but I found out that the Hannspree website does work occasionally because I was able to download the zip from the Hannspree website a couple of days ago.
 

·
Registered
Joined
·
8 Posts
I was recovering from a boot loop caused by installing Vegantab 7.0 - the bug which stopped the SD card from mounting. After much faffing I have managed to make step 1 work - thanks for a great tool, and thanks to everyone for all the comments and feedback that I was able to use to fill in the gaps.

I changed the file sizes in hannconfig32, removed the filename for part-14 and kept trying, and eventually it went through. The weird thing is... I can't do step 2, but the pad works anyway.

The pad still freezes on the green logo when I try booting into the recovery kernel image.

It does load into stock android quite nicely, and everything seems to work, but I haven't been able to load the recovery image (first stock, then I tried installing CWM with this tool).

Has anyone else encountered that? Where Android seems to run fine, but the recovery tools don't? Stock is fine for now, but I know I'll be wanting to go custom again soon!
 

·
Registered
Joined
·
1 Posts
Completely Destroy Your Tablet.

There may be times (such as selling your tablet, clutching at straws with a truly bricked tablet etc) where you wish to make completely sure the tablet is wiped as clean as you can get it.

Remember that even if the method works as it should (no guarantee) there may still be some bits,bytes etc etc of readable data despite this, but it should give you better peace of mind than the standard erase data function.

This method works in a similar way to both Sm0k3d0uT's G-Tablet format (it uses some of his partition files for this) and Darik's Boot And Nuke (D.B.A.N).

Basically what you're doing to the tablet is this:

1) Replacing all the partitions (except boot, recovery, system and cache) with those of the G-Tablet Format utility by Sm0k3dOuT.
2) Replacing the boot, recovery, system and cache partitions with customised partitions which solely contain files full of random data (thus making recovery of your files near-impossible).
3) Erasing over the SDCard with random data (you must do this step manually) which once again makes recovery of your files near-impossible.

Part 1.

1) Download these three files:

Part1: http://www.mediafire.com/?h69zr38c6d0zuzp
Part2: http://www.mediafire.com/?66mdrjnu9x4vvf7
Part3: http://www.mediafire.com/?93ot52lhvz7ddjz

2) Using 7-Zip, open the .001 file, open the .7z within, and finally extract the .img files and randomtext.7z file into your NVFlash folder.

3) Go into APX mode.

4) On your pc, run RunME.bat and choose the destroy option.

5) Once it's completed, unplug the tablet and then boot it back into APX mode, then install the CWM boot loader.

6) Mount the USB storage so that Windows can access it, occasionally Windows will demand you let it format the drive before use.

7) Exctract the rand1-6.txt file into your storage space. Once finished, do another Factory Reset, and restore your tablet to stock settings as detailed in the other guide.
Ive tried this. But at the point after i installed the CWM from the runMe.bat, i onloy get a black screen. My Hannspad is not booting into the recovery mode. all i can do is enter the APX mode.
 

·
Registered
Joined
·
12 Posts
A BIG thank you for these guides. I'd not been using my VeganTab-based Hannspad for a while, preferring instead to use my Vega with ICS. I then tried all flavours of Honeycomb on my Hannspad, but all failed to logon to Google servers. I then tried the revised stock rom, but ended up in the CWM boot loop.

So with nothing to lose, I followed your excellent instructions and installed the Team DRH ICS rom, and it has put the Hannspad rightly back at the top of my affections, due to its vastly superior screen compared to the Vega.

Thank you for your great help to the forum, it is much appreciated.
 

·
Registered
Joined
·
1 Posts
Does anyone know if this will work for the SN10t2 version of this tablet? I rooted it wish SuperoneClick but it would turn on for a few minutes then reboot, and wasn't reading the sdCard so I tried to unroot it, and now it turns on but there is no picture or anything. I have a Transformer as well and had this happen with it before and was able to fix it fairly easily, but I can't find any info or help on the internet regarding the SN10t2 and its extremely frustrating. Anyone help please?
 

·
Registered
Joined
·
2 Posts
scusate, non non mi so esprimere in inglese, scrivo in italiano e poi traduco con google...
il mio tablet all'avvio non da segni di vita, se premo power si accende la spia verde e il display rimane nero, se ripremo power la spia dopo qualche secondo si spegne.
all'avvio tenendo premuto sia vol+ e power, oppure vol- e power, non da segno di entrare in modalita bootloader...
se lo collego tramite usb con i driver apx, il pc vede il tablet ed avvia la procedura di ripristino, in questo caso l'unico segno di vita è una scritta che compare dul display in alto. alla fine della procedura, alcune volte compare il logo verde, ma dopo alcuni secondi di nuovo tutto nero, resetto tutto ma non cambia il risultato.
vi è mai capitato qualcosa del genere, ovvero non funziona più la modalità bootloader, e entra in modalita apx appena acceso?

sorry, I do not know how to express in English, I write in Italian and then translated it with google ...
my tablet startup shows no signs of life, if I press the green power light comes on and the display remains black if ripremo power light goes off after a few seconds.
at startup by holding down both vol + and power, or volume-and power, not a sign to get into bootloader mode ...
If I connect it via USB with drivers apx, sees the tablet PC and start the recovery process, in this case, the only sign of life is an inscription that appears dul display on top. at the end of the procedure, sometimes you see the green logo, but after a few seconds of the new all black, I reset everything but does not change the result.
you ever had something like that, which no longer works the bootloader mode, and enter into apx mode when turned on?
 

·
Registered
Joined
·
2 Posts
Hello,

The tablet will not suddenly start. I can get into Recovery but the normal system unbootable.

Since I tried to do Recovery Data Wipe / Factory Reset and does not work. I can not retrieve a backup nandroid had.

In its day it was the same and I recovered it with this tutorial but now I get it. It goes well the first part, but when Recovery act. Fail in step 4 ("Wipe data / factory reset '):

ClockworkMod Recovery v2.5.1.1-bekit-0.8
Formatting Data:...
E:Can't mount /dev/block/mmcblk3p2
(Invalid argument)
Error mounting /data/!
Skipping format...
Formatting CACHE:...
Formatting SDEXT:...
No app2sd partition found. Skipping format of /sd-ext
Formatting SDCARD:/.android_secure...
Data wipe complete.

I have tried to install the Recovery of serie and then did not even enter the Recovery partition. With ICS partitions I have the same result.

I start thinking that has failed for truth and disposing for use warranty.

Any ideas? Thanks in advanced.
 

·
Registered
Joined
·
4 Posts
Type No: SN10T130R1633

I have read though the whole of this thread. My intention is to install ICS. But I am getting stuck on the backup (before even installing CWM). I seem to have no problem getting into APX mode, and I have installed the drivers on my Win Vista computer. When I run RunMe!.bat and try and do a backup it gets as far as part-2.img and then seems to hang whilst receiving.

It says: "receiving file: part-2.img expected size 3145728"

but I've tried a few times and it hangs at some random part in the download (the bytes received are not consistent).

On the Hannspad I get the message "Entering NvFlash recovery mode / Nv3p Server" which I think to be strange?

Anyway, does anyone have thoughts on this?

TIA.
 

·
Registered
Joined
·
2 Posts
Restore Your Tablet

This Recovery Method can recover a bricked device to its original stock state, or it can be used to recover your tablet to your own NVFlash backup files (as created in the first guide).

Part 1.

1. Hannspree have now changed the method in which new updates are done (they're now a wifi download directly to the tablet itself).

2. So please download the very first hannspad official stock rom update below (unless you already have an update.zip to use and can ignore step 3).

http://www.mediafire.com/download.php?5wr0kyzg91kzxwu

3. Extract the Original_Update.7z file to (eg) your desktop, and then repackage the files into an update.zip

4. Extract the update.zip file to your desktop.

5. If you are restoring to stock, open up the downloaded update.zip file and extract the boot/system.img files to the NVFlash folder otherwise use your own backup parts-12/13.img.

6. Then if you are restoring to stock, rename system.img to part-13.img and rename boot.img to part-12.img

7. Once this is done, with the tablet powered off, plug in its usb cable, and connect it to the computer and enter APX mode.

8. IF you do not have a part-14.img file to restore (which if returning to stock you will not have) go into the NVFlash folder, and open the 'hannsconf.cfg' file. Navigate to the last [partition] entry named 'CAC' and delete 'filename=part14.img' and set the 'size=254017536' to 'size=0xFFFFFFFFFFFFFFFF'.
If you do not have a part-14, There is a mistake on point number 8. If you have a Version 33 tablet do as the instructions say, but if you have a version 53 you need to modify the "hannsconf53.cfg" file instead (do the same modifications).

I was running into bother with this for a while last night til I opened up the runMe bat file to find out what it was doing. Hope this helps someone.
 

·
Registered
Joined
·
6 Posts
Took a while but managed to get it to work in the end.. Had to add part-11 and part-12 and reset the "size=..." for each on the config file and then it came back to life..

Thank you.. Thought my tablet was about to go into the bin..
 
81 - 100 of 138 Posts
Top