Android Tablets Forum banner
1 - 2 of 2 Posts

·
Premium Member
Joined
·
2,338 Posts
I picked up a new White PD yesterday after hopelessly junking my WiFi (Don't ask, just know that Bed Bath and Beyond's no nonsense return policy is the best, ... aaaand amateurs shouldn't touch stuff the pros say you shouldn't touch.)

Credit goes to Roebeet for his tip to Nate trying to hack the Black one. help nate with the black pdn - he needs to flash an alt home over so he can use adb

  1. Put an app you want to install on your SD Card.
  2. Use your browser to install it by typing this in the browser's URL box. file:///sdcard/YOUR.APP.HERE.apk
  3. If it sends you to a settings screen, check the "allow 3rd party" box then try again.
Basically, you can use your built-in browser to install a new home screen like pandahome which is how Meth and Nate started the ball rolling. (You can also use Roebeet's version of modified 7_24 firmware using a non-Intel Mac which includes the Google Experience and Clockworx's button hack - pretty much essential to use most apps.) I'm looking forward to Clockworx's Not Ugly Market fix being included in a firmware flash.

Here's my tick-toc:
  • 8/12 10am OOB inspection: No visible cracks. roughly half-charge on battery, enabled WiFi.
  • Put to sleep via switch toggle while charging. Unit was awake (screen lit up) within an hour later. It was not disturbed in that period but screen (and alleged light sensor) was covered.
  • 5 hours later, screen was dimmed but could be woken via touch on screen.
  • 8 hours after that, screen completely dark, could only be woken via sw-toggle.
  • Unit up w/in 3 seconds.Dims after 10 minutes, Dark approx 3 seconds after that. Cannot be woke via screen tap.
  • WiFi on w/in 20 seconds, scans and connects within 51 seconds of waking up. (That's pretty damn good, makes me hesitate to upgrade FW, especially to buggy WiFi of 7_24 which I will avoid except for the altered version to get Google Experience and Button Hack.)
  • Web browser inoperable. goes to dark screen, then blank white. Cannot power down, only induce sleep via sw-toggle, long press does nothing. Hard reset via button-hole.
  • Boot screen flashes after 12 seconds, animates after 47 sec's, 90 seconds to home screen. WiFi connected at 1:56. Browser up and connected to PD home screen within 3 minutes of hard reset.
  • Plugged into USB/computer interface, GOT MAC?!? PD_NOVEL internal and "untitled" external cards mounted.
[Home screen install procedure.]

  • Copied several launchers onto external SD plus HomeSwitcher, AppMonster, Astro, Office_Suite_Pro, Skyfire and Seesmic.
  • Copied and renamed LauncherPro-0.6.7.2.apk LauncherPro.apk, diconnected and wokeup PD which updated contents of External SD.
  • Ran Browser, entered file:///untitled/LauncherPro.apk (that's the name of my external card as shown on my mac) = not found entered file:///sdcard/LauncherPro.apk = "install blocked"!!
  • Settings - allow unknown (USB debugging switch now available)
  • There is no real way back (lack of buttons) ReBoot
  • No Home choice. I haz a sad. Lost.Dir is now on both SD cards, empty.
  • Renamed pandahome_v1.90.apk to pandahome.apk, ReBoot, hoping I get a choice before installing pandahome with 2nd boot. No joy.
  • Browser = file:///sdcard/pandahome.apk JOY, actual install screen (com.fede.launcher)

  • This is weird, it installed LauncherPro, not Pandahome. Choice to open is dimmed. Pressed "done" which threw me back to browser. Tried Pandahome again.
  • OOps, I know what I did. I forgot the colon in file///... so it threw me to a google search. I saw that my choice of Pandahome was there (google is so helpful) and then Fat-Fingered it, hitting file:///sdcard/LauncherPro.apk instead of file///sdcard/pandahome.apk (notice the lack of colon).
  • Installing Panda too, just cuz. This time it gave me the choice to open it.
  • OOOH PRETTY! I HAVE JUST HACKED THIS THING WITH JUST A PRE-INTEL MAC USING NO ADB OR COMMAND LINES.
Nate should be happily hacking away as he finishes his review since you (and all you guys with real computers) can now make sure USB debugging is on.

I'm still going to have to do the button hack. Any suggestions? I can install a real launcher now, so I don't have to do the Flash install to Google Experience and ButtonHack I did before - which was based on the dreaded 7_24 FW update with its buggy WiFi. A virtual back and/or menu button in the notification area would be ideal, especially one I can install via apk.

I'm going to look around for one, but any suggestions would be greatly appreciated.

For you guys who wanted to see a virgin setup, here's what was on it OOB.

TSI: Serial No. 0 -- I've seen reports of this in OOB PD's that gets cleaned via FW updates.
Previous unit had base number (00071000071000 etc) after 7_24 FW flash, "Real" Serial No. appeared after 8_01 (altered 7_24) FW hack flash.
Serial No. also corrected on 7_18 FW.
FW: S10_07_05B ("B" for Bed Bath and Beyond. K's indicate Kohls and downloadable FW updates.)
WiFi: 2.3.0.0 July 01, 2010
Framework: V1.0_07052010
Application: V1.0_07052010
Adobe RMSDK 9.1.0
API and Browser Source ID: DL00000002

[Edit: wow does this seem like ancient history. I did this one other time on another unit in late August, 2010 and it worked even smoother since I knew what I was doing. The fully flashable market mods came out the next week or so with Nchntrman's tailor made set up right after that.]
 
  • Like
Reactions: mrsburnout

·
Premium Member
Joined
·
2,338 Posts
Quick update: Tapatalk works! So does the Slideme market w/sam2.apk ... as you can see below. Haven't done the google market. I flashed the 8/12 mod B4 market not ugly fix was included. Seeing some of the continued struggles with wifi, I think I got enuf to keep me busy until we see if we really do get the source code.

Sent from my sec_smdk6410 using Tapatalk
 
1 - 2 of 2 Posts
Top