Android Tablets Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
97 Posts
I found an interesting trick to get my PDN to behave like it did before GE was installed... Deep sleep all night. No power switch troubles.All I have to do is rename the googleapps database.... gls.db located in /data/data/com.google.android.googleapps/databasesI use root explorer to rename it to gls.db2.Then clear the google cache... To clear the google cache select Settings - Applications - Manage Applications.Press menu button and select filter.Select the all button.Scroll down the list of apps to Market and select it.Press the Clear cache button.When I do this I am able to use the timeout or power switch to put my PDN into deep sleep and it has stayed this way for more than 8 hours twice. Wifi works fine...or I should say as good as normal..When I want to use market again I just reverse this process. Renaming gls.db2 back to gls.db. Clear the google cache again, log into google talk... and market works as before. .. including the other GE type problems... Trouble staying in deep sleep with the power switch for more than an hour.. ANd inability to sleep over night by using the timeout value.One more thing... Whenever you reboot your PDN without the gls.db file a new version of the gls.db file is created... with an androidid of 0. I just delete it since I have the real gls.db file renamed to gls.db2.Also note that in addition to this "trick" I still need1. background data turned off under settings - accounts and sync2. backup my settings turned off under settings - privacy .As in the past this power stuff is complicated and involves lots of issues. Soooo YMMV....I have spent lots of time getting my PDN to work the way I like it to and just want to share this extra tidbit in the hope that it can help others serious about getting the PDN to not drop power over night.
 

·
Registered
Joined
·
7 Posts
Why not just turn WiFi off before putting it to sleep? Seems a bit less complicated. And then if it doesn't connect right away, go to the WiFi settings page and "scan". You network will show up within 10 seconds.
 

·
Registered
Joined
·
361 Posts
That would be OK if it booted a bit faster. If you use the PDN throughout the day, it is a nice feature to have it go to sleep & still available almost immediately. Problem is, it doesn't stay asleep & therefore not in a power saver mode.
 

·
Registered
Joined
·
846 Posts
agreed.. is there some sort of script that could be written to automate the above task? Something that would make it as simple and quick as running an app? .. or better yet.. a script that is run a certain number of seconds before a timeout?Kind of a crude workaround, but maybe a decent solution..
 

·
Registered
Joined
·
135 Posts
Since upgrading to FW 8-06 I've been experimenting with ways to get the PDN to deep sleep. I have now been able to reproduce the desired result over many 6+ hours deep sleep sessions over the last several days (yes I'm obsessed about this!), and I'd like to share my experience with you. YMMV.NOTE: all these are built on the previous works/threads of cosmos. Thanks!(1) go to "setting", and then turn off (a) "use wireless network" in "location & security" (
"background data" in "accounts and sync" (c) "back up my settings" & "use my location" in "privacy"(2) in setting/running services, turn off anything that might conceivably use data/sync/update, e.g. google voice, kindle, weather services, calendar, ...(3) in setting/sound & display/screen timeout, pick a small value (I use 30 seconds)(4) use a system monitoring app like "system panel" or "smartbar" to check one more time that no other apps (beside system panel) is running in the foreground, AND that none of the remaining background apps require updates/syncs (a brute force way to do this is course to just kill all but the launcher and smartbar, but some might argue that that is unnecessary and will affect the performance when PDN returns from sleep... YMMV)(5) return home, wait for the screen to time out. The screen would dim, and then turned off a few seconds latter. And we are DONE!NOTE:* (very important) I did NOT turn off wifi!Based on my experience, as long as I follow steps (1)-(5) then wifi does not affect deep sleep. Not only that, but wifi returns in seconds (!) when the PDN wakes up from deep sleep. This is in contrast to a number of times when I inadverdently let the PDN time out and then I wake it up while the screen is dim but not off -- in that scenario wifi takes well over half a minute, sometimes longer, before it reconnects (a couple of times it take so long that I just reboot!).* clock/weather widgets are obvious candidates that require background data syncs. I find that it suffices to kill the weather app and leave the widget on the home menu; when the PDN wakes up, I just touch the widget and it will restart. Contrast that with jorte -- the one calender widget I have used (and really like) -- I need to kill both jorte the app AND jorte the widget (painful lessons...)* if you use e.g. better alarm, you can still set the alarm clock, put the PDN to deep sleep, and then hours later the alarm still works! (with no apparently drop in battery level).By the way, better alarm is LOUD! :)That's all, folks. I hope this works for you. Remember that YMMV, and gives cosmos a hug :) Or a new battery :)
 

·
Registered
Joined
·
179 Posts
I found a pretty simple thing that seems to work for me - YMMV. I just to go into Settings , Date & time, then deselect the Automatic option and manually set the date, time zone, and time. Then I shut down all the extraneous tasks with Smart Bar's Task Manager and put the PDN to sleep with a quick flip of the power switch. That's it. Prior to this, I pretty regularly experienced the PDN waking up to the dim screen state. Not now. I tried to figure out why this works, and one theory I came up with was that when Date and Time was set to Automatic, where the explanation text reads Use network-provided values, the PDN must be awakened by the OS periodically or at some pre-set time (like GMT-0:00?) to get updated date and time info via a timeserver somewhere on the Internet (I couldn't find an option to specify this, BTW). If correct, this necessitates waking up the PDN to at least a minimal power state and turning on wireless, of course, and I'm guessing the PDN developers neglected to shut things back down afterwords.I don't have GE and I'm sure lots of the other things others with problems do, but I do have lots of the other common hacks and apks (Dalvik VM upgrade with explicit JIT, volume button, Smart Bar, Panda Home, a few media and alternate reader apps, etc.). So, as I said, YMMV, but it seems to keep my PDN in a deep sleep until I wake it up manually if I follow the above, and I was able to get it to revert to the 'bad' behavior by turning Automatic back on.EDIT: My bad - just realized this forum was only for issues those that DO use GE are having - I don't have GE but can force sleep to malfunction. So I leave this here FWIW in case my approach helps those with GE.
 

·
Registered
Joined
·
10 Posts
This worked great for me. I put my PDN to sleep at Midnight last night, and awoke it today at 6pm (18 hours later), and the battery hardly drained at all.The only issue is that the Marketplace requires background data to be enabled, so you have to manually disable it every time. Is there a way to make a shortcut to just that menu on the desktop?
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top