Android Tablets Forum banner
1 - 20 of 20 Posts

·
Registered
Joined
·
97 Posts
Discussion Starter · #1 ·
I think I'm having a hardware problem. I have spent the last day using recovery to try to get a stable system. My goal was to use 8/06 firmware... While using this a week ago I seemed to have the least amount of flakey screen problems.... wifi worked OK... and sleep was predictable. But while trying to reinstall 8/06 I ran into a strange problem. It appears to be similar to what was reported here:http://www.slatedroid.com/pandigital-novel-android-tablet-discussion/6011-help-pd-apps-mia.htmlas losing the base PD launcher and reader. SYMPTOM... On initial boot the launcher force closes before it gets to the language and time setup screen. This causes a loop. adb still works. So I was able to install launcher pro. And lots of other apps... But the PD launcher and PD book reader always force close. The PD launcher gets loaded from time to time causing occaisional force closes. This happened to me flashing 8/06 and 8/20. When I flashed Nchntrman's 7/24 all in one package... It failed to install all the apps... But the base 7/24 firmware came up with language and time setup screen and PD launcher. So I tried again to install 8/06... Same behavior no pdlauncher... and just the base 7/24 firmware...comes up with time and language...i.e. worksI went back and looked at the recovery logs for all this behavior and found the following recuring error while fusing the userdata package. Every time there was a userdata.img present....8. fuse userdata.img about to run program [/tmp/fuse] with 3 argsimglen:2112, page:2112type=4flags=1024size=197132288erasesize=131072writesize=2048oobsize=64ecctype=-1eccsize=0Erasing and programming NANDBlock at 0x05320000 is damaged and is not being formattedOK So I appears I have a memory problem..at 0x05320000Memory problems eventualy cause major problems. So I perhaps need to return my PDN for a replacement.QUESTIONS:Am I reading this correctly ?Any other things I should be looking at ?Thanks for any guidance.
 

·
Registered
Joined
·
97 Posts
Discussion Starter · #2 ·
Answering my own request for help...I sent an email to PanDigital about my hardware problem.It took 1 day to respond with a form letter.... and 2 more days to respond with a real person...Telling me to call them..I did call them.. They said they would send me instructions on how to properly flash my PDN..It took 4 hours for the email to reach me..But when it did it was different from what has been said on this forum... AND IT DID SOLVE MY PROBLEM!!!!My problem was I could not flash the 8/06 or 8/20 firmware levels... I ended up with no PDLauncher... and force closes.I tried lots of workarounds.. And found several with promise...But always ended up with flakey errors... Force Close on PD launcher.....Power off switch wouldn't power off... app drawer was blank.... Anyway...PD told me to remove the SDCARD.... Make sure there were no other .zip files on the pd_novel internal card..... download the current (8/20) firmware... put it on the pd_novel internal card ... power down..... Start up with Vol up + power on...IT WORKED!!!.... I have done this 5 times using the SDCard... But this time it installed and worked... came up with set language and time.... to the PDN laucnher.I got some errors on userdata... saying UID's were incorrect....I went to PDN settings... Reset Defaults... It went into a 15 second android recovery screen... and rebooted...And everything worked again...Not sure how I screwed my system but I was convinced I had a hardware error.. And had to return the unit..Just followed PD support and everything worked!!!WOW... I am amazed....
 

·
Registered
Joined
·
97 Posts
Discussion Starter · #4 ·
Glad it's well known. I spent a week farting around browsing this site and googling looking for solutions. I bought this 4GB Lexar card new for the PDN from Newegg. Had no idea it was lousy. No problems on my Windows desktop, laptop, Mac, multiple Cameras, PalmOS, WinCE, or stick TV systems with it. Formatted it with PDN. Silly Me!
 

·
Registered
Joined
·
1,351 Posts
I am really not sure that the card is lousy, it just seems the PDN is picky for reasons entirely unknown. I had the same issue with a brand new card, worked fine everywhere, even in the PDN after booting, but would never flash from it.
 

·
Premium Member
Joined
·
2,216 Posts
How is that different from how we tell people to do it on this site?
 

·
Registered
Joined
·
97 Posts
Just to make it more interesting I went back and reflashed off my lousy SDCard... I didn't change any bits... And it worked.. It didn't work yesterday. Before this PD support help...To me there is something that happens differently when flashing off the pd_novel than off the SDcard.I have been an avid reader and participant in this forum since 7/8. And I seemed to run into a problem that looked like it required a return of hardware..With help from PD support I solved my problem. I just want other others to be aware that when all else fails... A last resort would be remove the SDCard and try flashing from the PD-Novel internal card.SOmehow I missed that message after a solid week of searching and trying things and so I am trying to point out to to others another thing to try before giving up on the PDN..That message never reached me... And that is why I am posting... Ban me if you must or move my post to some obscure place... Just trying to help..Sorry if that upsets someones applecart...
 

·
Premium Member
Joined
·
2,216 Posts
Relax. Wow. They need to adjust your meds, bub... I was just asking how your experience was different. Actually Pandigital's official line until recently was to NOT flash off the internal card, though that often works and we've been telling people to do it all along. The most common problem is people not getting the entire FW file and trying to flash. A few have gotten bad memory sectors. Many, many have had issues with bad SDcards. I just didn't see what you were told to do that I haven't seen on this site. If I move this post it will be as part of a cleanup to combine the several other threads regarding this same problem - I'd rather you'd necro'ed one, but if I banned every mook who starts a jingle-thread I would be talking to Clockworx and Roebeet all day... Deep breaths... use a paper bag if you have to.
 

·
Registered
Joined
·
666 Posts
Lol, i found this thread helpfull. Nice to know PanDigital's tech support is improving.hehehe, he said mook
 

·
Registered
Joined
·
1,351 Posts
[quote name='nchntrman;53588]Lol' date=' i found this thread helpfull. Nice to know PanDigital's tech support is improving.hehehe, he said mook[/QUOTE'] The four hours before the email arrived was probably PD support desperately scouring our forum.
 

·
Premium Member
Joined
·
7,365 Posts
You could also use the PDN update app and DL the FW to the Novel right from pandigital's site. Without an external SD card in the device.I have had better luck flashing with smaller (128mb, 256mb and 512mb) SD cards formatted in FAT
 

·
Registered
Joined
·
1,351 Posts
[quote name='mrsburnout;53602]You could also use the PDN update app and DL the FW to the Novel right from pandigital's site. Without an external SD card in the device.I have had better luck flashing with smaller (128mb' date=' 256mb and 512mb) SD cards formatted in FAT[/QUOTE'] I thought that just downloaded the file and pushed it onto the SD card. (Never used it though, guess I may as well learn how it really works)
 

·
Registered
Joined
·
97 Posts
Discussion Starter · #17 ·
I have been unable to use the alternative 1 PD site flash option... Flash thru the computer... My Win7 gives me an error...So after reflashing off the SDCard I went back removed the SDCard and tried reflashing the PD_Novel internal card. I changed no bits on the PD_Novel card. It failed to flash with the triangle ! symbol... WOW.... So I reread the instructions they sent... It said remove all .zip files from the PD_Novel... and copy the downloaded version... So I deleted it (the S10-08-20......zip) file and just copied it again.... Reflashed and it worked this time...Very strange... But it seems like it is only good for 1 flash... How do they even do that ??? Let alone why??I have no idea... But following their instructions again lead me to again successfully reflashing with everything working..cosmos ...aka the Jingle Thread Mook..... sounds like an xmas song
 

·
Premium Member
Joined
·
7,365 Posts
cosmos;53654 said:
I have been unable to use the alternative 1 PD site flash option... Flash thru the computer... My Win7 gives me an error...
Have you tried using the PDN's update apk itself? It is on the second page of preinstalled apps. This eliminates the need for external sd card or computer connection. However, you need to have wifi connected for this option. You can also perform the same action by accessing pandigital's download page from the browser on your PDN and selecting the SD card download and it will go to your PDN internal sd card.
 

·
Registered
Joined
·
97 Posts
Discussion Starter · #19 ·
Thanks mrsburnout... I was not aware of either of those options. Does the update.apk...just download the firmware or does it also force the recovery mode without the double switch stuff ?
 

·
Premium Member
Joined
·
7,365 Posts
cosmos;53922 said:
Thanks mrsburnout... I was not aware of either of those options. Does the update.apk...just download the firmware or does it also force the recovery mode without the double switch stuff ?
The update apk just downloads the current firmware to the internal sd card. You still need to power off and then back on while holding the volume + key for 5 seconds as with any PDN flashing process.
 
1 - 20 of 20 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top