Android Tablets Forum banner

Firmware v1.7.4 on M001 - Apps won't download from Android Market

7016 Views 19 Replies 13 Participants Last post by  mikepurdie
I really like the v1.7.4 firmware upgrade for my M001, but the Android Market will NOT download any app I choose. It doesn't matter which one. They queue up and say "Starting download", but never download. I've seen this before on my various Android phones and I know how to fix it, but none of those tricks have worked on the M001. I have tried logging in with Google Talk first as that often resolves the same problem on an Android phone. The two apps are tied together somehow and Google Talk's code is used in the authentication (I think). I have also tried creating a new Google account in case the one I was trying to use had problems because I have also used it recently with Android v2.2 on a Nexus One. No luck. I have tried doing factory resets a couple of times, once with each of the old Google account and the new one. So far, I can't get any apps to download from the Android Market. I have access to the Market on my phone, so can just copy the *apk files over and install them. That's OK for the free apps, but I'd prefer to not pirate the paid apps and would like to buy them if I could get the market to work properly.The Internet connections I've been trying this on are my wifi at work (heavily firewalled and often causes the Market problems) and tethered to my Nexus One (running Froyo) via the built-in wifi hotspot. Neither one works for the Market. The only connection I haven't tried is my own wifi at home.
1 - 20 of 20 Posts
Just a thought, what happens if you were to download the app from the market to a PC & then transfer it to the device.Not really a solution but a pos work around until the problem is resolved.
That does work, but that worked ages ago too.It's really unfortunate that the market won't download.
tried slide me marketplace and same issue. Must be the firware that is causing this
Rocky289 and Zerodime - How does one get to Market from a PC? I'm having tablet issues with Market, but I'd be happy to use the work-around in the meantime, if I knew how!
You can't use the market from your Pc, there are though a few alternatives to get some APKs from.
[quote name='Zerodime;11949]You can't use the market from your Pc' date=' there are though a few alternatives to get some APKs from.[/QUOTE'] I have 1.7.2 on my Eken M001 and seem to be having same problems with SlideMe. Can you provide details of the alternative sources for APKs that will work?
Aptoide works nice. Search on the forum for more info.
I wonder if AppBrain would work. It lets you select apps from the PC and they get installed on the device.....more of a push than a pull.....but it might not work either. I haven't tried it.
I tried AppBrain, but it uses the Android market, so that wasn't any good. (You need an Android phone for this to work) Instead, I: 1. Installed AppMonster Pro on my Android phone, then used it to back up all apps on the phone on to the sdcard. Any such program will do. 2. Used Estrongs File Explorer on the phone to navigate to the backup folder. 3. In Estrongs, found the app I wanted and long-pressed on that app to bring up the Menu.4. When the menu came up, I touched "send" and chose Gmail. 5. I then sent the *.apk to the gmail address for the M0016. On the M001, go to the Gmail inbox thru the BROWSER (not the Gmail app) as the browser will let you download the attachment. (The Gmail app will not let you download the apk). 7. The app downloads and you can just touch the download entry to start the install. The whole process takes about 1 minute / app. No big deal. But it works great. For protected apps, you'd obviously need a backup tool that was able to back them up. I'm mainly interested in the free apps.
See less See more
[quote name='veilance;11947]Rocky289 and Zerodime - How does one get to Market from a PC? I'm having tablet issues with Market' date=' but I'd be happy to use the work-around in the meantime, if I knew how![/QUOTE']Sorry, I was thinking AndAppStore.
Mogrith posted this in another thread, and it worked for me.
There is a weird bug in the market app. You need to clear the data in goggle apps before a new d/l will work.Try this:Best way I've found to D/L apps in market.Go into Market find and start D/l of app you want, it will just sit there at starting d/l. That's ok for now just find the next app you want and start a d/l on it. Repeat until you have all the apps you want.Now cancel all the D/l you started.Exit the market.Go into setttings, manage applications and clear data in Goggle apps.Exit settingsGo back into market Login again and into D/L tabFind the largest app and start the d/l. It should start.While the d/l is still going on start the rest of the apps D/l.You can start another d/l as long as another app is still d/l. It's like once the Market thinks it's done with d/l's it's screwed up and won't start another. But as long as one app is is in d/l you can start another.Good luck
[quote name='jayk2k;13128]Mogrith posted this in another thread' date=' and it worked for me.[/QUOTE']Thanks jayk2k! Works like a charm. It's a little annoying to have to do a 2-step everytime I want to download something but hey it works! Much appreciated. :)
[quote name='jayk2k;13128]Mogrith posted this in another thread' date=' and it worked for me.[/QUOTE']Yes. This works for me, too. Though not every app installs successfully even if you do manage to download it. but I have "Beautiful Home" widgte running on my Home screen now and I'm happy. :) If a custom ROM has this fixed, I'll change to that instead.
Yeah, i spent several days looking through all the info on the google site for the market and nothing seemed to work for me. Once I tried this method suggested by Mogrith I was very happy indeed. Like you say, it is a PITA, but at least we can get to the apps and download them. Far better than the stock 1.7.2 firmware I had with only access to slideme or a few other non standard markets.
When using this method of accessing the Android Market, I often see many apps attempting to be downloaded to my system - and failing. None of them are apps I have chosen at any point. I wonder why the Market thinks I want them? Looks like there may be a hack in the setup that makes the Market think many M001's are the same M001. What I am seeing is consistent with a file having fixed values that should not be fixed but should instead vary according to the individual system / user.
[quote name='jayk2k;13128]Mogrith posted this in another thread' date=' and it worked for me.[/QUOTE'] This worked for me originally however now I have 5 download icons on the top bar that won't go away. The device seems to be going slower now as well.Any ideas as to how I can get rid of these icons?Thanks
I found going into Manage Applications/Download Manager and clearing the app data (cache) worked.
1 - 20 of 20 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.