Android Tablets Forum banner
1 - 20 of 60 Posts

·
Vendor
Joined
·
1,154 Posts
Discussion Starter · #1 ·
Asked before, but maybe too early for people to have them..... try again...This Epad ZT180, or Zenithink ZT180 (others have em, flypad, wiipad etc...) with the Cortex A8 I think CPu, 256 ram, 10 inch screen...Finally out with Android, but I was told these have big issues.... Compat problem between Wifi, CPU, Battery.Namely, they overheat, the Wifi doesn't work, and the Battery dies after 1 hour (4 hour recharge cycle).Someone said within last couple days they fixed it to work 3 hours... still not the 5-7 hour listed.Even read one report Zenithink admitted the problem and that there's a faulty Wifi module, and programming problem with the Droid, CPU and battery.Sometimes doesn't show up for a week, or couple cycles....ANYONE KNOW THE TRUE STATUS ON THESE ?thanks
 

·
Vendor
Joined
·
1,154 Posts
Discussion Starter · #4 ·
i knew about beta issues, but this is something even discovered last week.... so, i dont know if bad reporting, or if something quickly fixed, or what.i was hoping someone might have hands on Droid 2.1 ZT180 experience that could say.... and not the actual battery life and Wifi ability.??sorry mozz... not a clue.. have you asked the seller, usually they have one emailed to them from the manufacturer... not the same but...
 

·
Vendor
Joined
·
1,154 Posts
Discussion Starter · #7 ·
merlot, i was on that site, but saw no reference to problems being solved?thanks matemozz--- sellers usually say "coming soon" with these units IF they simply don't have android, OR are not willing to sell yet because the problems still exist.
 

·
Vendor
Joined
·
1,154 Posts
Discussion Starter · #8 ·
hey, got word from the seller... by mistake i posted this as new topic.....the Epad ZT180 is a seller flash Droid, that is, it is not Android rewritten for zt180, it's just a ROM flashed onto whatever the factory ships them.as i said, i believe the company is honest enough, she did tell me, but it explains the issues it's having.this is upsetting.maybe it means the hardware is there and down the road when someone makes a working Droid for ZT, it will be ready for it, i dont know.
 

·
Vendor
Joined
·
1,154 Posts
Discussion Starter · #11 ·
axelwhat i mean is, the epad zt180 does not come FROM THE FACTORY with a working Android 2.1Droid is flashed onto it by whatever seller is selling them.who know what they had on them to start with (probably wince)without Android being tweaked at the factory to work with whatever cpu etc... you get problems.so, im asking if there ARE MIDS coming out of the factory with working, unit appropriate Android ?
 

·
Registered
Joined
·
44 Posts
Until I can get my hands on a linux kernel for the Zenithink, I decided to crack it open and find the serial port. Here's some output from uboot:
U-Boot 2009.08 (Jul 10 2010 - 17:14:29) for zenithink 1008MHz ddr126 256M 4L fastCPU : iMAPx200 @ 1008 MHzFCLK: 1008 MHz, HCLK: 126 MHz, PCLK: 63 MHzSDRAM: 256 MBMMU : Enabled!!NAND: 2048 MiBIn: serialOut: serialErr: serialMMC: Net: GMACGPBDAT is 0xf , 0x20e10010Bootup U1 successfully!!GPBDAT 2 is 0xfusb_otg_attach : 0x4fff0000 = 0xffffffffHit any key to stop autoboot: 2  1  0 Loading OS image ...MMC Device 0 not foundresult is 1OEM NAND read finished.iMAP NAND: 1 bit ECC error, corrected.iMAP NAND: 1 bit ECC error, corrected.iMAP NAND: 1 bit ECC error, corrected.iMAP NAND: 1 bit ECC error, corrected.iMAP NAND: 1 bit ECC error, corrected.iMAP NAND: 1 bit ECC error, corrected.iMAP NAND: 1 bit ECC error, corrected.iMAP NAND: 1 bit ECC error, corrected.iMAP NAND: 1 bit ECC error, corrected.iMAP NAND: 1 bit ECC error, corrected.OEM NAND read finished.Image Ready! Load address = 0x40200000Move zNK to swapMove zNK to swap...done!U-Boot 2009.08 (Jul 10 2010 - 17:14:29) for zenithink 1008MHz ddr126 256M 4L fastCPU : iMAPx200 @ 1008 MHzFCLK: 1008 MHz, HCLK: 126 MHz, PCLK: 63 MHzSDRAM: 256 MBMMU : Enabled!!NAND: 2048 MiBIn: serialOut: serialErr: serialMMC: Net: GMACGPBDAT is 0xf , 0x20e10010Bootup U1 successfully!!GPBDAT 2 is 0xfusb_otg_attach : 0x4fff0000 = 0xffffffffHit any key to stop autoboot: 2  0 [email protected]:# printenvbootdelay=2baudrate=115200stdin=serialstdout=serialstderr=serialbootargs=console=ttySAC1,115200 rdinit=/init mem=256Methact=GMACserverip=192.168.0.50ipaddr=192.168.0.111bootcmd=nand read 40200000 1000000 600000;go 40200000Environment size: 232/16380 [email protected]:# bootmWrong Image Format for bootm commandERROR: can't get kernel [email protected]:# help? - alias for 'help'autoscr - DEPRECATED - use "source" command insteadbase - print or set address offsetbdinfo - print Board Info structureboot - boot default, i.e., run 'bootcmd'bootd - boot default, i.e., run 'bootcmd'bootelf - Boot from an ELF image in memorybootl - Boot pre-burned linux.bootm - boot application image from memorybootp - boot image via network using BOOTP/TFTP protocolbootvx - Boot vxWorks from an ELF imagebootw - Boot pre-burned wince.cls - clear screencmp - memory compareconinfo - print console devices and informationcp - memory copycrc32 - checksum calculationdcache - enable or disable data cacheecho - echo args to consoleexit - exit scriptfatinfo - print information about filesystemfatload - load binary file from a dos filesystemfatls - list files in a directory (default /)go - start application at address 'addr'help - print online helpicache - enable or disable instruction cacheiminfo - print header information for application imageimxtract- extract a part of a multi-imageitest - return true/false on integer compareloadb - load binary file over serial line (kermit mode)loads - load S-Record file over serial lineloady - load binary file over serial line (ymodem mode)loop - infinite loop on address rangels - ls.md - memory displaymm - memory modify (auto-incrementing address)mmc - MMC sub systemmmcinfo - mmcinfo <dev num>-- display MMC infomtest - simple RAM read/write testmw - memory write (fill)nand - NAND sub-systemnboot - boot from NAND devicenfs - boot image via network using NFS protocolnm - memory modify (constant address)ping - send ICMP ECHO_REQUEST to network hostprintenv- print environment variablesrarpboot- boot image via network using RARP/TFTP protocolreginfo - print register informationreset - Perform RESET of the CPUrun - run commands in an environment variablesaveenv - save environment variables to persistent storagesetenv - set environment variablesshowvar - print local hushshell variablessleep - delay execution for some timesource - run script from memorytest - minimal test like /bin/shtftpboot- boot image via network using TFTP protocolversion - print monitor versionwup - WinCE update [email protected]:# versionU-Boot 2009.08 (Jul 10 2010 - 17:14:29) for zenithink 1008MHz ddr126 256M 4L [email protected]:# [email protected]:# baseBase Address: [email protected]:# bdinfoarch_number = 0x000008F8env_t = 0x00000000boot_params = 0x40000100DRAM bank = 0x00000000-> start = 0x40000000-> size = 0x10000000ethaddr = (not set)ip_addr = 192.168.0.111baudrate = 115200 [email protected]:# bootw
 

·
Registered
Joined
·
44 Posts
I have two of the ePads and neither will recognize MicroSD cards. I have tried 2x2GB Sandisk, 1x4G Sandisk SDHC, 1x1GB Kodak. I wonder if mmc support in this uboot is screwed up. Anyone else have an epad that can test SD cards?
 

·
Registered
Joined
·
12 Posts
Mine arrived this afternoon.The android 2.1 that is installed is quite buggy.It still has all the phone related components - network signal strength, ringer volume settings, etcThe included LAN dongle works, no problems with ethernet connectivity.Wifi is a little dodgy. It shows only one bar of signal when in a room that has full signal on my laptop. It does occasionally dropout or refuse t connect in the first place. Speed is also low,web pages take a while to load.There is no Android Market.It sometimes hangs and requires rebooting.It also gets occasional error message stating that such and such was unable to continue (or something I can't remember the exact error message).The screen could also be a little more responsive, but it is not too bad.Battery so far seems ok, 4 hours to fully charge and so far I have probably used it for 2.5hrs with wifi on and the battery indicator still shows around half full.It gets a little warm on the bottom left corner.It seems to me like (as was mentioned earlier) that the seller has just slapped android onto a former Win CE tablet or something and got it barely running. It certainly hasn't been optimized for this particular unit.[quote name='mozzwald;24428]I have two of the ePads and neither will recognize MicroSD cards. I have tried 2x2GB Sandisk' date=' 1x4G Sandisk SDHC, 1x1GB Kodak. I wonder if mmc support in this uboot is screwed up. Anyone else have an epad that can test SD cards?[/QUOTE'] I have a Sandisk 2GB in mine and it is fine.
 

·
Registered
Joined
·
44 Posts
The bottom left corner is where the USB wifi chip is located. It gets very hot in CE as well. I assume my SD problems are because of a rush to market release of software. U-Boot won't even see the cards so a simple flash upgrade by SD is not an option for me. I don't spose you could copy your mtd partitions off your device and put them up for download? :)I'm working on a small blog post with more info on what I know. You can see some internal pictures here: http://mozzwald.com/image/tid/21
 

·
Registered
Joined
·
383 Posts
mozzwald;24977 said:
The bottom left corner is where the USB wifi chip is located. It gets very hot in CE as well. I assume my SD problems are because of a rush to market release of software. U-Boot won't even see the cards so a simple flash upgrade by SD is not an option for me. I don't spose you could copy your mtd partitions off your device and put them up for download? :)I'm working on a small blog post with more info on what I know. You can see some internal pictures here: http://mozzwald.com/image/tid/21
I got my M16/ZT-180 yesterday... my TF is a bit funky but I have gotten it to accept both 16 and 32GB cards if you pop in and out a cpouple times... but it tends to hang when accessing lots of files... I haven't been able to get ADB to connect via USB cable... never recognized as anything plugged in... I was able to copy system to the SDcard and I'll try to got some more in the morning... really need a fresh build as this zenithink rom is really rough... really need to get root and adb to get very far I'm afraid...
 
1 - 20 of 60 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top