Android Tablets Forum banner
21 - 40 of 73 Posts

·
Registered
Joined
·
239 Posts
Just a quick word on benchmarking:

I am currently tweaking the build.prop file and I noticed that the results might be skewed by the SD card used.

Please boot your device wihtout SD Card before running benchmarks so we can compare apples to apples.


There is something else going on :| Will investigate, as 2 different runs one after another gave results over 150 pts appart

Thank you.

DW

PS: There should be an intermediate release between 1a and the version with the build.prop files. I am working on a little surprise
hehehehe (dont get your hopes up, its NOT flash 11 nor iPlayer)
 

·
Registered
Joined
·
113 Posts
DW why is the first post in this thread lined through? Have you given up on your ROM now?

What was the surpirse you had up your sleve aswell mate?

Cheers Harty
 

·
Registered
Joined
·
239 Posts
DW why is the first post in this thread lined through? Have you given up on your ROM now?

What was the surpirse you had up your sleve aswell mate?

Cheers Harty
Harty,
If you would have asked me this question 3 hours ago I would have said yes.
Now, to be honest, I don't know what will happen with it.
I just don't know if it is worth it.
Getting my roms up to the others' quality would be a massive undertaking I don't think I have the knowledge for,
and I don't think using someone else's rom as a base is fair to the original coder. (At least if I share it publicly)

The surprise was the deodexed app folder, but it ended up being a curse more than surprise...
I also wanted to update busybox and a couple other things in the next release, but yeah, idk

I am sorry if this is not clear or has bad grammar, I am exhausted ...

DW
 

·
Registered
Joined
·
113 Posts
No problems mate, I wouldnt have been able to do half of what you have done anyway. Why dont you help XpLoZa with his ROM and suggest anything you may be able to add to his such as your deodexed app folder? That way we could have one great ROM Im sure he would be happy with some help and ideas. Thanks for your work so far anyway and hope you stay on the forums.

Cheers Harty
 

·
Registered
Joined
·
239 Posts
Harty,
Great timing once again


I have already send a message to Xploda to let him know he was free to use the deoxed apks.
I warned him against them, because at the time I thought they might have been the culprit for the AC3 issue.

They might not be thought, as I might have found the solution to my AC3 problem, and well, If i'm right it actually never worked but, lets see!

I'll test my video on Xploda's rom since his AC3 is working before I flash back my rom. (thought of that just in time lol)

I disagree with some of the directions he took, but this is in no way bad, just different opinions

Without talking to each other, we took 2 totally different routes, his being all integrated, mine being more of a build-your-own (or Ikea
) kind of thing.

He did amazing work. His tweaks, but especially his boot screen rocks !

DW

EDIT:
God damn I could watch this boot screen all day... :| lol

Harty:
And I wanted to change the backgrounds to less sucky ones, again! got further but not quite there yet.
 

·
Registered
Joined
·
239 Posts
On an unrelated note:

Known ZT282 issues by me: (happened with any rom on my tablet)

#1: If your tablet stops charging intermittently, it most likely is the charger, EVEN if you check it with a multimeter and it looks fine. (+24h wasted, had fun poking around inside, wonder if I can find the serial port test points *wink wink*)

#2: If you flash a rom (any rom really) and you don't have sound after the flash, flash it again. (Happened to me a couple times)

#3: If it looks like it doesn't want to turn ON, it might actually be ON but stuck somehow, press the reset button to shut it down
(you will notice the screen getting a little darker) and power it up again, it should be fine.

#4: Open up your tablet NOW. If I wouldn't have opened myself, I wouldn't have known about the wires with its insulation melted.
(Nice soldering job on that one, my chinese friend.... )

#5: If you feel like throwing it through a wall, go to sleep


Thought I would share if it can be of use to anyone.
I will update if I think of other things.
Let me know if you have any to add!

DW
 

·
Registered
Joined
·
113 Posts
DW Im stuck in a recovery loop help! Tried XpLoZas new ROM first with the 1.2Ghz and 2GB partition kernel from omarahum but it kept freezing and kept saying preparing internal storage checking for errors.

Then I read a bit on here and figured I needed the correct recovery file and flashed it again replacing the kernel and recovery files in the ROM with the ones from the same folder in the media fire of omarahums folders (sorry thats long winded but hope you get me). Now it went into update mode then recovery mode and keeps recovering itself over and over never starting up. I have pressed the reset button and when starting back up goes into recovery mode and pulled the memeory card and it still does it. Any ideas?

Cheers harty
 

·
Registered
Joined
·
239 Posts
Harty:

Sorry to hear about your troubles :| I will try to help you the best I can, but as I said previously, my knowledge is pretty limited.

First thing to do, make sure the tablet has sufficent battery (or have it powered) and make sure it is shut down. (by pressing the reset button, you should here the speakers chirp)

When I hit a snag, I like to flash back to the stock rom (or at least stock kernel and recovery) because I know they work. It can take more than 1 flash.

Very important! :
Make sure you format your SD card using HP flash formatting tools (if you are using windows)
You can do a quick format but make sure to format it. I have had weird errors sometimes if I didn't.

I'd say try that and let me know how it works out.
I'm pretty sure it is not related to the rom you are using, to me it looks more kernel-like.

But then again, I'm just a noob with a tablet here.

If it doesn't work, try to either get pictures, or the exact error(s) message(s) you are getting, so I can try to help you further.

DW

That reminds me... I need to talk to Omarahum about kernels...
 

·
Zenithink Tablet User / Information Transmitter
Joined
·
6,629 Posts
DW Im stuck in a recovery loop help! Tried XpLoZas new ROM first with the 1.2Ghz and 2GB partition kernel from omarahum but it kept freezing and kept saying preparing internal storage checking for errors.

Then I read a bit on here and figured I needed the correct recovery file and flashed it again replacing the kernel and recovery files in the ROM with the ones from the same folder in the media fire of omarahums folders (sorry thats long winded but hope you get me). Now it went into update mode then recovery mode and keeps recovering itself over and over never starting up. I have pressed the reset button and when starting back up goes into recovery mode and pulled the memeory card and it still does it. Any ideas?

Cheers harty
Is your camera button stuck?Or either of the volume ones?
 

·
Zenithink Tablet User / Information Transmitter
Joined
·
6,629 Posts

·
Registered
Joined
·
239 Posts
Discussion Starter · #35 ·
Hi again!
(Tab is flashing
)

Yeah the kernel thing ...

I tried doing an overclocked kernel using the scripts from... Johanes I think his/her name his, and your tips on getting it to work a couple posts down, but it didn't seem to work...

I assumed that since the kernel's speed were both the same at stock, that it would work on the 282, but it didnt.

Maybe there was something wrong with my tools version or something :|

Any hints you can give me if you have the time I would appreciate.

I'm also looking into all the talks in the C71 forum about running linux on the tab, but for one simple reason: init.d

I still didn't find a way to load the serial modules at startup. I might just be too god damn thick lol.

Thanks for taking the time


DW
 

·
Zenithink Tablet User / Information Transmitter
Joined
·
6,629 Posts
Hi again!
(Tab is flashing
)

Yeah the kernel thing ...

I tried doing an overclocked kernel using the scripts from... Johanes I think his/her name his, and your tips on getting it to work a couple posts down, but it didn't seem to work...

I assumed that since the kernel's speed were both the same at stock, that it would work on the 282, but it didnt.

Maybe there was something wrong with my tools version or something :|

Any hints you can give me if you have the time I would appreciate.

I'm also looking into all the talks in the C71 forum about running linux on the tab, but for one simple reason: init.d

I still didn't find a way to load the serial modules at startup. I might just be too god damn thick lol.

Thanks for taking the time


DW
If you want to post your terminal output from the Linux OS where you tried to make it (copy and paste the whole thing of you trying to make them), I may be able to tell you what might be wrong.... Again, all this is over my head, I just followed johanes instructions, I am not a Linux User....

I also told unknown26man how to make them (pretty much the same way, he sent me the errors he was getting and I told him what he was doing wrong), so you can ask him also, although it appears he hasn't been on the forum for the last month and a half (well at least he didn't miss any new Official Zenithink ROMs, lol).... Plus there's probabaly a lot of other people in the forum who can help you (if I can't)...
 

·
Registered
Joined
·
239 Posts
Discussion Starter · #37 ·
I'm sorry I think I didn't express myself correctly...

The changes weren't applied after boot


I mean, It was....

I'm a f.... idiot. Nevermind.

I'm sure I did the script on the 2gb rom I am using... you know... the 900mhz one...

I'm sure you get what might have happened now lolll


/me hides in a corner in shame

DW
 

·
Zenithink Tablet User / Information Transmitter
Joined
·
6,629 Posts
I'm sorry I think I didn't express myself correctly...

The changes weren't applied after boot


I mean, It was....

I'm a f.... idiot. Nevermind.

I'm sure I did the script on the 2gb rom I am using... you know... the 900mhz one...

I'm sure you get what might have happened now lolll


/me hides in a corner in shame

DW
I have had a long bad day too, I'm sorry but I don't understand (may just be the amount of pain I'm in and being so tired)....

This is what I used to make the kernel:
Code:
rm kernel*<br />
rm *.dump<br />
rm ZT282.recovery<br />
<br />
dd if=ZT282.kernel of=kernel1.lzma bs=128 skip=1<br />
<br />
lzcat < kernel1.lzma > kernel1<br />
<br />
hexdump -C kernel1 > stock.dump<br />
<br />
##Do overclock patch to 900Mhz (0x35A4E900)<br />
sed 's/\x00\x46\xc3\x23\x00\xa3\xe1\x11\x00\x08\xaf\x2f/\x00\x46\xc3\x23\x00\xa3\xe1\x11\x00\xe9\xa4\x35/' kernel1 > kernel2<br />
<br />
##Do patch to 2GB userdata <br />
sed 's/\xf8\xbb\x94\xc0\x00\x00\x00\x00\x00\x00\x00\x40\x00\x00\x00\x00\x00\x00\x00\x40\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x04\xbc\x94\xc0\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x80\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00/\xf8\xbb\x94\xc0\x00\x00\x00\x00\x00\x00\x00\x80\x00\x00\x00\x00\x00\x00\x00\x40\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x04\xbc\x94\xc0\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\xc0\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00/' kernel2 > kernel3<br />
<br />
hexdump -C kernel3 > mod.dump<br />
<br />
java -Xmx512m -jar JLzma.jar e kernel3 kernel.patched.lzma<br />
sudo mkimage -A arm -O linux -T kernel -C lzma -a 80008000 -e 80008000 -d kernel.patched.lzma -n Linux-2.6.34 kernel.patched.uImage<br />
sudo mkimage -A arm -O linux -T firmware -C none -a ffffffff -e 00000000 -d kernel.patched.uImage -n [URL=LK:ZT282_H3_1a]LK:ZT282_H3_1a[/URL] ZT282.recovery<br />
<br />
diff mod.dump stock.dump<br />
binwalk ZT282.recovery<br />
This is what I used to make the recovery file:
Code:
rm kernel*<br />
rm *.dump<br />
rm ZT282.recovery<br />
<br />
dd if=ZT282.kernel of=kernel1.lzma bs=128 skip=1<br />
<br />
lzcat < kernel1.lzma > kernel1<br />
<br />
hexdump -C kernel1 > stock.dump<br />
<br />
##Do overclock patch to 900Mhz (0x35A4E900)<br />
sed 's/\x00\x46\xc3\x23\x00\xa3\xe1\x11\x00\x08\xaf\x2f/\x00\x46\xc3\x23\x00\xa3\xe1\x11\x00\xe9\xa4\x35/' kernel1 > kernel2<br />
<br />
##Do patch to 2GB userdata <br />
sed 's/\x08\x76\xc3\xc0\x00\x00\x00\x00\x00\x00\x00\x40\x00\x00\x00\x00\x00\x00\x00\x40\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x14\x76\xc3\xc0\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x80\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00/\x08\x76\xc3\xc0\x00\x00\x00\x00\x00\x00\x00\x80\x00\x00\x00\x00\x00\x00\x00\x40\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x14\x76\xc3\xc0\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\xc0\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00/' kernel2 > kernel3<br />
<br />
hexdump -C kernel3 > mod.dump<br />
<br />
java -Xmx512m -jar JLzma.jar e kernel3 kernel.patched.lzma<br />
sudo mkimage -A arm -O linux -T kernel -C lzma -a 80008000 -e 80008000 -d kernel.patched.lzma -n Linux-2.6.34 kernel.patched.uImage<br />
sudo mkimage -A arm -O linux -T firmware -C none -a ffffffff -e 00000000 -d kernel.patched.uImage -n [URL=LK:ZT282_H3_1a]LK:ZT282_H3_1a[/URL] ZT282.recovery<br />
<br />
diff mod.dump stock.dump<br />
binwalk ZT282.recovery
 

·
Zenithink Tablet User / Information Transmitter
Joined
·
6,629 Posts
Well the scripts looks for 800mhz to patch it to 1000mhz doesnt it?

Hard to find 800 in a kernel that is already at 900 lol...
Ah, gotchya,
well I editted my previous post and posted the scripts I used.... Of course for the recovery file, I renamed the stock ZT282.recovery file to ZT282.kernel before I executed it, and for the ZT282.kernel, I renamed the outputted ZT282.recovery file to ZT282.kernel....

Hope that helps...
 
21 - 40 of 73 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top