Android Tablets Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
So my Eken M001 won't charge anymore, I had another charger that met all of the requirements and it won't even charge it, I even tried on different outlets in different rooms with both chargers with no sucess. I've read on some laptops that sometimes the charging pins connection can sometimes break off of the motherboard, but I'm kind of scared to open it up since I don't know what I'm doing or looking for. I just bought this off of ebay for 49.99 plus 60.95 shipping, so even if I did try to exchange for a replacement it would probably cost alot more than the device is actually worth! If anyone can walk me through this, maybe even with some pictures, I would greatly appreciate it!!
 

·
Registered
Joined
·
40 Posts
When plugged into the wall, I get no LED lights until I hit the power button. If I disconnect the charger, everything immediately goes off. I've tried re-setting it with the little reset pinhole on the back, I've tried re-flashing the Android software, and I've tried 3 different chargers, including a brand new iPhone charger cord. I'm at a loss : /
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
Ok well I figured out that the other charger wasn't "long" enough if that makes any sense. So I got a universal charger from Wal-mart for $18 and it works perfectly again!! YAY!!
 

·
Registered
Joined
·
14 Posts
[quote author=roxyq662 link=topic=406.msg4363#msg4363 date=1275497822]Ok well I figured out that the other charger wasn't "long" enough if that makes any sense. So I got a universal charger from Wal-mart for $18 and it works perfectly again!! YAY!![/quote]Today I went to Walmart too, and picked up a universal charger brand name Powerline for 18.00. Now my M001 is able to charge.
 

·
Registered
Joined
·
19 Posts
imayoda;5429 said:
Be aware you need 9V and at least 1.5 amps on your chargers.. there are threads with people that got eken burnt fo the wrong power supply ;)
So what did you mean by "eken burnt for the wrong power supply"..?This answers the question why I had a 9volt 1amp power supply in my box and it chargedmy NEW M001 just one time...does that mean by using that power supply I damaged theunit? Its the one that came in the box for crying out loud..didn't think I needed to researchif I was using the correct power cord if its the one that came with it...
 
1 - 11 of 11 Posts
Top