Android Tablets Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
97 Posts
Discussion Starter · #1 ·
I wanted to put a cookbook together on how to get your PDN into deep sleep and keep it sleeping overnight. Doing this may require you disable or remove some of your apps and make others not as convenient to use by turning off automatic update options. If you don't think saving power is worth it don't attempt these instructions.Let me know the results... I'd like to try to get this so it works for most people.The first thing you will need is a good reliable tool to examine your system that does not depend on background monitors or services. There are likely many of these available. The one I use I know works so lets begin:1. Download and install "system panel". The lite version from the marketplace is good enough. If you don't have marketplace google around for the apk. Try including androidsoft4u.2. Reboot your system to start off with a clean system.3. In settingsa. Under "wireless and networks" turn off wifib. Under "Sound and display" select the last item.. "screen timeout"... select a smallish value like 2 minutes.b. Under "Location and security" turn off "use wireless networks" and "use gps satellites"c. Under "accounts and sync" turn off "Background data"d. Under "privacy" turn off "use my location" and "back up my settings"4. Run system panel app. the default first page shows active tasks and inactive tasks. The inactive ones don't matter. But the only active task you want is system panel. I also have "better keyboard" app showing here which I know allows deep sleep. But if you have any task monitors or email clients or google stuff here.. Kill them one by one. Press the task and on the next page select the kill button.5. Kill off any services you have running.. Under "settings - applications settings" select "running services". The only one I have is better keyboard which I know allows deep sleep. Anything else should be suspect. GTalk loves to hang out here if you have GE installed. Kill them all...6. Some apps have options for automatic checking of something... for example email programs might check for new email every hour. If you have any apps like this installed turn off the automatic checks. This might be email clients, instant messaging programs, news programs, social networking programs, task killers, etc.7. Select "spare parts - battery history". Check "other usage" on first box and "since last unplugged" on second box. Press the "running" bar.. Copy down how many minutes was spent without sleep.8. Check using system panel one more time for active tasks. Kill any that snuck back in. And exit the system panel.9. Be sure you are at the homescreen.10. FINALLY TURN OFF YOUR SYSTEM.. using the power switch.11. Wait 10 minutes 12. Turn on your PDN13. Check the running time again from step 7... It should be the same as when you turned it off. This is deep sleep.If your system went into deep sleep you can go back to step 8 and wait longer. Unless you installed GE you should be able to wait as long as you want within reason... THere is still small power drainage.. I suspect you could leave the system with a full charge in this state for more than a week or so. But I have not played with this at all.If you have GE installed and you intend to let the system sleep more than 30 minutes you need to replace step 10 with:10. Wait for the "screen timeout" to turn off the system.
 

·
Registered
Joined
·
97 Posts
Discussion Starter · #4 ·
bugeyed,Thank you for taking the time to try this. I get a 5 - 10 second period when the screen is dim before it goes to off... I don't think this time is relevant. I only get it when using the screen timeout value not the on/off switch. I believe Android is giving you a chance to hit the screen and cancel the sleep. The steps provided do not affect this period to the best of my knowledge.I think you said earlier you did not install GE... that may be why you don't have the "backup my settings" option. But I think I had the "use my location" from the beginning... Time for your virgins to speak up..It sounds to me like your PDN was in deep sleep for over 6 minutes before something triggered it to wake up. Did you use the power switch or timeout ? If timeout what is the value of your timeout ? Was the screen black or dim when you woke it up ? Did you disable the Advanced Task Killer monitor ? There has to be something going on in your system that is not being put to sleep. I have around 30 apps installed. But they are mostly simple games or productivity apps. Very few system type apps that are most likely to affect sleep time by waking up and doing something. I uninstalled all of those. Also what homescreen program are you using.. I use launcher pro
 

·
Registered
Joined
·
97 Posts
Discussion Starter · #7 ·
bugeyedre the auto light sensing... AT this point anything is possible.. I have not noticed this but haven't been looking for it. I'll pay more attention.Something is definately more active in your system than in mine. This is a similar result to your previous one... Around 6 minutes of deep sleep before something ran that partially woke it up.You mentioned advanced task killer in some other post... Do you still have it installed ? It does have a timer option to check for tasks to kill periodically.. This should be disabled or the app removed since these periodic checking for things are what I suspect is stopping our systems from staying asleep.This morning when I woke up my screen was also dim..RATS!. Deep sleep had been interrupted after 6 hours. So there is still something active in mine also.. I have been very successful in getting mine to sleep soundly for 4-5 hours but only by letting it time out to sleep. I do have GE installed. When I pull the power switch it can only deep sleep about an hour. Something in GE is much more aggressive at periodic checking.
 

·
Registered
Joined
·
97 Posts
Discussion Starter · #8 ·
hello worldinteresting finding about setting being inactive... Since settings wasn't active or inactive when your machine went to sleep but it was when it woke up settings definitely ran. I quit killing the inactive tasks... after I studied it on the web. I believe the inactive tasks are how android manages it's memory. It lets the stuff lay around in memory inactive rather than releasing the memory... If the memory is needed then it removes the inactive tasks... I believe this is in the hope that the user will run this program again and save some steps. But in this case it's like footprints.Also your experience of around an hour of sleep after pulling the switch is consistant with mine. I assume you have GE installed ?I also have system panel on my homescreen... SO we are doing the same stuff.I have thought several times that I had this problem under control... But then shit happens.....like last night... my PDN did not sleep all night only around 6 hours..
 

·
Registered
Joined
·
97 Posts
In spite of all the problems associated with deep sleep I checked my usage today..I recharged it this morning.. I have12 hours 41 minutes since unplugged.1 hour and 25 minutes of run time30 minutes of wifi time80 % battery left.I have alternated between power off switch when I knew I'd be coming back in 10 minutes or so and screen timeout.... my value is 45 seconds.. When I knew I'd be gone for a while. I have taken it with me on a shopping expedition with my wife and while visiting friends.. This is actually very acceptable power usage....I'll try again tonight for long ( more than 6 hours ) deep sleep...
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top