Android Tablets Forum banner

[custom rom] CyanogenMod 10.2 (4.3.1) by ChristianTroy - update 2013-11-30

251502 Views 367 Replies 114 Participants Last post by  cxz
If you appreciate my work and would like to support me with a small donation you can click on btn_donate_SM.gif button.
If every happy user of this rom would just donate something I could invest more time in all these Android projects.

Issues and possible workarounds

* HDMI out doesn't work. Actions uses two hwcomposer modules, I don't know why, maybe because even they don't have access to Vivante's hwc source code, anyway to have HDMI working you need both modules. With 4.3 the two hwc modules races each other so you I can load only one of them. If (and when) a stock 4.3 will be available (both hwc HALs come as binary blobs) this will probably be fixed, in the meantime in the next days I'll see if it can be worked around in some way.

Extra features

* Xbox 360 gamepad support (xpad)
* Generic / chinese (Pantherlord / GreenAsia) gamepads support (hid-pl and hid-gaff)
* Veno congestion control algorithm
* USB bluetooth (It supports only CSR devices, they can be identified typing "lsusb" from an app like "terminal emulator": the supported device will be present with an entry like "Bus 001 Device 002: ID 0a12:0001" ("0a12:0001" is the supported VID:pID). Do not boot with the bluetooth plugged in; plug it once you booted to android.)


* You need TWRP to be able to flash this rom. Read the linked thread for instructions.
* Put rom (cm-10.2-$, gapps (gapps-jb-$ and compatibility zip on internal memory or external sdcard.
* Turn on the tablet in recovery mode as explained in TWRP thread.
* If this is your first install select "Factory reset" from "Wipe" menu.
* Flash rom (cm-10.2-$, gapps (gapps-jb-$ and the required compatibility zip.
* Now select "Reboot".
* Enjoy CyanogenMod 10.2!

Changelog & download links


* Updated upstream sources

ROM (md5sum)
Gapps ( mirror )

Compatibility zips

Next to comp zip's download link you will find the name of the stock ROM you must flash before to match the required kernel modules (it's based on the file name of the stock rom I used to grab the included kernel).

* Ainol Venus rc1 (2013-05-23-V1-4.2)
* Ainol Hero v1 rc1 (2013-05-21-V1-4.2)
* Ainol Hero v2 rc1 (2013-05-21-V2-4.2)
* Ainol Captain rc4 (20130820)
* Ainol Crystal II rc1 (4.2cris2)
* Ainol Discover rc2 (atm7029_AINOL_SDK0906_NOVO806_2013-9-27)

Third party compatibility zips

* Ainol Crystal II by cxz (TWRP) - Use this if you have a newer Crystal II (you will identify it because touch won't work using my twrp / comp zip)
( edit: Above link is dead. Here is just the touch fixer for all Crystal2s. Flash it after the comp zip. -cxz )


* WiFi now can stay enabled with display turned off. Note that if WiFi is enabled the tablet won't enter deep sleep so if you're more interestead in battery life instead of an always on WiFi change policy (on "Advanced" WiFi settings) from "Always" to "Never" and select your preferred WiFi timeout.
* Internal memory is mounted at /storage/sdcard0, external sdcard is mounted at /storage/sdcard1. If you wanna swap them (and make primary your real microsd) just edit "persist.sys.vold.switchexternal=0" to "persist.sys.vold.switchexternal=1" in "/system/build.prop" file
* If you don't like the new feature that automatically triggers airplane mode when the display is turned off you can change "ro.disable_auto_airplane_mode=0" to "ro.disable_auto_airplane_mode=1" in /system/build.prop file.


See less See more
  • Like
Reactions: 5
1 - 5 of 368 Posts
I did install this ROM at yesterday and I have noticed that my tablet crashes frequently now. Crash happens usually once or twice in hour (CM loading screen appears) when I'm using the device. I have reinstalled rom once and it didn`t help at all. Can you figure out what is the problem? My device is Ainol Novo 10 captain basic.
Speaking of juicy things... anyone with a captain tried that wakelock thing? just to see if it's limited to the discover or it's something buggy in the platform itself
I could try it out if somebody gives link to correct website and bit introductions. I'm newbie (and my English ain't perfect) so it might take sometime to figure it out by myself.
what do you mean? I guess you're using a captain, are you coming from the 0927 stock rom?
First I tried to flash cm 10.2 (4.3) with rc1 from cm 10.2 (4.3) with rc0 (it was too unstable). After flashing it got stuck in boot screen ainol Tav NOVO10 quad-core. Yesterday I flashed back to stock rom (atm7029_AINOL_SDK0906_NOVO102_2013-9-24 [v.]. Shud I try to flash Discover's stock rom (0927)?) then to CM 10.2 (4.3) with rc2 compzip. Now it works fine but screen auto-rotate doesn't work (stays all the time in portrait view). I also tried with AOKP and it had same problem :/ Yes I'm using Captain (Basic).

Here is pic what I meant about rotate buttons. Is there some way me to add these by myself?


See less See more
You can add the lockscreen orientation toggle to the top bar, or use an app to force rotation in some way. Anyway I just got report that on captain rotation works so be sure it's enabled in display settings otherwise try with stock again because it might be faulty somehow
Hmmm. Am I doing something wrong because it won't work? I have checked all places that auto-rotate is on (also turned off it and back to on).

1. Turn off device and connect it to PC. Turn device to "Firmware installation mode" (hold VOL UP + POWER buttons)
2. Load stock ROM atm7029_AINOL_SDK0906_NOVO102_2013-9-24 into Pad Product Tool (v.1.02.04)
3. Flash!
4. Disconnect device and turn on (screen rotation works now)
5. Move TWRP to sd-card
6. Turn off device and boot it to RECOVERY
7. Install TWRP and reboot device
8. Move 3 files to sd-card (ROM, gapps and compzip rc2)[what is md5sum file for?]
9. reboot device to TWRP
10. Wipe data
11. Flash device in with all 3 files (1.ROM 2.gapps 3.rc2)
12. Reboot
13. Screen rotation doesn't work anymore.

Also I have re-downloaded all files to ensure that files aren't corrupted...
See less See more
launch terminal emulator and type these commands

su<br />
dmesg > /sdcard/dmesg.txt<br />
getevent -p > /sdcard/getevent.txt<br />
logcat > /sdcard/logcat.txt
kill terminal emulator and grab those three files from internal memory, zip them and upload them somewhere
Here is the link for the 3 files . I have noticed that screen turns on slowly (3-4 sec).

[email protected]:/ $ su<br />
[email protected]:/ # dmesg > /sdcard/dmesg.txt<br />
dmesg > /sdcard/dmesg.txt<br />
[email protected]:/ # getevent -p > /sdcard/getevent.txt<br />
getevent -p > /sdcard/getevent.txt<br />
could not get driver version for /dev/input/mice, Not a typewriter<br />
[email protected]:/ # logcat > /sdcard/logcat.txt<br />
logcat > /sdcard/logcat.txt
Is that error critical?
1 - 5 of 368 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.