Android Tablets Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hi there,

I have a huge problem with my chuwi, I really don't know what happened.. Yesterday I charged it normally while sleeping and found it 100 % this morning. Later I went to buy a new charger (because mine sometimes produces sparkles when connected to a plug) but when we (me and the salesman) plugged in this new charger nothing happened. Black screen and no response at all.

So we tried to use the older one, but the results were the same.

So I wander.. What happened during the night?! This morning it worked perfectly and I really don't wanna think it was this new charger 's fault.

If so, I'm gonna ask for refund in some way.

PS.: when I brought it to the store and we tried the stuff mentioned above, is was turned off. So the only clue about it being okay this morning was the battery icon that was entirely green showing full charge when I unplugged it.

PS2: the new charger I asked for was 5v 2.5a as the old one.

Can someone help me?
Thanks in advance.

Inviato dal mio Samsung Galaxy S4 GT-I9505 tramite Tapatalk 4
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
Just wanna know if you think it could really have been the faulty charger.. I managed to open the tab however, unplugged and plugged again the battery to do an hard reset as I was suggested to do but it didn't work.

Inviato dal mio Samsung Galaxy S4 GT-I9505 tramite Tapatalk 4
 
1 - 3 of 3 Posts
Top