Jump to content


Photo

[ROM] CyanogenMod 10 for Allwinner A13


  • Please log in to reply
106 replies to this topic

#81 mon_gol

mon_gol

    Newbie

  • Jr. Member
  • Pip
  • 5 posts

Posted 15 September 2013 - 10:49 PM

do you flashed gslx680.zip patch from build 2013-08-28 folder?

i install cm10 +gapps + gslx680 + g-sensor = BLACK LCD

#82 ivancunningham

ivancunningham

    Newbie

  • Jr. Member
  • Pip
  • 2 posts

Posted 21 September 2013 - 06:45 PM

I had followed most of these options, but I must have missed a few things, I have a a13 softwaineerevb I did a backup of my old info but can't seem to gain access to it. all I get right now is the usb mass storage screen indicating usb connected it asks me to turn on usb storage but I get nothing. I have rebooted my device and tried using the volume up with power method to no success, tried volume down method with the power with no success, I even tried adb and fastboot but get no device found now. I am running windows 8 I don't have any other pc to try. when I try holding the volume+ and the power button I get tone from the pc but nothing shows in the device manager, even for the drives, I try the volume- and power get the same response. tone but nothing appears, when I just power the device up under the portable devices 2 devices pop up. please leave me know of options I can take to at least get into recovery to at least get my backup restored. I appreciate it.

#83 Gamblor

Gamblor

    Newbie

  • Jr. Member
  • Pip
  • 7 posts

Posted 10 October 2013 - 05:36 AM

Hi, I have managed to install CM, however the touchscreen doesn't work. I have an Ainol Novo 7 Rainbow. I have tried installing the "gslx680" touchscreen module, but it still doesn't work.
I flashed the ROM
Flashed gapps
Then flashed gslx680 module
Then rebooted and the touchscreen didn't work

I think maybe because my device numbers and event numbers are different to yours. Here are the logs from ADB:

lsmod
mt7601Usta 1942052 1 - Live 0x00000000
mma7660 7248 0 - Live 0x00000000
device 26862 0 - Live 0x00000000
mtprealloc7601Usta 1628 1 mt7601Usta, Live 0x00000000 (P)
rtl8150 10305 0 - Live 0x00000000
mcs7830 7581 0 - Live 0x00000000
qf9700 9152 0 - Live 0x00000000
asix 24601 0 - Live 0x00000000
sun5i_csi0 34042 0 - Live 0x00000000
camera 53105 1 sun5i_csi0, Live 0x00000000
gc0308 16888 1 - Live 0x00000000
videobuf_dma_contig 6243 1 sun5i_csi0, Live 0x00000000
videobuf_core 20242 2 sun5i_csi0,videobuf_dma_contig, Live 0x00000000
cedarx 11869 0 - Live 0x00000000
mali 200007 65 - Live 0x00000000
ump 34213 17 mali, Live 0x00000000
gslX680 221847 0 - Live 0x00000000
gt811_ts 18280 0 - Live 0x00000000
sun4i_vibrator 2451 0 - Live 0x00000000
nand 225008 8 - Live 0x00000000

getevent
add device 1: /dev/input/event3
name: "mma7660"
add device 2: /dev/input/event2
name: "gslX680"
add device 3: /dev/input/event0
name: "sun4i-keyboard"
could not get driver version for /dev/input/mice, Not a typewriter
add device 4: /dev/input/event1
name: "axp20-supplyer"

I have since reinstalled the stock firmware, but would prefer to use CM. I would appreciate your help. Thanks!

#84 AnonFBI

AnonFBI

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 68 posts

Posted 10 October 2013 - 11:44 AM

Hi, I have managed to install CM, however the touchscreen doesn't work. I have an Ainol Novo 7 Rainbow. I have tried installing the "gslx680" touchscreen module, but it still doesn't work.
I flashed the ROM
Flashed gapps
Then flashed gslx680 module
Then rebooted and the touchscreen didn't work

I think maybe because my device numbers and event numbers are different to yours. Here are the logs from ADB:

lsmod
mt7601Usta 1942052 1 - Live 0x00000000
mma7660 7248 0 - Live 0x00000000
device 26862 0 - Live 0x00000000
mtprealloc7601Usta 1628 1 mt7601Usta, Live 0x00000000 (P)
rtl8150 10305 0 - Live 0x00000000
mcs7830 7581 0 - Live 0x00000000
qf9700 9152 0 - Live 0x00000000
asix 24601 0 - Live 0x00000000
sun5i_csi0 34042 0 - Live 0x00000000
camera 53105 1 sun5i_csi0, Live 0x00000000
gc0308 16888 1 - Live 0x00000000
videobuf_dma_contig 6243 1 sun5i_csi0, Live 0x00000000
videobuf_core 20242 2 sun5i_csi0,videobuf_dma_contig, Live 0x00000000
cedarx 11869 0 - Live 0x00000000
mali 200007 65 - Live 0x00000000
ump 34213 17 mali, Live 0x00000000
gslX680 221847 0 - Live 0x00000000
gt811_ts 18280 0 - Live 0x00000000
sun4i_vibrator 2451 0 - Live 0x00000000
nand 225008 8 - Live 0x00000000

getevent
add device 1: /dev/input/event3
name: "mma7660"
add device 2: /dev/input/event2
name: "gslX680"
add device 3: /dev/input/event0
name: "sun4i-keyboard"
could not get driver version for /dev/input/mice, Not a typewriter
add device 4: /dev/input/event1
name: "axp20-supplyer"

I have since reinstalled the stock firmware, but would prefer to use CM. I would appreciate your help. Thanks!


Hello, the rom have preloaded gslX680.


Try to flash without touchscreen patch if do not work, copy and paste your gslX680.ko module from stock to cm10. read the main post to know how do it

#85 Gamblor

Gamblor

    Newbie

  • Jr. Member
  • Pip
  • 7 posts

Posted 11 October 2013 - 03:36 AM

Thanks for the fast response. Yeah I tried it with no compatibility patches and the touchscreen didn't work.

What program should I use to extract files out of the Novo7Rainbow-4.2_20130606v1.img file?

#86 DmW

DmW

    Newbie

  • Jr. Member
  • Pip
  • 2 posts

Posted 07 November 2013 - 10:43 AM

Hi,
I have a Chinese tablet with the following specs.

Processor Manufacture: AllWinner
Processor Type: A13
Processor Main Frequency: 1.2GHZ
Hard Drive Capacity: 4GB
Memory Capacity: 512MB
Touch Screen Type: Capacitive Screen
Display resolution: 800x480
Feature: Wifi,3G,Webcams,Multi Touch,G Sensor,Camera,Phone Call
Place of Origin: Guangdong, China (Mainland)
Model Number: MC-C714
Nand Flash: Nand Flash
Wifi: 902.11b/g/n
Carema: Front camera, 1.3 Megapixels
LCD: 7 inch Capacitive Touch Screen LCD 16:9, 800x480

And the output of my lsmod , getevent and cat modules.

127|root@android:/ # lsmod
lsmod
8188eu 581030 0 - Live 0x00000000
stk831x 28705 0 - Live 0x00000000
device 27006 0 - Live 0x00000000
mg8696s 63962 0 - Live 0x00000000
rtl8150 10305 0 - Live 0x00000000
mcs7830 7581 0 - Live 0x00000000
qf9700 9152 0 - Live 0x00000000
asix 24601 0 - Live 0x00000000
sun5i_csi0 33868 1 - Live 0x00000000
gc0308 16888 1 - Live 0x00000000
videobuf_dma_contig 6243 1 sun5i_csi0, Live 0x00000000
videobuf_core 20242 2 sun5i_csi0,videobuf_dma_contig, Live 0x00000000
cedarx 11468 4 - Live 0x00000000
mali 114007 12 - Live 0x00000000
ump 34122 23 mali, Live 0x00000000
zet6221_SY713 18883 0 - Live 0x00000000
nand 126290 4 - Live 0x00000000

root@android:/ # getevent
getevent
add device 1: /dev/input/event3
name: "stk831x"
add device 2: /dev/input/event2
name: "zet6221-ts"
add device 3: /dev/input/event0
name: "sun4i-keyboard"
could not get driver version for /dev/input/mice, Not a typewriter
add device 4: /dev/input/event1
name: "axp20-supplyer"

root@android:/proc # cat modules
cat modules
8188eu 581030 0 - Live 0x00000000
stk831x 28705 0 - Live 0x00000000
device 27006 0 - Live 0x00000000
mg8696s 63962 0 - Live 0x00000000
rtl8150 10305 0 - Live 0x00000000
mcs7830 7581 0 - Live 0x00000000
qf9700 9152 0 - Live 0x00000000
asix 24601 0 - Live 0x00000000
sun5i_csi0 33868 0 - Live 0x00000000
gc0308 16888 1 - Live 0x00000000
videobuf_dma_contig 6243 1 sun5i_csi0, Live 0x00000000
videobuf_core 20242 2 sun5i_csi0,videobuf_dma_contig, Live 0x00000000
cedarx 11468 0 - Live 0x00000000
mali 114007 12 - Live 0x00000000
ump 34122 23 mali, Live 0x00000000
zet6221_SY713 18883 0 - Live 0x00000000
nand 126290 4 - Live 0x00000000
root@android:/proc #

Now thats been covered here is my problem. I pulled ver cm_a13_20130828, gapps and zet6221-ts. I followed procedure and booted up in CWM recovery, did a factory reset / erase then loaded the CM rom, gapps and my touchscreen file. Everything loaded and booted but when it came up i had lost the function of the h/w "back" button on the tablet. That I can live without using softkeys but then I noticed that my wireless would not turn on. I checked with logcat and this is what I am seeing over and over again. This tablet does not have bluetooth or cell capabilities so wireless is all i have. Any suggestions on what to try from here?

WindowManager( 981): No lock screen!
WifiStateMachine( 981): releaseKeepaliveLock
PowerUI ( 1219): unknown intent: Intent { act=android.intent.action.ACTION_POWER_CONNECTED flg=0x8000010 }
ActivityManager( 981): Start proc com.android.settings for broadcast com.android.settings/.widget.SettingsAppWidgetProvider: pid=10619 uid=1000 gids={1015, 3002, 3001, 3003, 1028, 3007}
Trace (10619): error opening trace file: No such file or directory (2)
SurfaceFlinger( 798): Screen about to return, flinger = 0x4171daf0
LocalBluetoothProfileManager(10619): LocalBluetoothProfileManager construction complete
ActivityManager( 981): No longer want com.google.android.partnersetup (pid 3214): hidden #16
WifiHW ( 795): Failed to open wlan fw path param (No such file or directory)
SoftapController( 795): Softap fwReload - failed: -1
WifiStateMachine( 981): Failed to reload STA firmware java.lang.IllegalStateException: command '73 softap fwreload wlan0 STA' failed with '400 73 Softap operation failed (No such file or directory)'
CommandListener( 795): Failed to retrieve HW addr for wlan0 (No such device)
CommandListener( 795): Setting iface cfg
WifiStateMachine( 981): Unable to change interface settings: java.lang.IllegalStateException: command '75 interface setcfg wlan0 0.0.0.0 0 down' failed with '400 75 Failed to set address (No such device)'
wpa_supplicant(10653): rfkill: Cannot open RFKILL control device
wpa_supplicant(10653): Could not read interface wlan0 flags: No such device
wpa_supplicant(10653): WEXT: Could not set interface 'wlan0' UP
wpa_supplicant(10653): wlan0: Failed to initialize driver interface
WifiHW ( 981): Supplicant not running, cannot connect
WifiHW ( 981): Supplicant not running, cannot connect
WifiHW ( 981): Supplicant not running, cannot connect
WifiHW ( 981): Supplicant not running, cannot connect
WifiHW ( 981): Supplicant not running, cannot connect


So far other than the wifi and back button issues your rom runs like champ so I'm really hoping you can help me resolve this so I can keep it. If you need any other data or output let me know and I will provide it.

Thanks

#87 DmW

DmW

    Newbie

  • Jr. Member
  • Pip
  • 2 posts

Posted 08 November 2013 - 11:55 PM

Anyone?


Hi,
I have a Chinese tablet with the following specs.

Processor Manufacture: AllWinner
Processor Type: A13
Processor Main Frequency: 1.2GHZ
Hard Drive Capacity: 4GB
Memory Capacity: 512MB
Touch Screen Type: Capacitive Screen
Display resolution: 800x480
Feature: Wifi,3G,Webcams,Multi Touch,G Sensor,Camera,Phone Call
Place of Origin: Guangdong, China (Mainland)
Model Number: MC-C714
Nand Flash: Nand Flash
Wifi: 902.11b/g/n
Carema: Front camera, 1.3 Megapixels
LCD: 7 inch Capacitive Touch Screen LCD 16:9, 800x480

And the output of my lsmod , getevent and cat modules.

127|root@android:/ # lsmod
lsmod
8188eu 581030 0 - Live 0x00000000
stk831x 28705 0 - Live 0x00000000
device 27006 0 - Live 0x00000000
mg8696s 63962 0 - Live 0x00000000
rtl8150 10305 0 - Live 0x00000000
mcs7830 7581 0 - Live 0x00000000
qf9700 9152 0 - Live 0x00000000
asix 24601 0 - Live 0x00000000
sun5i_csi0 33868 1 - Live 0x00000000
gc0308 16888 1 - Live 0x00000000
videobuf_dma_contig 6243 1 sun5i_csi0, Live 0x00000000
videobuf_core 20242 2 sun5i_csi0,videobuf_dma_contig, Live 0x00000000
cedarx 11468 4 - Live 0x00000000
mali 114007 12 - Live 0x00000000
ump 34122 23 mali, Live 0x00000000
zet6221_SY713 18883 0 - Live 0x00000000
nand 126290 4 - Live 0x00000000

root@android:/ # getevent
getevent
add device 1: /dev/input/event3
name: "stk831x"
add device 2: /dev/input/event2
name: "zet6221-ts"
add device 3: /dev/input/event0
name: "sun4i-keyboard"
could not get driver version for /dev/input/mice, Not a typewriter
add device 4: /dev/input/event1
name: "axp20-supplyer"

root@android:/proc # cat modules
cat modules
8188eu 581030 0 - Live 0x00000000
stk831x 28705 0 - Live 0x00000000
device 27006 0 - Live 0x00000000
mg8696s 63962 0 - Live 0x00000000
rtl8150 10305 0 - Live 0x00000000
mcs7830 7581 0 - Live 0x00000000
qf9700 9152 0 - Live 0x00000000
asix 24601 0 - Live 0x00000000
sun5i_csi0 33868 0 - Live 0x00000000
gc0308 16888 1 - Live 0x00000000
videobuf_dma_contig 6243 1 sun5i_csi0, Live 0x00000000
videobuf_core 20242 2 sun5i_csi0,videobuf_dma_contig, Live 0x00000000
cedarx 11468 0 - Live 0x00000000
mali 114007 12 - Live 0x00000000
ump 34122 23 mali, Live 0x00000000
zet6221_SY713 18883 0 - Live 0x00000000
nand 126290 4 - Live 0x00000000
root@android:/proc #

Now thats been covered here is my problem. I pulled ver cm_a13_20130828, gapps and zet6221-ts. I followed procedure and booted up in CWM recovery, did a factory reset / erase then loaded the CM rom, gapps and my touchscreen file. Everything loaded and booted but when it came up i had lost the function of the h/w "back" button on the tablet. That I can live without using softkeys but then I noticed that my wireless would not turn on. I checked with logcat and this is what I am seeing over and over again. This tablet does not have bluetooth or cell capabilities so wireless is all i have. Any suggestions on what to try from here?

WindowManager( 981): No lock screen!
WifiStateMachine( 981): releaseKeepaliveLock
PowerUI ( 1219): unknown intent: Intent { act=android.intent.action.ACTION_POWER_CONNECTED flg=0x8000010 }
ActivityManager( 981): Start proc com.android.settings for broadcast com.android.settings/.widget.SettingsAppWidgetProvider: pid=10619 uid=1000 gids={1015, 3002, 3001, 3003, 1028, 3007}
Trace (10619): error opening trace file: No such file or directory (2)
SurfaceFlinger( 798): Screen about to return, flinger = 0x4171daf0
LocalBluetoothProfileManager(10619): LocalBluetoothProfileManager construction complete
ActivityManager( 981): No longer want com.google.android.partnersetup (pid 3214): hidden #16
WifiHW ( 795): Failed to open wlan fw path param (No such file or directory)
SoftapController( 795): Softap fwReload - failed: -1
WifiStateMachine( 981): Failed to reload STA firmware java.lang.IllegalStateException: command '73 softap fwreload wlan0 STA' failed with '400 73 Softap operation failed (No such file or directory)'
CommandListener( 795): Failed to retrieve HW addr for wlan0 (No such device)
CommandListener( 795): Setting iface cfg
WifiStateMachine( 981): Unable to change interface settings: java.lang.IllegalStateException: command '75 interface setcfg wlan0 0.0.0.0 0 down' failed with '400 75 Failed to set address (No such device)'
wpa_supplicant(10653): rfkill: Cannot open RFKILL control device
wpa_supplicant(10653): Could not read interface wlan0 flags: No such device
wpa_supplicant(10653): WEXT: Could not set interface 'wlan0' UP
wpa_supplicant(10653): wlan0: Failed to initialize driver interface
WifiHW ( 981): Supplicant not running, cannot connect
WifiHW ( 981): Supplicant not running, cannot connect
WifiHW ( 981): Supplicant not running, cannot connect
WifiHW ( 981): Supplicant not running, cannot connect
WifiHW ( 981): Supplicant not running, cannot connect


So far other than the wifi and back button issues your rom runs like champ so I'm really hoping you can help me resolve this so I can keep it. If you need any other data or output let me know and I will provide it.

Thanks



#88 gman0809

gman0809

    Newbie

  • Jr. Member
  • Pip
  • 5 posts

Posted 10 November 2013 - 09:08 AM

hi great rom love it but got 1 small problem no sound. plies help

i only got sound when i connect headphones

#89 AnonFBI

AnonFBI

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 68 posts

Posted 11 November 2013 - 11:57 PM

Anyone?




hi, try to copy and paste your backup wifi module, 8188eu.ko to cm10 into:

/system/lib/modules

set permissions to file 644 and try to turn on the wifi.

I hope this help you

Edited by AnonFBI, 11 November 2013 - 11:58 PM.


#90 Mythrall

Mythrall

    Newbie

  • Jr. Member
  • Pip
  • 3 posts

Posted 12 November 2013 - 10:35 AM

I've searched everywhere for a JellyBean ROM for the Allwinner A13.

Many thanks for all the hard work on this.

#91 gman0809

gman0809

    Newbie

  • Jr. Member
  • Pip
  • 5 posts

Posted 12 November 2013 - 11:48 PM

hi my problems is no camera no bluetoth, g-senser wrong way around and no sound.
plese help dont wont to loss this great rom and volume bottons doing wrong thinks

Edited by gman0809, 12 November 2013 - 11:49 PM.


#92 gman0809

gman0809

    Newbie

  • Jr. Member
  • Pip
  • 5 posts

Posted 13 November 2013 - 09:39 AM

soo i add my stock moduls and stuck tablet on boot cyanogenmod logo

#93 gman0809

gman0809

    Newbie

  • Jr. Member
  • Pip
  • 5 posts

Posted 13 November 2013 - 11:02 AM

hi ok i got my kernel but i dont know how to add them to the rom

#94 risheeb1002

risheeb1002

    Newbie

  • Jr. Member
  • Pip
  • 1 posts

Posted 24 November 2013 - 03:52 AM

hi i'm new to this so i dont know where to start. i have an a13 tab. i got abd shell and did lsmod :

rtk_btusb 14692 0 - Live 0xbf19b000
dmard06 12334 0 - Live 0xbf193000
stk8312 23957 0 - Live 0xbf188000
mma865x 9192 0 - Live 0xbf181000
mma7660 7959 0 - Live 0xbf17b000
rtl8150 10305 0 - Live 0xbf174000
mcs7830 7581 0 - Live 0xbf16e000
qf9700 9152 0 - Live 0xbf167000
asix 24601 0 - Live 0xbf15b000
sun5i_csi0 33493 0 - Live 0xbf14d000
gt2005 20254 0 - Live 0xbf144000
sp2518 17261 0 - Live 0xbf13b000
siv121d 17645 1 - Live 0xbf132000
gc0329 18140 0 - Live 0xbf129000
gc0308 19924 0 - Live 0xbf120000
videobuf_dma_contig 6251 1 sun5i_csi0, Live 0xbf11b000
videobuf_core 20242 2 sun5i_csi0,videobuf_dma_contig, Live 0xbf111000
cedarx 9351 0 - Live 0xbf10a000
mali 151020 6 - Live 0xbf0d8000
ump 49342 11 mali, Live 0xbf0c4000
sun4i_vibrator 2673 0 - Live 0xbf0c0000
ft5x_ts 45857 0 - Live 0xbf0af000
sichuang 16257 0 - Live 0xbf0a7000
gsl168x 51344 0 - Live 0xbf096000
gt910_ts 75189 0 - Live 0xbf07e000
gt811 16629 0 - Live 0xbf067000
pixcir_ts 23146 0 - Live 0xbf05c000
aw5306_ts 87483 0 - Live 0xbf040000
nand 225008 8 - Live 0xbf000000

pls help


sorry for being a noob :mellow:

#95 jeff reynold

jeff reynold

    Newbie

  • Jr. Member
  • Pip
  • 2 posts

Posted 04 December 2013 - 04:20 AM

sir which one do i download? there are 3 files. my tablet is allwinner a13. hardware sun5i, armv7l, ics

#96 gman0809

gman0809

    Newbie

  • Jr. Member
  • Pip
  • 5 posts

Posted 04 December 2013 - 08:53 AM

hi all need help i instal your rom all work but no sound camera bluetooth and my buttons dont work. i got stock rom if need that.
mxc622x 6160 1 - Live 0xbf0c3000
mecs 4078 2 - Live 0xbf0bf000
rtl8150 10305 0 - Live 0xbf0b8000
mcs7830 7581 0 - Live 0xbf0b2000
qf9700 9152 0 - Live 0xbf0ab000
asix 24601 0 - Live 0xbf09f000
sun5i_csi0 33255 0 - Live 0xbf091000
gc0308 18408 1 - Live 0xbf088000
camera 54418 0 - Live 0xbf075000
videobuf_dma_contig 6251 1 sun5i_csi0, Live 0xbf070000
videobuf_core 20242 2 sun5i_csi0,videobuf_dma_contig, Live 0xbf066000
sun4i_vibrator 2057 0 - Live 0xbf062000
cedarx 9351 0 - Live 0xbf05b000
mali 150748 8 - Live 0xbf029000
ump 49102 15 mali, Live 0xbf016000
ft5x_ts 61984 0 - Live 0xbf000000

#97 fotocreaman

fotocreaman

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 154 posts
  • LocationBelgium

Posted 06 December 2013 - 06:40 AM

I tried to install this rom, but was not able to get touchscreen to work. I tried many possible drivers. With the alternative gslx680 driver I have some reaction but the TS is mirrored (left is right and top is bottom) plus displaced. I get the tablet to work with FaaastJB 2.5 and coocked rom. Attached is lsmod and getevent. I also attach script.bin that work with these rom's. Can somebody help me.
I managed to get some more info. By using the tools from hereI inverted the Y axxis. Then I could activate in the developer settings the pointer location. I see that I have 2 touch points on both sides of my point location (about 2,5 cm to the left and right of the point). See attached screenshot. Any idea on how to solve this?

Attached Files


MID1024 running Namko's Jelly Bean

#98 Hammad9

Hammad9

    Newbie

  • Jr. Member
  • Pip
  • 1 posts

Posted 19 December 2013 - 04:23 PM

Hi,
First of all i would like to appreciate all your work. This is the first time i flashed a custom rom and first time ever i am posting on any forum so please excuse my stupid questions. I am using Prestigio Multipad Prime + (PMP3470B) I was able to install CWM and CyanogenMod 10 without a problem. Everything works except for the following:

Touchscreen
Camera
Volume Down Button

I tried almost everything you mentioned in the forum but nothing seems to working. May be i am doing something wrong ? i have also attached lsmod and getevent. Your help would be really appreciated thanks
Hammad

app_47@android:/ $ lsmod
8188eu 621096 0 - Live 0xbf103000
YFdecrypt 22118 0 - Live 0xbf0f8000
kt080x 5983 0 - Live 0xbf0f3000
mc32x0 7726 0 - Live 0xbf0ed000
dmt0567 10125 0 - Live 0xbf0e6000
bma250 7521 0 - Live 0xbf0e0000
byd693x_ts 9491 0 - Live 0xbf0d9000
pixcir_jc 13381 0 - Live 0xbf0d1000
sitronix_ts 23687 0 - Live 0xbf0c6000
goodix_gt82x 21242 0 - Live 0xbf0bc000
rtl8150 10305 0 - Live 0xbf0ab000
mcs7830 7589 0 - Live 0xbf0a5000
qf9700 9152 0 - Live 0xbf09e000
asix 24601 0 - Live 0xbf092000
usbnet 26253 3 mcs7830,qf9700,asix, Live 0xbf085000
sun5i_csi0 33604 0 - Live 0xbf077000
hi704 19664 1 - Live 0xbf06e000
hi253 21036 0 - Live 0xbf064000
videobuf_dma_contig 6251 1 sun5i_csi0, Live 0xbf05f000
videobuf_core 20242 2 sun5i_csi0,videobuf_dma_contig, Live 0xbf055000
cedarx 9479 0 - Live 0xbf04e000
mali 151198 4 - Live 0xbf01c000
ump 48898 13 mali, Live 0xbf009000
sw_ts 18329 0 - Live 0xbf000000
app_47@android:/ $


app_47@android:/ $ su
app_47@android:/ # getevent
add device 1: /dev/input/event2
name: "mc32x0"
add device 2: /dev/input/event3
name: "byd693x-ts"
add device 3: /dev/input/event0
name: "sun4i-keyboard"
could not get driver version for /dev/input/mice, Not a typewriter
add device 4: /dev/input/event1
name: "axp20-supplyer"

#99 aragorn

aragorn

    Newbie

  • Jr. Member
  • Pip
  • 1 posts

Posted 28 December 2013 - 04:32 PM

yest, I tried installing the CM10 on my allwinner a13 tablet - d2 pad. it installed fine but the touchscreen and gsensor is not working. I have my stock rom backed up. I tried patches that are here and made my own custom patches but nothing worked. So let me know how to fix these issues. thanks

I assuming my TS module is gsl1680 and gt811
Gsensor module = ecompass_data




here is my getevent info


add device 1: /dev/input/event4

name: "ecompass_data"

add device 2: /dev/input/event3

name: "gsl1680"

add device 3: /dev/input/event2

name: "gt811"

add device 4: /dev/input/event0

name: "sun4i-keyboard"

could not get driver version for /dev/input/mice, Not a typewriter

add device 5: /dev/input/event1

name: "axp20-supplyer"



here is lsmod info:

mxc622x 6088 1 - Live 0xbf123000

mecs 4078 1 - Live 0xbf11f000

rtl8150 10305 0 - Live 0xbf118000

mcs7830 7581 0 - Live 0xbf112000

qf9700 9152 0 - Live 0xbf10b000

asix 24601 0 - Live 0xbf0ff000

sun5i_csi0 33271 0 - Live 0xbf0f1000

gt2005 28142 0 - Live 0xbf0e5000

siv121d 14304 1 - Live 0xbf0dd000

videobuf_dma_contig 6251 1 sun5i_csi0, Live 0xbf0d8000

videobuf_core 20242 2 sun5i_csi0,videobuf_dma_contig, Live 0xbf0ce000

cedarx 9351 0 - Live 0xbf0c7000

mali 151020 6 - Live 0xbf095000

ump 49330 13 mali, Live 0xbf081000

gsl1680 94063 0 - Live 0xbf051000

pixcir_touch_811 21580 0 - Live 0xbf046000

gt811 17146 0 - Live 0xbf03d000

byd693x_ts 7326 0 - Live 0xbf02e000

zet622x 15814 0 - Live 0xbf025000

ssd253x_ts 21647 0 - Live 0xbf01b000

ft5x_ts 51435 6 gsl1680,pixcir_touch_811,gt811,byd693x_ts,zet622x,ssd253x_ts, Live 0xbf000000

Edited by aragorn, 29 December 2013 - 12:30 AM.


#100 Cleverson Gallego

Cleverson Gallego

    Newbie

  • Jr. Member
  • Pip
  • 6 posts

Posted 14 February 2014 - 04:20 PM

Hi, I have managed to install CM, however the touchscreen doesn't work. I have an Ainol Novo 7 Rainbow. I have tried installing the "gslx680" touchscreen module, but it still doesn't work.
I flashed the ROM
Flashed gapps
Then flashed gslx680 module
Then rebooted and the touchscreen didn't work

I think maybe because my device numbers and event numbers are different to yours. Here are the logs from ADB:

lsmod
mt7601Usta 1942052 1 - Live 0x00000000
mma7660 7248 0 - Live 0x00000000
device 26862 0 - Live 0x00000000
mtprealloc7601Usta 1628 1 mt7601Usta, Live 0x00000000 (P)
rtl8150 10305 0 - Live 0x00000000
mcs7830 7581 0 - Live 0x00000000
qf9700 9152 0 - Live 0x00000000
asix 24601 0 - Live 0x00000000
sun5i_csi0 34042 0 - Live 0x00000000
camera 53105 1 sun5i_csi0, Live 0x00000000
gc0308 16888 1 - Live 0x00000000
videobuf_dma_contig 6243 1 sun5i_csi0, Live 0x00000000
videobuf_core 20242 2 sun5i_csi0,videobuf_dma_contig, Live 0x00000000
cedarx 11869 0 - Live 0x00000000
mali 200007 65 - Live 0x00000000
ump 34213 17 mali, Live 0x00000000
gslX680 221847 0 - Live 0x00000000
gt811_ts 18280 0 - Live 0x00000000
sun4i_vibrator 2451 0 - Live 0x00000000
nand 225008 8 - Live 0x00000000

getevent
add device 1: /dev/input/event3
name: "mma7660"
add device 2: /dev/input/event2
name: "gslX680"
add device 3: /dev/input/event0
name: "sun4i-keyboard"
could not get driver version for /dev/input/mice, Not a typewriter
add device 4: /dev/input/event1
name: "axp20-supplyer"

I have since reinstalled the stock firmware, but would prefer to use CM. I would appreciate your help. Thanks!

Have you resolved this issue with rainbow? I would love to install cyannogen. Stock rom has a lot of performance issues.