Jump to content


Photo

Non-ugly market fix for GT78


  • Please log in to reply
29 replies to this topic

#1 clockworx

clockworx

    Advanced Member

  • Hero Member
  • PipPipPip
  • 1,351 posts

Posted 27 August 2010 - 05:02 PM

Based on the framework.jar provided by Mogrith, here's a non-ugly market fix for the Gentouch. Here's the PDN thread for more documentation:http://www.slatedroi...market-fix.html It should allow you to get your own Android ID, from Google, without any of that emulator mess. I have tested it after using my tablet a while, but it seems the most surefire usage is to have this installed as part of a clean install/wipe, before you start setting up your google acct. For whatever reason, people have had issues when they've had their tablet set up for a while and THEN try to use this...Android just refuses to send off to request a fresh Android ID, so again, I suggest this when starting from fresh.I unfortunately don't have a gentouch, so I can't test this. I suggest doing a backup of /system before installing, but I don't see any reasons it shouldn't work.Feel free to leave feedback.framework.jaror Hereframework.jarold jar file if you need it. framework-old.jar Rename it back to framework.jar

#2 manfly9884

manfly9884

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 107 posts

Posted 27 August 2010 - 05:41 PM

Trying this right now

#3 manfly9884

manfly9884

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 107 posts

Posted 27 August 2010 - 05:48 PM

Sorry. it did not work for me. Got eternal "starting download" :-(

#4 manfly9884

manfly9884

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 107 posts

Posted 27 August 2010 - 05:51 PM

Nan restoring as I write

#5 clockworx

clockworx

    Advanced Member

  • Hero Member
  • PipPipPip
  • 1,351 posts

Posted 27 August 2010 - 06:08 PM

Did you do it from a factory reset and set up your acct again? Did you check your android ID and if Talk works?Also, you can check logcat for a couple lines tagged CLOCKWORX to see if it is activating.

#6 manfly9884

manfly9884

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 107 posts

Posted 27 August 2010 - 06:49 PM

Sorry did not do it from factory reset. Will try again tomorrow...no time right now

#7 clockworx

clockworx

    Advanced Member

  • Hero Member
  • PipPipPip
  • 1,351 posts

Posted 28 August 2010 - 09:22 AM

Can someone test this following the proper directions specified in the OP? I'd like to know if it works for the GenTouch.

#8 cpg716

cpg716

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 246 posts

Posted 28 August 2010 - 09:54 AM

Doing so now.. CPG

#9 cpg716

cpg716

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 246 posts

Posted 28 August 2010 - 10:40 AM

WORKS!!!! Android ID was assigned on its own.. Did some test downloads and worked.. HOWEVER, with us a few downloads worked after the updates. So I will keep you updated after resets, etc... BUT.... an ANDROID ID was assigned without using the emulator, so thats a WIN.CPG

#10 clockworx

clockworx

    Advanced Member

  • Hero Member
  • PipPipPip
  • 1,351 posts

Posted 28 August 2010 - 10:41 AM

You mean "without using the emulator", right? Assuming it is working right....thanks for testing :)

#11 cpg716

cpg716

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 246 posts

Posted 28 August 2010 - 11:14 AM

[quote name='clockworx;46302]You mean "without using the emulator"' date=' right? Assuming it is working right....thanks for testing :D[/QUOTE']Lol. yeah, fixed it right after I wrote it.. you posted right away lol... Still working after a few resets...CPG

#12 cpg716

cpg716

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 246 posts

Posted 29 August 2010 - 03:53 PM

Seems to be working still. This may be our resolution also.CPG

#13 onihiro

onihiro

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 75 posts

Posted 29 August 2010 - 04:00 PM

lets hope so

#14 manfly9884

manfly9884

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 107 posts

Posted 30 August 2010 - 04:35 PM

Hi all. Quick question. If I do the factory reset. Will this erase all the updates?, causing me to redo all of them again?Thanks in advance

#15 cpg716

cpg716

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 246 posts

Posted 02 September 2010 - 07:28 PM

Just so everyone is aware, this does work, follow the instructions in the original post and you will have the Android Market on your GT78.CPG

#16 jdelgado

jdelgado

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 51 posts

Posted 03 September 2010 - 07:19 AM

Hi guys,Will this give you a 2.1 market ? Or will it give you a 1.6. I have the market working but it is the 1.6 using the emulator. I'll be curious to see if this will give me a 2.1 market.Thanksjdelgado

#17 linckraker

linckraker

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 85 posts

Posted 04 September 2010 - 02:20 AM

Can anyone else confirm that this is working?@CPG is it still working?

#18 cpg716

cpg716

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 246 posts

Posted 04 September 2010 - 10:05 AM

Can anyone else confirm that this is working?@CPG is it still working?

Yes sir, still working... CPG

#19 sifon187

sifon187

    Advanced Member

  • Hero Member
  • PipPipPip
  • 460 posts

Posted 04 September 2010 - 11:14 AM

I have a problem, every time I apply this fix and reboot, my gt hangs at the duck bill paltapuss guy. Now I have not done a factory reset before attempting the fix, is this the cause for the hang?

#20 cpg716

cpg716

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 246 posts

Posted 04 September 2010 - 11:30 AM

[quote name='sifon187;51111]I have a problem' date=' every time I apply this fix and reboot, my gt hangs at the duck bill paltapuss guy. Now I have not done a factory reset before attempting the fix, is this the cause for the hang?[/QUOTE']Apply which update? This is changing out a file, not applying an update.. which are you meaning?CPG