Jump to content


Photo

How to up- or downgrade your Onda V812.


  • Please log in to reply
10 replies to this topic

#1 janesh

janesh

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 436 posts
  • Locationthe netherlands

Posted 19 January 2013 - 07:23 AM

First Install PhoenixSuit and normally the right drivers will be installed during this procedure.

When done this, run PhoenixSuit, and you will see 'no device attached yet'.

Load the firmware, image, of your choice in the PhoenixSuite.

Power off your Allwinner A31 device.

Press 'home' button and keep pressing when you connect your powered off device by usb, with your computer.

Done this still pressing the 'home' button, press and release short, three times the power button, now you see a screen popped up, asking you what you want, 'ýes' for format upgrade mode, and 'no' for normal (recommend) upgrade mode.
Now you can release the home button

At last click 'yes' or 'no' and you will see starting the up- or downgrading process, wait patiently till this is done.
When your device does not boot automatically, just press the power button.
  • jahras likes this
On order, nothing, and am i am finished with Chinese cpu's, i prefer my exynos devices.
Favorites, in order of use, Samsung galaxy note 8 inch, Ramos W42, Ployer Momo11 quad exynos 4412.
Sold last months, PiPo U1, Teclast P85, PiPo S2, Teclast P85HD, Cube mini U30GT, Yuandao Vido N80IPS, Ainol Novo 10 Hero ii: very bad, Ployer Momo12, Onda V812, Yuandao Vido N80 RK3188, Teclast P88, Google Nexus 7-8Gb, PiPo M8pro RK3188, Chuwi V88 RK3188, Samsung galaxy tab 7.7, Ployer Momo8 IPS, Yuandao Window N70, BB playbook.
And: You know we all became mathematicians for the same reason: we were lazy.

#2 Icarus Greed

Icarus Greed

    Newbie

  • Jr. Member
  • Pip
  • 7 posts

Posted 19 January 2013 - 10:26 AM

okay. Here's what I did.

I install the phoneix suit
Plug the tablet in the computer while it is in USB debugging mode
Phonenix will recognize the tablet at the first tag and show that the tablet is attached
Then go to the second tag called "firmware" and do the last thing normally
The tablet will auto restart

#3 kodro

kodro

    Member

  • Jr. Member
  • PipPip
  • 17 posts

Posted 21 January 2013 - 09:56 AM

anyone knows if the phoenix suite will install correctly in Vista64?
or is it XP and Win7/8 only?

#4 jahras

jahras

    Member

  • Jr. Member
  • PipPip
  • 21 posts

Posted 24 January 2013 - 09:54 PM

Janesh, very useful info here. One question, is there an English version of phoenix?

#5 janesh

janesh

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 436 posts
  • Locationthe netherlands

Posted 25 January 2013 - 10:58 AM

Kodro, i istalled PhoenixSuite on a vista enterprise 32 bit computer without any problem, after that i perfect upgraded the Onda V812 on this computer.
After that i did the same on a XP enterprice machine, also without any issues.
Normally i am using a windows 8 pro computer to do this.

jahras, thanks for your support, the PhoenixSuite is only in chinese whwn you install it, when you are running the Suite, its in english.
On order, nothing, and am i am finished with Chinese cpu's, i prefer my exynos devices.
Favorites, in order of use, Samsung galaxy note 8 inch, Ramos W42, Ployer Momo11 quad exynos 4412.
Sold last months, PiPo U1, Teclast P85, PiPo S2, Teclast P85HD, Cube mini U30GT, Yuandao Vido N80IPS, Ainol Novo 10 Hero ii: very bad, Ployer Momo12, Onda V812, Yuandao Vido N80 RK3188, Teclast P88, Google Nexus 7-8Gb, PiPo M8pro RK3188, Chuwi V88 RK3188, Samsung galaxy tab 7.7, Ployer Momo8 IPS, Yuandao Window N70, BB playbook.
And: You know we all became mathematicians for the same reason: we were lazy.

#6 befa34

befa34

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 71 posts

Posted 25 January 2013 - 11:19 AM

infos Backup ROM:

http://www.androidta...xplorer-24.html
French (Montpllier)

#7 Geo602

Geo602

    Newbie

  • Jr. Member
  • Pip
  • 1 posts

Posted 20 February 2013 - 03:22 PM

hi i got my onda v812 last week, but the other day it wouldn't work it just stays at the boot up screen with the animated bubbles about the device. is there a way past it!?

#8 befa34

befa34

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 71 posts

Posted 21 February 2013 - 05:25 AM

Very simple TUTO:
http://translate.goo...fcde4f&t=552863

su
dd if=/mnt/sdcard/cwm_v99.img of=/dev/block/nandg


I can backup ... my firmware/rom ... ;-)



YOU can backup you rom with CWM (in recovery)
French (Montpllier)

#9 zer0mode-ax

zer0mode-ax

    Newbie

  • Jr. Member
  • Pip
  • 2 posts

Posted 23 February 2013 - 01:56 AM

Hello all

I'm trying something similar to /dev/block/nandc with this tut.
http://android-dls.c...ack_Boot_Images

Everything is fine except for the part

flash_image boot /sdcard/image.img ---> NOT OK
error scanning partitions: No such file or directory

im trying with fastboot but command dont exist

cat /proc/mtd ----> File not exist but there is something else i found

# mount point fstype device device2
/bootloader vfat /dev/block/nanda
/env emmc /dev/block/nandb
/boot emmc /dev/block/nandc
/system ext4 /dev/block/nandd
/data ext4 /dev/block/nande
/misc emmc /dev/block/nandf
/recovery ext4 /dev/block/nandg
/cache ext4 /dev/block/nandh
/sdcard vfat /dev/block/mmcblk0p1 /dev/block/nandj

I have concluded that there is no mount_point who exist /boot nor /misc nor /env .... using emmc fsys

I try this...
After unpacking/packing ramdisk and kernel without any changes into ramdisk folder...
File size of original and recompiled image is equal 16MB but little difference in ~10b

adb push image.img /sdcard/image.img
adb shell su -c "cat /dev/null > /dev/block/nandc"
adb shell su -c "cat /sdcard/image.img > /dev/block/nandc"
adb shell su -c "sync"

Reboot device....
Device stuck up on first logo (Core 4) :(

now im tried wipe image and fill with content without unpacking/packing
adb shell su -c "cat /dev/block/nandc > /sdcard/image.img"
adb shell su -c "cat /dev/null > /dev/block/nandc"
adb shell su -c "cat /sdcard/image.img > /dev/block/nandc"
adb shell su -c "sync"

Reboot device....
Everithing OK

Is there any chance that the problem is in the process of unpacking/packing or something else i dont understand ???

#10 doctor33

doctor33

    Newbie

  • Jr. Member
  • Pip
  • 1 posts

Posted 09 April 2013 - 11:05 AM

hello everyone, i'm new here. i have a broblem with my pc (window 7)not recognizing my onda v812 and hence i can't upgrade to fw v 2.0/ anyone have a solution. thanks.

#11 rob14

rob14

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 34 posts
  • Locationphilippines

Posted 25 April 2013 - 02:34 AM

im trying to upgrade my firmware from 1.33v to 1.35 bvut after installation of phoenix suites my pc did not recognized my tab i used xp and windows 7 can you help me im very frustrated
I can do all things thru CHRIST who strengthens me Phil. 4:13