Jump to content


Photo

[FIX] Windows 7 not recognizing new USB devices after installing tablet drivers


  • Please log in to reply
2 replies to this topic

#1 Aquous

Aquous

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 115 posts

Posted 29 December 2012 - 02:17 PM

Ever since I installed the drivers for my Elf, my Windows 7 PC hasn't worked properly. It would ask for drivers for every new device that was plugged in, even for those devices that it already had the drivers for, such as simple USB sticks or my keyboard and mouse (if I removed them from device manager they wouldn't work again, not even after a reboot)! After a long and painstaking debugging process, I figured out the culprit: my crappy Chinese tablet. Or rather, it was the drivers I used for it - be it the PDAnet, LiveSuit, or Tasselhoff drivers, they all caused my USB subsystem to be permanently screwed up.

In this post I will share what I had to do in order to both have USB working normally and be able to use my tablet. You may or may not find this post useful if you are having USB issues, and following the instructions here may or may not work for you. All standard disclaimers apply.

Requirements: you must have the Android SDK installed with the Google USB driver component checked.
  • Disconnect your tablet and uninstall all driver software (e.g. PDAnet) you have installed.
  • Open up a command prompt with administrative privileges and enter these two commands:
    set devmgr_show_nonpresent_devices=1
    start devmgmt.msc
  • The Device Manager will pop up. Click View->Show hidden devices.
  • Now uninstall all grayed out devices from the following device groups (translating here so the names might be a bit off):
    • Android USB Devices
    • Universal Serial Bus controllers
    • (Optional - not necessary but if you're obsessed with starting from a perfectly clean slate:) Portable Devices, Disk Drives, Disk Devices
  • Reconnect your tablet. Windows should search for drivers, and fail.
  • Double click the Unknown Device that's popped up in Device Manager. Mine was called simply 'Android'. If the tabs are grayed out, give it a minute to finish failing. Now go to Driver -> Update and choose 'Search on my computer' followed by 'Let me choose manually'. Click Next when it's finished loading the long and uninteresting list of driver categories.
  • You do NOT want to install Google's driver now. Instead, browse the list and search for 'Composite USB device'. For me it was the third item from the left menu, followed by the first item from the right menu. Unfortunately my Windows isn't English, so no screenies :(
  • Force install the driver against all that Windows advices.
  • Hey presto! Suddenly a lot more devices are appearing! Your tablet is now exporting its SD card interfaces, which are installed automatically, and there's yet another 'Unknown Device' that Windows can't find drivers for.
  • This time, tell Windows you're going to install the drivers yourself, but at the screen where you have to select the driver, don't pick Composite USB Device this time, but rather click 'Browse' and point it to Google's driver files. For me, that driver was at %USERPROFILE%\ADT\sdk\extras\google\usb_driver\android_winusb.inf
  • Now pick the driver 'Android ADB Device'
  • You're done! Now your tablet works perfectly, both with ADB and with mass storage, and Windows's USB subsystem is NOT screwed up this time! :)

I hope this little tutorial helps anyone else who is beating themselves up over this. ;)

Edited by Aquous, 29 December 2012 - 02:19 PM.


#2 brand19

brand19

    Newbie

  • Jr. Member
  • Pip
  • 8 posts

Posted 16 April 2013 - 07:38 PM

Very helpful tread . Thanks

#3 Victorious1

Victorious1

    Member

  • Jr. Member
  • PipPip
  • 16 posts

Posted 19 July 2013 - 03:35 PM

This post and advice was extremely helpful to me and it solved my problem completely, as well as, teaching me how to make my computer work better. Thank you, thank you, thank you Aquous. :yahoo: