Jump to content


Photo

Pipo M2 Charging Issue


  • Please log in to reply
12 replies to this topic

#1 rhazes

rhazes

    Newbie

  • Jr. Member
  • Pip
  • 5 posts

Posted 30 October 2012 - 03:08 AM

hi there everybody got some problem with my new bought pipo M2, on a trip on china i've decided to buy a pipo m2 since the feedbacks i've readt on this forum - and everywhere else where positive - but now that i'm using it , first when plugged to the charger it don't indicate that it's plugged to a charger but it say battery full at 100% and when i unplugg the charger it simply turn off
so can you tell me please if there's some people in the same situation as me ,if it's a soft or hardware problem and if there's a solution

thanks for your advices and sorry for my bad english :D

#2 nikro56

nikro56

    Newbie

  • Jr. Member
  • Pip
  • 2 posts

Posted 30 October 2012 - 07:19 AM

I had the same problem... my pipo m2 came with a 5V / 2.5A charger, and it need a 9V charger.
I bought a 9V / 1.5A charger and now it works.

Sorry for my english too!

#3 rhazes

rhazes

    Newbie

  • Jr. Member
  • Pip
  • 5 posts

Posted 31 October 2012 - 05:05 AM

indeed i've bought a new 9 v charger and it's ok , the only thing is that when i plugg it when the tab is off nothing happen but when i plugg it when the tab is on i have the indicator that the tab is charging so i turn the tab on the standby mode and charge it ....so it seem fine

thanks nikro for your fast reply , i really appreciate it , btw , can you share with me your feedback and impression of this tab?

waiting for your reply

#4 rhazes

rhazes

    Newbie

  • Jr. Member
  • Pip
  • 5 posts

Posted 31 October 2012 - 12:04 PM

just another question to ask about . even if i let my tab charging all night long , the battery gauge still stick to 99% and it never show 100% is it okay? i mean is it due to the fact that it's only my 2nd charging or is there another problem and is there a solution to 100% charge my battery? thanks for the replies

#5 nikro56

nikro56

    Newbie

  • Jr. Member
  • Pip
  • 2 posts

Posted 31 October 2012 - 04:01 PM

I own it for 10 days and i searched at least 3 days why my pipo m2 does not charge... so i can't give you interesting feedback.
I mainly use it for reading comics in my bed (Pipo m2 is awesome for that, better than my ex 16/10 Acer A510) ... i also watch 1 movie without problem.
The only major issue i encountered was an incompatibility with a Sandisk 32Gb class 10 sdcard. Putting an other sdcard solve the problem.

I disabled chineese bloatware and installed an other launcher (apex) because i use it on all my android devices.

Battery life isn't as good as A510 one but for half price, i won't cry.

I hope you are not french, because it's my mother language and i make a big effort to write this post...

#6 Maxx007

Maxx007

    Newbie

  • Jr. Member
  • Pip
  • 2 posts

Posted 02 November 2012 - 08:13 AM

Hello everyone! I'm new and I apologize for my English. I'm about to buy a 3G Pipo M2 someone was able to test it?

#7 PIPOUSER

PIPOUSER

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 54 posts

Posted 02 November 2012 - 01:06 PM

just another question to ask about . even if i let my tab charging all night long , the battery gauge still stick to 99% and it never show 100% is it okay? i mean is it due to the fact that it's only my 2nd charging or is there another problem and is there a solution to 100% charge my battery? thanks for the replies

I have posted several times regarding battery % drop on my PIPO M1. I tried a USB charging dock (with 2.5mm end power plug) and it charged to 100% OK overnight, but on unplugging, shot down to 60%. With the standard charger it goes to 99% and usually no further. On unplugging it drops fairly quickly with use, then stabilises at lower % values. Recently, I left it on charge and it reached 100% and "fully charged" after another 2-3 hours. That extra 1% made a huge difference - with constant use it dropped much more gradually. I have deliberately not left it on charge overnight, but would suggest that you try to charge in the day to 99% then leave it for a few more hours and see if it reaches 100%. I will now only use the supplied charger with this tablet due to bad experiences regarding battery drop with two other chargers (the USB one is routinely used with my MOMO7 tablet).

#8 arolas

arolas

    Newbie

  • Jr. Member
  • Pip
  • 3 posts

Posted 21 November 2012 - 08:47 AM

Hello, today I got my "PiPo M2 3G". Unfortunately the german customs, in addition to 40€ import tax, did not allow to import the charger because it is apparently not CE marked…

Can anyone please tell me the data of the charger? Output voltage (V), output current (mA) and plug (mm)?


I am looking forward to share my experience with the tablet, if I will be able to charge and use it ...
Thanks

#9 PIPOUSER

PIPOUSER

    Advanced Member

  • Jr. Member
  • PipPipPip
  • 54 posts

Posted 21 November 2012 - 11:05 AM

Hello, today I got my "PiPo M2 3G". Unfortunately the german customs, in addition to 40€ import tax, did not allow to import the charger because it is apparently not CE marked…

Can anyone please tell me the data of the charger? Output voltage (V), output current (mA) and plug (mm)?


I am looking forward to share my experience with the tablet, if I will be able to charge and use it ...
Thanks

My PIPO is the M1 - assuming that the charger is the same as the M2, the supplied charger says: 100 - 240V ~ 0.5A, DC 5V 2.5A or less sign, The rest of the writing is in Chinese. Hope that this helps.

#10 arolas

arolas

    Newbie

  • Jr. Member
  • Pip
  • 3 posts

Posted 22 November 2012 - 10:11 AM

My PIPO is the M1 - assuming that the charger is the same as the M2, the supplied charger says: 100 - 240V ~ 0.5A, DC 5V 2.5A or less sign, The rest of the writing is in Chinese. Hope that this helps.


Thanks. Meanwhile i got this information from TLW002: 9V, 2.5A
i ordered this universal charger and hope one the tiny plugs matches...

#11 bluedragon24

bluedragon24

    Newbie

  • Jr. Member
  • Pip
  • 8 posts

Posted 29 November 2012 - 06:02 PM

Hello, today I got my "PiPo M2 3G". Unfortunately the german customs, in addition to 40€ import tax, did not allow to import the charger because it is apparently not CE marked…

Can anyone please tell me the data of the charger? Output voltage (V), output current (mA) and plug (mm)?


I am looking forward to share my experience with the tablet, if I will be able to charge and use it ...
Thanks


HI, MY PIPO Mix M2 CHARGER IS 9VDC, 2.5A, it charges the battery to 100% in three hours. Excellent performance.

#12 bluedragon24

bluedragon24

    Newbie

  • Jr. Member
  • Pip
  • 8 posts

Posted 29 November 2012 - 06:04 PM

Hello, today I got my "PiPo M2 3G". Unfortunately the german customs, in addition to 40€ import tax, did not allow to import the charger because it is apparently not CE marked…

Can anyone please tell me the data of the charger? Output voltage (V), output current (mA) and plug (mm)?


I am looking forward to share my experience with the tablet, if I will be able to charge and use it ...
Thanks


HI, MY PIPO Mix M2 CHARGER IS 9VDC, 2.5A, it charges the battery to 100% in three hours. Excellent performance.

#13 DrJekyll123

DrJekyll123

    Newbie

  • Jr. Member
  • Pip
  • 1 posts

Posted 30 November 2012 - 09:08 PM

I'm having a similar problem with a PIPO M3.

When it's plugged into the charger, it seems like it's charging, well the battery % is constantly increasing anyway. The problem is that the second I take it off the charge, the tablet turns off and when turned back on the charge % is back at 1%.

My charger is 9V and 2.5A, but I'm having to use a travel adapter to convert the Chinese plug into the UK type, this adapter takes 13A and 250V, could that be having an effect on the battery not holding the charge?